Windsheild Washer fluid pump? - Page 2 - Mercedes-Benz Forum
Reply
 
LinkBack Thread Tools Display Modes
post #11 of 13 (permalink) Old 09-25-2011, 10:36 AM
BenzWorld Junior Member
 
Date registered: Jul 2005
Vehicle: 1996 C280
Location: Atlanta, GA
Posts: 16
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
I am getting fluid to the spray nozzles - it gushes out when I disconnect the hoses from the nozzles and turn the pump on. Does anybody know what the purpose of the wires that go to each spray nozzle? Is there some electronic control for each nozzle?
timberleaf is offline  
Sponsored Links
Advertisement
 
post #12 of 13 (permalink) Old 09-25-2011, 10:54 AM
BenzWorld Elite
 
xvvvz's Avatar
 
Date registered: Sep 2006
Vehicle: '99 2.3L Kompressor
Location: Atlanta, GA
Posts: 1,944
Mentioned: 0 Post(s)
Quoted: 1 Post(s)
They are heated so they don't freeze in the winter.

It sound like yours are clogged. Time to clean them out or buy some new ones?
xvvvz is offline  
post #13 of 13 (permalink) Old 08-31-2014, 10:59 AM
BenzWorld Junior Member
 
cabinet's Avatar
 
Date registered: Nov 2010
Vehicle: 2010 ML 350
Location: New Jersey, USA
Posts: 44
Mentioned: 0 Post(s)
Quoted: 13 Post(s)
Quote:
Originally Posted by n0alpha View Post
The part number is 2028690121 and it's about $18 US from Auto Parts at AutohausAZ - OEM Auto Parts - Discount Replacement Parts, Resources and Car Care Tips and they do ship to Canada. Great site, I've bought lots of stuff there.
Hello..... it seems there are two pumps on my ML320 washer fluid reservoir. Any reason? Is one for the rear ? They look the same. The connector on the one that leads to the windshield is getting power, so the pump is bad. Thanks.
cabinet is offline  
Sponsored Links
Advertisement
 
Reply

  Mercedes-Benz Forum > Mercedes-Benz Sedan Forums > W202 C-Class

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Mercedes-Benz Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in











Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Topic Author Forum Replies Last Post
Windsheild washer/wipers not responding + rear mirror LED quepao W163 M-Class 3 11-06-2006 12:15 PM
Rear Windsheild washer.... dewdaltz W163 M-Class 4 10-11-2006 04:57 PM
washer fluid pump 95 S320 bc2885 W140 S-Class 5 01-04-2005 04:49 PM
Washer/Wiper fluid pump does not work 400SEL W140 S-Class 1 12-22-2003 04:50 AM
Windshield washer fluid pump/leak Guest (MBNZ) W124 E,CE,D,TD Class 1 07-25-2002 07:18 PM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 

Title goes here

close
video goes here
description goes here. Read Full Story
For the best viewing experience please update your browser to Google Chrome