Bad climate control switch or bad vacuum switchover valve - Mercedes-Benz Forum
 
LinkBack Thread Tools Display Modes
post #1 of 1 (permalink) Old 10-13-2004, 09:21 PM Thread Starter
BenzWorld Junior Member
 
Date registered: Aug 2004
Posts: 16
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
(Thread Starter)
Bad climate control switch or bad vacuum switchover valve

When my 84 190D is running I can hear a clicking sound coming from my vacuum switchover valve that is behind the pass. vent. The clicking sound will go on for some time. the clicking is not when I am switching the climate control switch. It does it on it's own. It will click for a few seconds then stop then it will come back. If anyone has any ideas please respond.
jwht is offline  
Sponsored Links
Advertisement
 
Reply

  Mercedes-Benz Forum > Mercedes-Benz Sedan Forums > W201 190-Class

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Mercedes-Benz Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in











Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 

Title goes here

close
video goes here
description goes here. Read Full Story
For the best viewing experience please update your browser to Google Chrome