Oil change mistake - Mercedes-Benz Forum
 
LinkBack Thread Tools Display Modes
post #1 of 4 (permalink) Old 06-12-2019, 08:31 PM Thread Starter
BenzWorld Newbie
 
Date registered: Jun 2019
Vehicle: 2013 ml250
Location: Au
Posts: 1
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Send a message via Skype™ to ROSCOYANDLE@BIGPOND.COM
(Thread Starter)
Oil change mistake

I found out that the local MB dealer neglected to replace the centre spigot that goes inside the oil filter last oil change
I am concerned that this would allow the oil to bypass the filter and damage the engine
Does anyone know about this
Sponsored Links
Advertisement
 
post #2 of 4 (permalink) Old 06-13-2019, 02:47 AM
BenzWorld Extremist
 
plinker17722's Avatar
 
Date registered: Mar 2015
Vehicle: 1989 W124 260E
Location: Kidderminster in Worcestershire
Posts: 807
Mentioned: 2 Post(s)
Quoted: 161 Post(s)
Garage
I would just replace it .You do have a strainer in the sump to look after particles that get past your main filter .But if its only been short time that its been like this it wont be a problem .
plinker17722 is offline  
post #3 of 4 (permalink) Old 06-13-2019, 03:14 AM
Lifetime Premium Member
 
mattml430's Avatar
 
Date registered: Sep 2008
Vehicle: 2000 ML55 sold😢 2013 ML500,😁 2015 C250 estate wagon, 1927 Dodge 4 sedan, 1929 Dodge
Location: Melbourne Australia
Posts: 4,404
Mentioned: 4 Post(s)
Quoted: 807 Post(s)
Lifetime Premium Member
Its probably not optimal but it will just mean the oil wont be filtered. It may also mess with the oil flow and pressure a little.more flow and less pressure. How many miles have you done since the service.


Sent from my iPhone using Tapatalk
mattml430 is offline  
Sponsored Links
Advertisement
 
post #4 of 4 (permalink) Old 06-13-2019, 04:08 AM
Lifetime Premium Member
 
jaymaynard's Avatar
 
Date registered: Mar 2013
Vehicle: 2015 ML250 Bluetec, 62K miles; 1987 560SL, 121K miles
Location: Fairmont, Minnesota, USA
Posts: 3,546
Mentioned: 9 Post(s)
Quoted: 719 Post(s)
Lifetime Premium Member
It's not going to be catastrophic as long as it's fixed promptly. The interesting question is just how in he hell did the dealer not put that part back in?! I'd be asking very pointed questions.

"Engineered like no other car in the world." That's both a bug and a feature.
jaymaynard is offline  
Sponsored Links
Advertisement
 
Reply

  Mercedes-Benz Forum > Mercedes-Benz Vans/Trucks/SUV/Others > W166 M-Class / GLE-Class

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Mercedes-Benz Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in











Currently Active Users Viewing This Thread: 2 (1 members and 1 guests)
B&kML350
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 

Title goes here

close
video goes here
description goes here. Read Full Story
For the best viewing experience please update your browser to Google Chrome