P205C HELP!!!! - Mercedes-Benz Forum
 
LinkBack Thread Tools Display Modes
post #1 of 4 (permalink) Old 06-11-2019, 10:02 AM Thread Starter
BenzWorld Junior Member
 
Date registered: Feb 2019
Posts: 11
Mentioned: 0 Post(s)
Quoted: 6 Post(s)
(Thread Starter)
P205C HELP!!!!

My check engine light came on today, and the engine is smoking like white shit, any news about this code, I checked online and shows DEF tank replacement
gramen is offline  
Sponsored Links
Advertisement
 
post #2 of 4 (permalink) Old 06-11-2019, 10:26 AM
Supporting Vendor
 
AutohausAZ's Avatar
 
Date registered: Dec 2004
Vehicle: Too Many to List
Location: Phoenix, Arizona
Posts: 168
Mentioned: 3 Post(s)
Quoted: 31 Post(s)
"Code P205C means an insufficient degree of voltage in the reductant tank temperature sensor circuit." Might need a new DEF heating assembly.

Visit the AutohausAZ Vendor Section for special pricing for Benzworld members:
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
!
AutohausAZ is offline  
post #3 of 4 (permalink) Old 06-11-2019, 01:13 PM Thread Starter
BenzWorld Junior Member
 
Date registered: Feb 2019
Posts: 11
Mentioned: 0 Post(s)
Quoted: 6 Post(s)
(Thread Starter)
Can you please provide me with a link how does the part looks like?
gramen is offline  
Sponsored Links
Advertisement
 
post #4 of 4 (permalink) Old 06-11-2019, 09:02 PM
BenzWorld Veteran
 
WE47B1ME's Avatar
 
Date registered: Sep 2014
Vehicle: 2015 ML250 BluTec, 2002 ML 500 Sport Edition (Sold :(), 2012 C250
Location: Los Angeles, CA
Posts: 745
Mentioned: 0 Post(s)
Quoted: 224 Post(s)
Quote:
Originally Posted by gramen View Post
My check engine light came on today, and the engine is smoking like white shit, any news about this code, I checked online and shows DEF tank replacement
Assume you're talking about a w166, but your profile is missing your vehicle.

Sent from my BlackBerry Key2 using Tapatalk
WE47B1ME is offline  
Sponsored Links
Advertisement
 
Reply

  Mercedes-Benz Forum > Mercedes-Benz Vans/Trucks/SUV/Others > W166 M-Class / GLE-Class

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Mercedes-Benz Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in











Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 

Title goes here

close
video goes here
description goes here. Read Full Story
For the best viewing experience please update your browser to Google Chrome