2014 ML 350 BlueTec Pre Safe Functions Limited - Mercedes-Benz Forum
Reply
 
LinkBack Thread Tools Display Modes
post #1 of 11 (permalink) Old 02-03-2019, 04:54 PM Thread Starter
BenzWorld Junior Member
 
Date registered: Feb 2019
Posts: 11
Mentioned: 0 Post(s)
Quoted: 6 Post(s)
(Thread Starter)
2014 ML 350 BlueTec Pre Safe Functions Limited

I got the sign saying Pre Safe Functions Limited on the dashboard, I did wash my car and all the sensors but the sign didn’t go away, did anyone else had the same problem and If yes how did you fix It, thank you!
gramen is offline  
Sponsored Links
Advertisement
 
post #2 of 11 (permalink) Old 02-03-2019, 10:01 PM
BenzWorld Veteran
 
WE47B1ME's Avatar
 
Date registered: Sep 2014
Vehicle: 2015 ML250 BluTec, 2002 ML 500 Sport Edition (Sold :(), 2012 C250
Location: Los Angeles, CA
Posts: 749
Mentioned: 0 Post(s)
Quoted: 227 Post(s)
Quote:
Originally Posted by gramen View Post
I got the sign saying Pre Safe Functions Limited on the dashboard, I did wash my car and all the sensors but the sign didnít go away, did anyone else had the same problem and If yes how did you fix It, thank you!
You need to scan the truck and see what comes back. Did you high pressure it? Could have dislodged a sensor wire.

Sent from my BlackBerry Key2 using Tapatalk
WE47B1ME is online now  
post #3 of 11 (permalink) Old 02-04-2019, 12:36 AM
Lifetime Premium Member
 
mattml430's Avatar
 
Date registered: Sep 2008
Vehicle: 2000 ML55 sold😢 2013 ML500,😁 2015 C250 estate wagon, 1927 Dodge 4 sedan, 1929 Dodge
Location: Melbourne Australia
Posts: 4,365
Mentioned: 4 Post(s)
Quoted: 795 Post(s)
Lifetime Premium Member
Scanning it may help point you in the rite direction to finding a plug that is full of water. You might have to pull a view apart and let them dry out and then spray some CRC electrical contact cleaner in them. It evaporates and leaves them clean and dry.


Sent from my iPhone using Tapatalk
mattml430 is offline  
Sponsored Links
Advertisement
 
post #4 of 11 (permalink) Old 02-04-2019, 12:22 PM Thread Starter
BenzWorld Junior Member
 
Date registered: Feb 2019
Posts: 11
Mentioned: 0 Post(s)
Quoted: 6 Post(s)
(Thread Starter)
It was a rainy day and I drove into a big hole with water so after that the sign came on, so maybe sensor wires are wet but I’ll scan and see what It says, my mechanic didn’t seem interested helping me out he just said that doesn’t know anything about that
gramen is offline  
post #5 of 11 (permalink) Old 02-04-2019, 05:23 PM
BenzWorld Veteran
 
WE47B1ME's Avatar
 
Date registered: Sep 2014
Vehicle: 2015 ML250 BluTec, 2002 ML 500 Sport Edition (Sold :(), 2012 C250
Location: Los Angeles, CA
Posts: 749
Mentioned: 0 Post(s)
Quoted: 227 Post(s)
Quote:
Originally Posted by gramen View Post
It was a rainy day and I drove into a big hole with water so after that the sign came on, so maybe sensor wires are wet but Iíll scan and see what It says, my mechanic didnít seem interested helping me out he just said that doesnít know anything about that
First you said you washed your car, now you're saying you drove into a big puddle? And you already took to a mechanic but they didn't want to charge you for "diagnosing"? I don't know if this testimony would hold up in court
WE47B1ME is online now  
post #6 of 11 (permalink) Old 02-04-2019, 06:42 PM Thread Starter
BenzWorld Junior Member
 
Date registered: Feb 2019
Posts: 11
Mentioned: 0 Post(s)
Quoted: 6 Post(s)
(Thread Starter)
I said I did wash my car and all the sensors before someone tells me “ take all the dirt from the sensors” I did everything possible what I saw online, but the problem occurred when I drove into the puddle which I didn’t want to believe that a $70K car would give me that trouble just because I drove on a water puddle.
gramen is offline  
post #7 of 11 (permalink) Old 02-04-2019, 08:56 PM
BenzWorld Veteran
 
WE47B1ME's Avatar
 
Date registered: Sep 2014
Vehicle: 2015 ML250 BluTec, 2002 ML 500 Sport Edition (Sold :(), 2012 C250
Location: Los Angeles, CA
Posts: 749
Mentioned: 0 Post(s)
Quoted: 227 Post(s)
Quote:
Originally Posted by gramen View Post
I said I did wash my car and all the sensors before someone tells me ď take all the dirt from the sensorsĒ I did everything possible what I saw online, but the problem occurred when I drove into the puddle which I didnít want to believe that a $70K car would give me that trouble just because I drove on a water puddle.


Your verbiage was confusing in your first post, sorry. You never said you drove thru a puddle at first. From reading it, I assumed you were saying "I washed my car and the sensors stopped working and the message illuminated."

Regardless, you still need to have the truck scanned with a pro level scanner. It will tell you exactly what's wrong or point you in the right direction. It's a guessing game here until you do so.
mattml430 likes this.
WE47B1ME is online now  
post #8 of 11 (permalink) Old 02-04-2019, 08:57 PM
Lifetime Premium Member
 
mattml430's Avatar
 
Date registered: Sep 2008
Vehicle: 2000 ML55 sold😢 2013 ML500,😁 2015 C250 estate wagon, 1927 Dodge 4 sedan, 1929 Dodge
Location: Melbourne Australia
Posts: 4,365
Mentioned: 4 Post(s)
Quoted: 795 Post(s)
Lifetime Premium Member
Quote:
Originally Posted by gramen View Post
I said I did wash my car and all the sensors before someone tells me ď take all the dirt from the sensorsĒ I did everything possible what I saw online, but the problem occurred when I drove into the puddle which I didnít want to believe that a $70K car would give me that trouble just because I drove on a water puddle.


Owning any late model car these days itís definitely worth investing in a decent pro level scanner. If your a bit handy it will pay for itself in no time.


Sent from my iPhone using Tapatalk
mattml430 is offline  
post #9 of 11 (permalink) Old 02-04-2019, 09:29 PM Thread Starter
BenzWorld Junior Member
 
Date registered: Feb 2019
Posts: 11
Mentioned: 0 Post(s)
Quoted: 6 Post(s)
(Thread Starter)
Suggest me one scanner?
gramen is offline  
post #10 of 11 (permalink) Old 02-05-2019, 02:28 AM
Lifetime Premium Member
 
mattml430's Avatar
 
Date registered: Sep 2008
Vehicle: 2000 ML55 sold😢 2013 ML500,😁 2015 C250 estate wagon, 1927 Dodge 4 sedan, 1929 Dodge
Location: Melbourne Australia
Posts: 4,365
Mentioned: 4 Post(s)
Quoted: 795 Post(s)
Lifetime Premium Member
Quote:
Originally Posted by gramen View Post
Suggest me one scanner?


I have the Foxwell NT630 that I used on my old ML w163 and it was great for that. It worked ok on the 166 but didnít really get into all the systems to well.
I invested in a snap on scanner which is probably a little over the top for the home mechanic but I have a 2013 & 2015 Benz and want to service and look after them myself. I have a view friends that seem to bring all the car issues my way as well so it will pay for itself. Iíd like someone else to advise on what they use on the 166 just to point you in the rite direction.
The Snap On is brilliant and gives you very detailed help on a lot of problems.
The Autel Maxidiag has been a highly recommended scanner as well. Spending a view hundred on a scanner will pay for itself in the first few uses. Steer clear of generic OBDll scanners they wonít get into the systems you need to.




Sent from my iPhone using Tapatalk
mattml430 is offline  
Sponsored Links
Advertisement
 
Reply

  Mercedes-Benz Forum > Mercedes-Benz Vans/Trucks/SUV/Others > W166 M-Class / GLE-Class

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Mercedes-Benz Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in











Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Topic Author Forum Replies Last Post
Considering 2014 E 350 CPO as 3rd car NC211 W212 E-Class 8 06-25-2017 04:11 PM
2014 Chevrolet Sonic Gets Deep Magenta Metallic Limited Edition Color AutoGuide.com AutoGuide.Com News 0 07-22-2013 01:50 PM
2014 Chevrolet Corvette Limited to High-Volume Dealers AutoGuide.com AutoGuide.Com News 0 01-23-2013 09:50 AM
Not intended for another oil war. JeffreyP W210 E-Class 22 01-19-2010 01:17 PM
Limited Slip Differential on SLK 350 - Anyone Interested? Cixi R171 SLK-Class 2 04-27-2009 03:37 PM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 

Title goes here

close
video goes here
description goes here. Read Full Story
For the best viewing experience please update your browser to Google Chrome