ML63 Alignment woes... - Mercedes-Benz Forum
Reply
 
LinkBack Thread Tools Display Modes
post #1 of 11 (permalink) Old 05-11-2019, 11:52 PM Thread Starter
BenzWorld Junior Member
 
Date registered: Mar 2019
Vehicle: 2007 ML63
Location: Qatar
Posts: 42
Mentioned: 0 Post(s)
Quoted: 3 Post(s)
(Thread Starter)
ML63 Alignment woes...

So... I can't seem to get my ML63 going in a straight line all the time... I had the alignment done when I first got the car after it had new front bushes, track rod ends and drop inks etc, still pulled to the right slightly and still had to correct it with the steering wheel slightly towards 11... I assumed it was the tyres, being that although all the same brand and tread, they all seemed to be at different wear heights... So I got 4 new tyres, had the alignment checked again, this is 4 wheel laser alignment on the the Hunter Hoawkeye each time, and although slightly improved and sometimes it will be centre and run true, still most of the time the car wants to pull to the right sightly and I still find myself having to correct it to keep it straight...
It's not the roads where I live as I have a RR Sport as well which has also had 4 new tyres and alignment and it's like an arrow, on all and any roads, straight and true as is expected...
If it was like it all the time, it would be easier to pinpoint the problem maybe but its more like 60-70% of the time its off and the rest of the time it's straight and true... It can behave different on the same road as well, one day it will be off and the next it will be true on the same bit of road...
I can take it the dealer for alignment but are they gonna do anything that the Hawkeye doesn't...??? Not only that, it's 6 times the price to take it to the dealer...!!
Car hasn't been in any accidents either so it ain't bent...!!

Just doesn't make any sense and it's driving my OCD mental, I cant bear to look at a wonky steering wheel or have a car that don't drive straight, so much so that if I cant fix the problem, I will get rid of the car.... Drives me mad...

As said, have changed the track rod ends, all the front suspension bushes, steering rack bushes, engine mounts...
The only issue I have at the moment is a air leak in my front near side spring but when the car is running, it runs level, it just dumps the air out when you turn off the car... But I can't believe this will effect the alignment...

Any ideas please...??????
mixja23 is offline  
Sponsored Links
Advertisement
 
post #2 of 11 (permalink) Old 05-12-2019, 12:48 AM
Lifetime Premium Member
 
mattml430's Avatar
 
Date registered: Sep 2008
Vehicle: 2000 ML55 sold😢 2013 ML500,😁 2015 C250 estate wagon, 1927 Dodge 4 sedan, 1929 Dodge
Location: Melbourne Australia
Posts: 4,244
Mentioned: 3 Post(s)
Quoted: 767 Post(s)
Lifetime Premium Member
Have you tried giving the power steering system a bleed.


Sent from my iPhone using Tapatalk
mattml430 is offline  
post #3 of 11 (permalink) Old 05-12-2019, 02:33 AM Thread Starter
BenzWorld Junior Member
 
Date registered: Mar 2019
Vehicle: 2007 ML63
Location: Qatar
Posts: 42
Mentioned: 0 Post(s)
Quoted: 3 Post(s)
(Thread Starter)
Quote:
Originally Posted by mattml430 View Post
Have you tried giving the power steering system a bleed.


Sent from my iPhone using Tapatalk
Well, I've done the 2-3 times lock to lock more times than I care to remember...!!
Is that what you mean...??
mixja23 is offline  
Sponsored Links
Advertisement
 
post #4 of 11 (permalink) Old 05-12-2019, 02:35 AM Thread Starter
BenzWorld Junior Member
 
Date registered: Mar 2019
Vehicle: 2007 ML63
Location: Qatar
Posts: 42
Mentioned: 0 Post(s)
Quoted: 3 Post(s)
(Thread Starter)
I should say as well, it's worse when its on the highway, a long straight flat road and I almost every time find myself holding it from pulling right....
Low speed around town, it seems mostly ok....
Just above about 40-50mph seems on a straight road, to be a lot worse...
mixja23 is offline  
post #5 of 11 (permalink) Old 05-12-2019, 02:38 AM
Lifetime Premium Member
 
mattml430's Avatar
 
Date registered: Sep 2008
Vehicle: 2000 ML55 sold😢 2013 ML500,😁 2015 C250 estate wagon, 1927 Dodge 4 sedan, 1929 Dodge
Location: Melbourne Australia
Posts: 4,244
Mentioned: 3 Post(s)
Quoted: 767 Post(s)
Lifetime Premium Member
Iím not totally up to speed on the 164 power steering but when we do it in the 163 itís wheels off the ground, engine off and 20-30 times lock to lock.
When I replaced the engine in my friends ML63 thatís how I bleed the power steering in his.
Has any work ever been performed on the power steering.


Sent from my iPhone using Tapatalk
mattml430 is offline  
post #6 of 11 (permalink) Old 05-12-2019, 02:40 AM
Lifetime Premium Member
 
Date registered: Aug 2006
Vehicle: 02 ML320 06 ML500
Location: Bronx, New York
Posts: 16,527
Mentioned: 23 Post(s)
Quoted: 1519 Post(s)
Lifetime Premium Member
Remove your right side calipers and see if the slide pins (#340) move freely back and forth.
Attached Thumbnails
Click image for larger version

Name:	2019-05-12_052831.jpg
Views:	5
Size:	53.3 KB
ID:	2511990  
Attached Files
File Type: pdf R&I Brake Caliper Front.PDF (118.7 KB, 5 views)
File Type: pdf R&I Brake Caliper Rear.PDF (87.4 KB, 5 views)
mattml430 likes this.
43sqd is offline  
post #7 of 11 (permalink) Old 05-12-2019, 02:42 AM
Lifetime Premium Member
 
mattml430's Avatar
 
Date registered: Sep 2008
Vehicle: 2000 ML55 sold😢 2013 ML500,😁 2015 C250 estate wagon, 1927 Dodge 4 sedan, 1929 Dodge
Location: Melbourne Australia
Posts: 4,244
Mentioned: 3 Post(s)
Quoted: 767 Post(s)
Lifetime Premium Member
Good call Jim.


Sent from my iPhone using Tapatalk
mattml430 is offline  
post #8 of 11 (permalink) Old 05-12-2019, 02:44 AM Thread Starter
BenzWorld Junior Member
 
Date registered: Mar 2019
Vehicle: 2007 ML63
Location: Qatar
Posts: 42
Mentioned: 0 Post(s)
Quoted: 3 Post(s)
(Thread Starter)
Quote:
Originally Posted by mattml430 View Post
Iím not totally up to speed on the 164 power steering but when we do it in the 163 itís wheels off the ground, engine off and 20-30 times lock to lock.
When I replaced the engine in my friends ML63 thatís how I bleed the power steering in his.
Has any work ever been performed on the power steering.


Sent from my iPhone using Tapatalk
I'm sure I read for these it's just 2-3 times lock to lock wheels on ground, I may be wrong tho...!!
I've only had the car a few months tbh, it's not needed any steering work since I've had it but the 2 owners before me both had all their work done at dealer.... SO chances are it may have gone in for a dust cap replacement and they've replaced the whole steering system lol...
There's a whole stack of MB invoices in the glove box, I only flicked thru them before, will check again and see if it's had anything done...

Never had this on a car before...!!
mixja23 is offline  
post #9 of 11 (permalink) Old 05-12-2019, 02:47 AM Thread Starter
BenzWorld Junior Member
 
Date registered: Mar 2019
Vehicle: 2007 ML63
Location: Qatar
Posts: 42
Mentioned: 0 Post(s)
Quoted: 3 Post(s)
(Thread Starter)
Quote:
Originally Posted by 43sqd View Post
Remove your right side calipers and see if the slide pins (#340) move freely back and forth.

Bit out of my scope that lol...

I'm going on holiday this week so it's going in to mechanic for couple of small jobs, I will ask him to check this....
I assume you're suggesting the brakes could be pulling it...??
mixja23 is offline  
post #10 of 11 (permalink) Old 05-13-2019, 01:27 PM
Lifetime Premium Member
 
Date registered: Aug 2006
Vehicle: 02 ML320 06 ML500
Location: Bronx, New York
Posts: 16,527
Mentioned: 23 Post(s)
Quoted: 1519 Post(s)
Lifetime Premium Member
Quote:
Originally Posted by mixja23 View Post
Bit out of my scope that lol...

I'm going on holiday this week so it's going in to mechanic for couple of small jobs, I will ask him to check this....
I assume you're suggesting the brakes could be pulling it...??
Yes.
43sqd is offline  
Sponsored Links
Advertisement
 
Reply

  Mercedes-Benz Forum > Mercedes-Benz Vans/Trucks/SUV/Others > W164 M-Class

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Mercedes-Benz Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in











Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Topic Author Forum Replies Last Post
Possible 2007 ML63 Purchase - Convince Me? carlosamg W164 M-Class 0 10-25-2014 07:38 AM
Rear Alignment Gremlins ccrider2 X164 GL-Class 0 03-31-2013 09:06 AM
True or False - Alignment questions steh-fan W126 S,SE,SEC,SEL,SD,SDL Class 23 10-17-2011 07:37 PM
Anybody know what the alignment specs are? Wotseurba W211 E-Class 2 07-29-2011 10:23 AM
Front-end and/or Four-wheel alignment DASola General Mercedes-Benz 0 02-14-2006 07:26 AM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 

Title goes here

close
video goes here
description goes here. Read Full Story
For the best viewing experience please update your browser to Google Chrome