W164 ML63 Air suspension question - Mercedes-Benz Forum
Reply
 
LinkBack Thread Tools Display Modes
post #1 of 17 (permalink) Old 04-16-2019, 05:02 AM Thread Starter
BenzWorld Junior Member
 
Date registered: Mar 2019
Vehicle: 2007 ML63
Location: Qatar
Posts: 42
Mentioned: 0 Post(s)
Quoted: 3 Post(s)
(Thread Starter)
W164 ML63 Air suspension question

So, bit of a weird one... Every now and then, say 3-4 days, I'll leave the car parked up for around 1-2 hours, when I go back to it, one, sometimes both, the front springs have dropped to the floor... Soon as I open the door tho, car pumps itself up to correct height, this without starting the engine... Initially it was just the passenger side which lead me to believe it may be the air spring but more often than not now, it drops on both sides which would suggest not the springs... I cant hear any leaking from either side either before I open the door or after when it pumps itself back up, there's no errors showing up on Carly or the dashboard either and when car is driving, it's as it should be...
Anyone had this before please...?? If so, what was the cause...??
Thanking you kindly...
Attached Thumbnails
Click image for larger version

Name:	IMG_5631.jpg
Views:	8
Size:	72.6 KB
ID:	2504838   Click image for larger version

Name:	IMG_5632.jpg
Views:	10
Size:	68.2 KB
ID:	2504840   Click image for larger version

Name:	IMG_5633.jpg
Views:	9
Size:	73.8 KB
ID:	2504842   Click image for larger version

Name:	IMG_5634.jpg
Views:	8
Size:	60.5 KB
ID:	2504844  
mixja23 is offline  
Sponsored Links
Advertisement
 
post #2 of 17 (permalink) Old 04-16-2019, 05:19 AM
Lifetime Premium Member
 
Date registered: Aug 2006
Vehicle: 02 ML320 06 ML500
Location: Bronx, New York
Posts: 16,523
Mentioned: 23 Post(s)
Quoted: 1518 Post(s)
Lifetime Premium Member
Your problem can only be diagnosed by a scanner that can read codes in all modules.

https://www.amazon.com/Autel-MD802-M...1?ie=UTF8&qid=

Look at all the possibilities.
Attached Files
File Type: pdf DTC Airmatic All..pdf (83.7 KB, 12 views)
43sqd is offline  
post #3 of 17 (permalink) Old 04-16-2019, 05:28 AM Thread Starter
BenzWorld Junior Member
 
Date registered: Mar 2019
Vehicle: 2007 ML63
Location: Qatar
Posts: 42
Mentioned: 0 Post(s)
Quoted: 3 Post(s)
(Thread Starter)
Well, I actually have the Autel MD808....
I've only plugged it in once tbh, only to see if showed up anything different to Carly which it didn't, the codes Carly showed up were the same (I purposely didn't clear any from the Carly scan)... I dunno if I've missed something and I only used it for one scan one time but it doesn't seem to scan everything...??? Engine, transmission, ESP module and something else I cant remember...!! But only 4 things...
I plugged it into the Mac downloaded all the updates etc before I used it as well...

Remember being surprised as I was expecting it to cover everything....

Have I missed something with it...???
Attached Images
 
mixja23 is offline  
Sponsored Links
Advertisement
 
post #4 of 17 (permalink) Old 04-16-2019, 06:09 AM Thread Starter
BenzWorld Junior Member
 
Date registered: Mar 2019
Vehicle: 2007 ML63
Location: Qatar
Posts: 42
Mentioned: 0 Post(s)
Quoted: 3 Post(s)
(Thread Starter)
Just seems weird that nothing is showing on the dash, assuming there's a fault...
I have a Range Rover Sport Supercharged as well, which had a leaky spring and a shot compressor, comes up on dash with suspension fault...
I had an Audi S8 as well which also had leaky springs and that would also come up on the dash...
mixja23 is offline  
post #5 of 17 (permalink) Old 04-16-2019, 09:31 AM
Lifetime Premium Member
 
Date registered: Aug 2006
Vehicle: 02 ML320 06 ML500
Location: Bronx, New York
Posts: 16,523
Mentioned: 23 Post(s)
Quoted: 1518 Post(s)
Lifetime Premium Member
You will only see the CEL if it is something important, eng. trans., ESP, etc.
43sqd is offline  
post #6 of 17 (permalink) Old 04-17-2019, 12:23 AM Thread Starter
BenzWorld Junior Member
 
Date registered: Mar 2019
Vehicle: 2007 ML63
Location: Qatar
Posts: 42
Mentioned: 0 Post(s)
Quoted: 3 Post(s)
(Thread Starter)
Quote:
Originally Posted by 43sqd View Post
You will only see the CEL if it is something important, eng. trans., ESP, etc.
Well, plugged in the Autel this morning, scanned everything I could but no mention of anything related to suspension....
Only 2 faults with motor and 2 with ESP... Other than that, clean as a whistle...

What could it be then...???!!!
Attached Thumbnails
Click image for larger version

Name:	IMG_5645.jpg
Views:	6
Size:	60.5 KB
ID:	2505196   Click image for larger version

Name:	IMG_5646.jpg
Views:	6
Size:	62.2 KB
ID:	2505198   Click image for larger version

Name:	IMG_5647.jpg
Views:	7
Size:	62.3 KB
ID:	2505200   Click image for larger version

Name:	IMG_5648.jpg
Views:	6
Size:	55.7 KB
ID:	2505202   Click image for larger version

Name:	IMG_5649.jpg
Views:	6
Size:	58.7 KB
ID:	2505204  

Click image for larger version

Name:	IMG_5652.jpg
Views:	6
Size:	66.7 KB
ID:	2505206   Click image for larger version

Name:	IMG_5650.jpg
Views:	7
Size:	55.7 KB
ID:	2505208   Click image for larger version

Name:	IMG_5651.jpg
Views:	6
Size:	59.3 KB
ID:	2505210  
mixja23 is offline  
post #7 of 17 (permalink) Old 04-17-2019, 01:09 AM
Lifetime Premium Member
 
Date registered: Aug 2006
Vehicle: 02 ML320 06 ML500
Location: Bronx, New York
Posts: 16,523
Mentioned: 23 Post(s)
Quoted: 1518 Post(s)
Lifetime Premium Member
Is your scanner able to read codes in Airmatic cont. module?
43sqd is offline  
post #8 of 17 (permalink) Old 04-17-2019, 02:25 AM Thread Starter
BenzWorld Junior Member
 
Date registered: Mar 2019
Vehicle: 2007 ML63
Location: Qatar
Posts: 42
Mentioned: 0 Post(s)
Quoted: 3 Post(s)
(Thread Starter)
Quote:
Originally Posted by 43sqd View Post
Is your scanner able to read codes in Airmatic cont. module?
If it does, I don't know how to do it...!!
Was pissing about with it for ages this morning trying out literally everything....
The only modules that show up for scanning seem to be Transmission, Motor, ESP and Airbag...
On another page I can get to the steering angle sensor and battery manager plus the OBD port...
mixja23 is offline  
post #9 of 17 (permalink) Old 04-17-2019, 03:11 AM
Lifetime Premium Member
 
Date registered: Aug 2006
Vehicle: 02 ML320 06 ML500
Location: Bronx, New York
Posts: 16,523
Mentioned: 23 Post(s)
Quoted: 1518 Post(s)
Lifetime Premium Member
I don't know anything about your scanner, but look to see if there is a Chassis section which includes Airmatic, ESP, Tire Pressure Monitor and Elec. Power Steering.
43sqd is offline  
post #10 of 17 (permalink) Old 04-17-2019, 04:07 AM Thread Starter
BenzWorld Junior Member
 
Date registered: Mar 2019
Vehicle: 2007 ML63
Location: Qatar
Posts: 42
Mentioned: 0 Post(s)
Quoted: 3 Post(s)
(Thread Starter)
Quote:
Originally Posted by 43sqd View Post
I don't know anything about your scanner, but look to see if there is a Chassis section which includes Airmatic, ESP, Tire Pressure Monitor and Elec. Power Steering.
There is definitely no chassis section....
mixja23 is offline  
Sponsored Links
Advertisement
 
Reply

  Mercedes-Benz Forum > Mercedes-Benz Vans/Trucks/SUV/Others > W164 M-Class

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Mercedes-Benz Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in











Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Topic Author Forum Replies Last Post
:: ECS Tuning :: Performance Air Filters For Your W164 ML63 AMG (2007-2011) ECSTuning W164 M-Class 0 06-19-2015 01:04 PM
Arnott Air Suspension Products Intro New Front Air Strut for '06-'11 ML63 AMG ArnottDoug Arnott Inc. 0 04-20-2015 12:49 PM
Question about Rear Air Suspension....Leak? skiman W211 E-Class 8 01-18-2013 11:31 AM
Intake Air Temperature and Design senorking C208/A208 CLK-Class 4 03-29-2011 07:48 AM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 

Title goes here

close
video goes here
description goes here. Read Full Story
For the best viewing experience please update your browser to Google Chrome