brake questions - Mercedes-Benz Forum
 
LinkBack Thread Tools Display Modes
post #1 of 2 (permalink) Old 07-09-2012, 08:02 PM Thread Starter
BenzWorld Newbie
 
Date registered: Feb 2011
Vehicle: 2007 ML350
Location: Edmond, OK
Posts: 3
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
(Thread Starter)
brake questions

I have a few break related questions on my ’07 ML350:
I recently (a couple weeks ago) replaced all four sets of brake pads with Wagner ThermoQuiet pads. I had the rotors turned. The rear pads had worn to the point that it tripped the sensor; the fronts still had a little meat left on them. When I had the rotors turned the shop said that the rotors were very warped; is this normal with benz rotors? The vehicle is not driven hard nor are the brakes “ridden”. They were unable to get the rotors completely true while staying within specs; there was a small area on all the rotors that was not hit with the lathe teeth. I say small, it was an area that looked like somebody had marked on the rotor with a sharpie. The shop said that it should not be an issue. I put everything back together and it has got to be the noisiest brake job I have ever completed. I researched and it seems that the ThermoQuiets take quite a few stops to properly seat. After nearly a month now, the brakes are still noisy. There is a “squeak, squeak, squeak, etc” noise that can be heard just driving down the road; I assume this can be fixed with new rotors. As the vehicle comes to a stop, I also hear a mechanical type of noise, as if something is loose or moving around??? I have taken everything apart and reassembled it in case I had done something wrong and can’t seem to cure it. Considered putting a brake hardware kit on when I replace the rotors. As a side note, the ThermoQuiets grip extremely well! Thanks in advance for everybody’s input.
tley is offline  
Sponsored Links
Advertisement
 
post #2 of 2 (permalink) Old 07-10-2012, 05:19 AM
BenzWorld Senior Member
 
1997E300D's Avatar
 
Date registered: Jan 2010
Vehicle: 2008 ML320CDI Iridium Silver/Black, NAV, P2 pkg, Sirius, Harmon Kardon. Active Bi-Xenon
Location: Cross Roads, PA
Posts: 478
Mentioned: 0 Post(s)
Quoted: 9 Post(s)
I am sorry for your issues, brake noises make me crazy. I only use OEM parts. I have tried and tried other options.

2008 ML320 CDI. Iridium Silver/Black MBTex, P2 pkg, NAV, Trailer Hitch. Purchased 3/2012 CPO 142,000 miles
2006 E320 CDI Black/Black, Leather, NAV, Harmon Kardon, HTD Seats, Rear Shade. Purchased 2/2010 CPO SOLD
1997 E300D Silver 304,000 miles SOLD
2000 VW Passat 1.8t Black/Black 400,200 miles original owner still going strong 3/2015
1997E300D is offline  
Sponsored Links
Advertisement
 
Reply

  Mercedes-Benz Forum > Mercedes-Benz Vans/Trucks/SUV/Others > W164 M-Class

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Mercedes-Benz Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in











Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 

Title goes here

close
video goes here
description goes here. Read Full Story
For the best viewing experience please update your browser to Google Chrome