ML350 3.5L Balance Shaft Failure - Mercedes-Benz Forum
Reply
 
LinkBack Thread Tools Display Modes
post #1 of 275 (permalink) Old 02-22-2010, 05:15 PM Thread Starter
BenzWorld Elite
 
azinn's Avatar
 
Date registered: Apr 2003
Vehicle: 2014 RX 350 F Sport, 2007 Scion tC, 2000 ML 430 Money Pit Finally Gone! Oh Happy Day!
Location: In A Van Down By The River
Posts: 1,284
Mentioned: 0 Post(s)
Quoted: 2 Post(s)
(Thread Starter)
azinn is offline  
Sponsored Links
Advertisement
 
post #2 of 275 (permalink) Old 02-23-2010, 12:56 PM
BenzWorld Elite
 
Date registered: Feb 2006
Vehicle: 1999 ML320
Location: Ratville
Posts: 24,029
Mentioned: 1 Post(s)
Quoted: 313 Post(s)
Wow, looks like ALL M272's are affected.

When was the last time MB designed or updated an engine right the first time ?

... and this important discussion continues.


Dooloogssst!
mlfun is offline  
post #3 of 275 (permalink) Old 02-23-2010, 04:55 PM
BenzWorld Member
 
Ox8xO's Avatar
 
Date registered: Jul 2009
Vehicle: W164
Location: Moscow, Russia
Posts: 251
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
This has been a known problem for a while. Not all are effected, just the ones up to engine #30468993. Any M2729 that falls within the defect range with check engine light and both error 1200 and 1208 will likely need this done. Part number for the repair kit is A2720300013. Sometimes the oil pump is also replaced. I think labor is about 25 hours, not including the 2 oil changes and test drive. Over here depending on your millage you can get post warranty repair credit from MB, full or partial, to fix this problem.
Ox8xO is offline  
Sponsored Links
Advertisement
 
post #4 of 275 (permalink) Old 02-23-2010, 05:38 PM
BenzWorld Junior Member
 
Date registered: Dec 2009
Posts: 24
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
i have an 07 ml350. could i possibly be affected?

i hope mercedes stands behind their product, or i will never buy another one again. something like a shaft that wasnt heat treated is not something that should happen even in a cheap car.
turboawd is offline  
post #5 of 275 (permalink) Old 02-24-2010, 02:59 PM
BenzWorld Junior Member
 
Date registered: Dec 2009
Posts: 24
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Quote:
Originally Posted by Ox8xO View Post
This has been a known problem for a while. Not all are effected, just the ones up to engine #30468993
i called the dealer, and was told my engine serial# is 27296730510122
do i go by the last digits 30510122, which would put the number higher than 30468993?
turboawd is offline  
post #6 of 275 (permalink) Old 02-24-2010, 05:37 PM
BenzWorld Member
 
Ox8xO's Avatar
 
Date registered: Jul 2009
Vehicle: W164
Location: Moscow, Russia
Posts: 251
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Quote:
Originally Posted by turboawd View Post
i called the dealer, and was told my engine serial# is 27296730510122
do i go by the last digits 30510122, which would put the number higher than 30468993?
Well yeah, isn't it obvious?
Ox8xO is offline  
post #7 of 275 (permalink) Old 02-24-2010, 05:50 PM
BenzWorld Junior Member
 
Date registered: Dec 2009
Posts: 24
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Quote:
Originally Posted by Ox8xO View Post
Well yeah, isn't it obvious?
just making sure.
turboawd is offline  
post #8 of 275 (permalink) Old 02-24-2010, 05:54 PM
BenzWorld Member
 
Ox8xO's Avatar
 
Date registered: Jul 2009
Vehicle: W164
Location: Moscow, Russia
Posts: 251
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Quote:
Originally Posted by turboawd View Post
just making sure.
then whats with the sad face? you're outside the problem range, so you got nothing to worry about.
Ox8xO is offline  
post #9 of 275 (permalink) Old 02-24-2010, 06:01 PM
BenzWorld Junior Member
 
Date registered: Dec 2009
Posts: 24
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Quote:
Originally Posted by Ox8xO View Post
then whats with the sad face? you're outside the problem range, so you got nothing to worry about.
you made it sound like i asked a stupid question. i guess thats better than looking forward to a balance shaft replacement though.
turboawd is offline  
post #10 of 275 (permalink) Old 02-24-2010, 06:52 PM
BenzWorld Member
 
Ox8xO's Avatar
 
Date registered: Jul 2009
Vehicle: W164
Location: Moscow, Russia
Posts: 251
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Didn't mean anything by it.
272.967 is the engine type/model identifier, the rest of the numbers are its serial #.
Ox8xO is offline  
Sponsored Links
Advertisement
 
Reply

  Mercedes-Benz Forum > Mercedes-Benz Vans/Trucks/SUV/Others > W164 M-Class

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Mercedes-Benz Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in











Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Topic Author Forum Replies Last Post
Has anyone ever had to replace their balance shaft? Achped W203 C-Class 531 01-06-2016 04:41 PM
Centre Drive Shaft Support Bearing Failure Big D W163 M-Class 34 06-02-2014 10:09 PM
ML350 3.5L Balance Shaft Failure azinn W163 M-Class 0 02-22-2010 01:52 PM
Girlfriends 2006 ML350 CPO - Balance Shaft Issue? 07ML350Mass W164 M-Class 0 06-19-2009 08:24 AM
'95 E300D: Cam Shaft Failure! RotaryMan W124 E,CE,D,TD Class 5 12-08-2006 05:46 PM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 

Title goes here

close
video goes here
description goes here. Read Full Story
For the best viewing experience please update your browser to Google Chrome