2000 ML320 ABS Unit Reprogramming? - Mercedes-Benz Forum
Reply
 
LinkBack Thread Tools Display Modes
post #1 of 27 (permalink) Old 07-31-2019, 11:11 PM Thread Starter
BenzWorld Junior Member
 
Date registered: Jul 2019
Vehicle: 2000 Mercedes ML320
Location: Seattle, WA
Posts: 16
Mentioned: 0 Post(s)
Quoted: 6 Post(s)
(Thread Starter)
2000 ML320 ABS Unit Reprogramming?

I replaced the entire ABS unit by purchasing 1 from eBay. The previous one had a bad pump. Now I am getting the following error:

1. ABS/BAS/ETS light is still on
2. Parking brake light is still on even when you disengage the parking brake
3. Radio is refusing to recognize the code

I have seen a post here that refers to a parking brake showing a similar behavior until the ABS was reset. But then I have seen videos on the youtube that do not require any resets at all. The unit was installed by a mechanic and later I found out he had no way or knowledge on how to reset the ABS light.

Do I need to get this unit reprogrammed or would buying an OBD2 Scanner with ABS reset capabilities solve the problem?
sbasi is online now  
Sponsored Links
Advertisement
 
post #2 of 27 (permalink) Old 08-01-2019, 03:05 AM
Lifetime Premium Member
 
Date registered: Aug 2006
Vehicle: 02 ML320 06 ML500
Location: Bronx, New York
Posts: 16,621
Mentioned: 24 Post(s)
Quoted: 1555 Post(s)
Lifetime Premium Member
Please UPDATE YOUR PROFILE in USER CP to include the year, model and where you live.
Attached Thumbnails
Click image for larger version

Name:	AAAAAAAAAA.jpg
Views:	5
Size:	96.3 KB
ID:	2531966  
khomer2 likes this.
43sqd is offline  
post #3 of 27 (permalink) Old 08-01-2019, 03:08 AM
Lifetime Premium Member
 
Date registered: Aug 2006
Vehicle: 02 ML320 06 ML500
Location: Bronx, New York
Posts: 16,621
Mentioned: 24 Post(s)
Quoted: 1555 Post(s)
Lifetime Premium Member
Post the link to the part that you purchased.
43sqd is offline  
Sponsored Links
Advertisement
 
post #4 of 27 (permalink) Old 08-01-2019, 09:32 AM
BenzWorld Elite
 
khomer2's Avatar
 
Date registered: Nov 2015
Vehicle: w163 02 ML500 W210 97 E50Amg w202 99 C230K w124 - need more space, time to build again
Location: Canada
Posts: 1,337
Mentioned: 7 Post(s)
Quoted: 304 Post(s)
Quote:
Originally Posted by sbasi View Post
I replaced the entire ABS unit by purchasing 1 from eBay. The previous one had a bad pump. Now I am getting the following error:

1. ABS/BAS/ETS light is still on
2. Parking brake light is still on even when you disengage the parking brake
3. Radio is refusing to recognize the code

I have seen a post here that refers to a parking brake showing a similar behavior until the ABS was reset. But then I have seen videos on the youtube that do not require any resets at all. The unit was installed by a mechanic and later I found out he had no way or knowledge on how to reset the ABS light.

Do I need to get this unit reprogrammed or would buying an OBD2 Scanner with ABS reset capabilities solve the problem?
Welcome sbasi,

If "your mechanic" doesn't know how to turn the steering wheel all the way to the right and to the left a couple of times, he's NOT a mechanic.
Respectfully, BUYER BEWARE......
khomer2 is offline  
post #5 of 27 (permalink) Old 08-01-2019, 07:52 PM Thread Starter
BenzWorld Junior Member
 
Date registered: Jul 2019
Vehicle: 2000 Mercedes ML320
Location: Seattle, WA
Posts: 16
Mentioned: 0 Post(s)
Quoted: 6 Post(s)
(Thread Starter)
Please see the ebay part here
sbasi is online now  
post #6 of 27 (permalink) Old 08-01-2019, 07:56 PM Thread Starter
BenzWorld Junior Member
 
Date registered: Jul 2019
Vehicle: 2000 Mercedes ML320
Location: Seattle, WA
Posts: 16
Mentioned: 0 Post(s)
Quoted: 6 Post(s)
(Thread Starter)
@khomer2 - I tried moving all the way right then moving all the way left a couple of times myself.. even drove it around the neighborhood the lights didn't go off. I wonder if

1. There is air in the brake lines because I have to push all the way down to make the brakes work.
2. If he damaged the ABS cable connecter while removing the old unit.

This is link to the part I bought from ebay
sbasi is online now  
post #7 of 27 (permalink) Old 08-01-2019, 08:20 PM
BenzWorld Elite
 
khomer2's Avatar
 
Date registered: Nov 2015
Vehicle: w163 02 ML500 W210 97 E50Amg w202 99 C230K w124 - need more space, time to build again
Location: Canada
Posts: 1,337
Mentioned: 7 Post(s)
Quoted: 304 Post(s)
Quote:
Originally Posted by sbasi View Post
@khomer2 - I tried moving all the way right then moving all the way left a couple of times myself.. even drove it around the neighborhood the lights didn't go off. I wonder if

1. There is air in the brake lines because I have to push all the way down to make the brakes work.
2. If he damaged the ABS cable connecter while removing the old unit.

This is link to the part I bought from ebay
If you can, get your money back and run away. It sounds like he didnt even bleed your brake system (at all) piecing it back together.
Find a reputable MB indie to repair it if you are unable to DIY.

Optionally, if you have, or can borrow a scanner, scan for codes and post here.
khomer2 is offline  
post #8 of 27 (permalink) Old 08-01-2019, 08:55 PM Thread Starter
BenzWorld Junior Member
 
Date registered: Jul 2019
Vehicle: 2000 Mercedes ML320
Location: Seattle, WA
Posts: 16
Mentioned: 0 Post(s)
Quoted: 6 Post(s)
(Thread Starter)
Quote:
Originally Posted by khomer2 View Post
If you can, get your money back and run away. It sounds like he didnt even bleed your brake system (at all) piecing it back together.
Find a reputable MB indie to repair it if you are unable to DIY.

Optionally, if you have, or can borrow a scanner, scan for codes and post here.
@khomer2 All the indie mechanics won't even agree to work on the car unless I agree to install a rebuilt unit from the mercedes dealership that will cost $1500 + labor. Mercedes no longer makes these units. As for the scanner, I borrowed one from Autozone today but didn't see any codes that were ABS Related. The borrowed scanner was Innova 3130e. Here is the link to the manual. https://www.innova.com/Content/Suppo...nual_3130e.pdf

The questions that are coming to my mind are:

1. If the the new unit is even communicating to the car?
2. Is there even such a thing as "programming the unit"?
3. Can this scanner reset the ABS light? I called Innova and they say yes.
sbasi is online now  
post #9 of 27 (permalink) Old 08-01-2019, 09:39 PM
BenzWorld Elite
 
khomer2's Avatar
 
Date registered: Nov 2015
Vehicle: w163 02 ML500 W210 97 E50Amg w202 99 C230K w124 - need more space, time to build again
Location: Canada
Posts: 1,337
Mentioned: 7 Post(s)
Quoted: 304 Post(s)
Quote:
Originally Posted by sbasi View Post
@khomer2 All the indie mechanics won't even agree to work on the car unless I agree to install a rebuilt unit from the mercedes dealership that will cost $1500 + labor. Mercedes no longer makes these units. As for the scanner, I borrowed one from Autozone today but didn't see any codes that were ABS Related. The borrowed scanner was Innova 3130e. Here is the link to the manual. https://www.innova.com/Content/Suppo...nual_3130e.pdf

The questions that are coming to my mind are:

1. If the the new unit is even communicating to the car?
2. Is there even such a thing as "programming the unit"?
3. Can this scanner reset the ABS light? I called Innova and they say yes.

1. Dont know
2. no
3. should be ok to reset the ABS/BAS/ETS light

Read thru this.
You are being redirected...

As well, review this older video plus there are plenty of other youtube videos that pertain to this issue.




More reading

https://www.benzworld.org/forums/w16...002-ml320.html
https://www.benzworld.org/forums/w16...e-problem.html

You can do more searching with the search button top right corner.
Attached Thumbnails
Click image for larger version

Name:	search benzworld - it's your best friend.png
Views:	5
Size:	58.7 KB
ID:	2532194  
khomer2 is offline  
post #10 of 27 (permalink) Old 08-01-2019, 09:44 PM Thread Starter
BenzWorld Junior Member
 
Date registered: Jul 2019
Vehicle: 2000 Mercedes ML320
Location: Seattle, WA
Posts: 16
Mentioned: 0 Post(s)
Quoted: 6 Post(s)
(Thread Starter)
Quote:
Originally Posted by khomer2 View Post
1. Dont know
2. no
3. should be ok to reset the ABS/BAS/ETS light

Read thru this.
You are being redirected...

As well, review this older video plus there are plenty of other youtube videos that pertain to this issue.

https://www.youtube.com/watch?v=_DPP6S74tjY



More reading

https://www.benzworld.org/forums/w16...002-ml320.html
https://www.benzworld.org/forums/w16...e-problem.html

You can do more searching with the search button top right corner.
Thanks for the information. This is very helpful. It seems like there is no way if there is air in the brake lines that can cause the ABS to fail?
sbasi is online now  
Sponsored Links
Advertisement
 
Reply

  Mercedes-Benz Forum > Mercedes-Benz Vans/Trucks/SUV/Others > W163 M-Class

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Mercedes-Benz Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in











Currently Active Users Viewing This Thread: 2 (1 members and 1 guests)
sbasi



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 

Title goes here

close
video goes here
description goes here. Read Full Story
For the best viewing experience please update your browser to Google Chrome