Double Din Radio - Mercedes-Benz Forum
 
LinkBack Thread Tools Display Modes
post #1 of 7 (permalink) Old 05-10-2019, 08:50 AM Thread Starter
BenzWorld Newbie
 
Date registered: May 2019
Posts: 1
Mentioned: 0 Post(s)
Quoted: 1 Post(s)
(Thread Starter)
Double Din Radio

Hi guys, i need help with my ML320 2000, i just change the radio to a double din one but the Bose system didn't work, anyone knows how to resolved this keeping the bose sistem or the only way is if i take out the bose system?
Thanks!
Sierrarecio is offline  
Sponsored Links
Advertisement
 
post #2 of 7 (permalink) Old 05-10-2019, 12:27 PM
Lifetime Premium Member
 
mattml430's Avatar
 
Date registered: Sep 2008
Vehicle: 2000 ML55 sold😢 2013 ML500,😁 2015 C250 estate wagon, 1927 Dodge 4 sedan, 1929 Dodge
Location: Melbourne Australia
Posts: 4,244
Mentioned: 3 Post(s)
Quoted: 767 Post(s)
Lifetime Premium Member
I did mine about 11 years ago but I think there was a black wire that needed to be powered up to run the amp.
Please wait and get confirmation from some of the other guys that are much more up to date on the wiring than me.


Sent from my iPhone using Tapatalk
mattml430 is offline  
post #3 of 7 (permalink) Old 05-10-2019, 01:16 PM
BenzWorld Extremist
 
khomer2's Avatar
 
Date registered: Nov 2015
Vehicle: w163 02 ML500 W210 97 E50Amg w202 99 C230K w124 - need more space, time to build again
Location: Canada
Posts: 934
Mentioned: 3 Post(s)
Quoted: 202 Post(s)
Quote:
Originally Posted by Sierrarecio View Post
Hi guys, i need help with my ML320 2000, i just change the radio to a double din one but the Bose system didn't work, anyone knows how to resolved this keeping the bose sistem or the only way is if i take out the bose system?
Thanks!
Welcome Sierrarecio,

Please upddate your user cp info.

As for the bose system, my son recently did his (with some minor assistance from dad ) - bose system with FO.

You cannot use the bose system. In fact, a new HU installed will sound much better than this dinosaur.
You cannot use the bose amp (under the the brake pedals) with your new HU install.
You could use the bose sub-woofer (not really a sub-woofer though) under the DS seat, but not really needed since the audio will be just fine w/o it.
You can re-use the 2ohm speakers and wont have any issues of blowing them out UNLESS you like to drive around feeling and sounding like a boombox.


reading - follow the example - it's very straight forward

https://www.benzworld.org/forums/w16...00bt-03-a.html
https://www.benzworld.org/forums/w16...d2-2001-a.html

Use the search function if you want more info. (there is lots...)

Have fun.

edit: photo of the gutted bose amp used only for the oem speaker connectors.
Attached Thumbnails
Click image for larger version

Name:	user cp info benzworld.jpg
Views:	5
Size:	131.0 KB
ID:	2511620   Click image for larger version

Name:	gutted the bose amp and used only the speker connectors.png
Views:	7
Size:	681.4 KB
ID:	2511622  
khomer2 is online now  
Sponsored Links
Advertisement
 
post #4 of 7 (permalink) Old 05-10-2019, 01:21 PM
Lifetime Premium Member
 
mattml430's Avatar
 
Date registered: Sep 2008
Vehicle: 2000 ML55 sold😢 2013 ML500,😁 2015 C250 estate wagon, 1927 Dodge 4 sedan, 1929 Dodge
Location: Melbourne Australia
Posts: 4,244
Mentioned: 3 Post(s)
Quoted: 767 Post(s)
Lifetime Premium Member
Quote:
Originally Posted by khomer2 View Post
Welcome Sierrarecio,



Please upddate your user cp info.



As for the bose system, my son recently did his (with some minor assistance from dad ) - bose system with FO.



You cannot use the bose system. In fact, a new HU installed will sound much better than this dinosaur.

You cannot use the bose amp (under the the brake pedals) with your new HU install.

You could use the bose sub-woofer (not really a sub-woofer though) under the DS seat, but not really needed since the audio will be just fine w/o it.

You can re-use the 2ohm speakers and wont have any issues of blowing them out UNLESS you like to drive around feeling and sounding like a boombox.





reading - follow the example - it's very straight forward



https://www.benzworld.org/forums/w16...00bt-03-a.html

https://www.benzworld.org/forums/w16...d2-2001-a.html



Use the search function if you want more info. (there is lots...)



Have fun.


I used my complete Bose system with an updated head unit. It sounded ok. I think you have to, to use the 2ohm speaker donít you?


Sent from my iPhone using Tapatalk
mattml430 is offline  
post #5 of 7 (permalink) Old 05-10-2019, 01:28 PM
BenzWorld Extremist
 
khomer2's Avatar
 
Date registered: Nov 2015
Vehicle: w163 02 ML500 W210 97 E50Amg w202 99 C230K w124 - need more space, time to build again
Location: Canada
Posts: 934
Mentioned: 3 Post(s)
Quoted: 202 Post(s)
Quote:
Originally Posted by mattml430 View Post
I used my complete Bose system with an updated head unit. It sounded ok. I think you have to, to use the 2ohm speaker donít you?


Sent from my iPhone using Tapatalk
Yes, oem speakers worked fine.
We fine tuned the audios on the new HU user interface and it sounded fantastic - all the highs, lows, mid-ranges were crisp.
It was recommended to us not use the wannabe bose sub woofer.
mattml430 likes this.
khomer2 is online now  
post #6 of 7 (permalink) Old 05-10-2019, 09:00 PM
BenzWorld Veteran
 
WE47B1ME's Avatar
 
Date registered: Sep 2014
Vehicle: 2015 ML250 BluTec, 2002 ML 500 Sport Edition (Sold :(), 2012 C250
Location: Los Angeles, CA
Posts: 702
Mentioned: 0 Post(s)
Quoted: 208 Post(s)
Quote:
Originally Posted by khomer2 View Post
Yes, oem speakers worked fine.

We fine tuned the audios on the new HU user interface and it sounded fantastic - all the highs, lows, mid-ranges were crisp.

It was recommended to us not use the wannabe bose sub woofer.
You don't HAVE to use the Bose bass module (it doesn't break any loops), but it helps the overall sound quality, especially if you aren't adding an additional amp + sub. I did both. Kept the Bose bass module wired in tandem with the driver door speaker, and a 15" MTX sub in the trunk that could be easily removed for when I needed to load up the truck.

I wish people would heed your advice and use that nifty search function

Sent from my BlackBerry Key2 using Tapatalk
pte and khomer2 like this.
WE47B1ME is offline  
post #7 of 7 (permalink) Old 05-10-2019, 09:44 PM
BenzWorld Extremist
 
khomer2's Avatar
 
Date registered: Nov 2015
Vehicle: w163 02 ML500 W210 97 E50Amg w202 99 C230K w124 - need more space, time to build again
Location: Canada
Posts: 934
Mentioned: 3 Post(s)
Quoted: 202 Post(s)
Quote:
Originally Posted by WE47B1ME View Post
You don't HAVE to use the Bose bass module (it doesn't break any loops), but it helps the overall sound quality, especially if you aren't adding an additional amp + sub. I did both. Kept the Bose bass module wired in tandem with the driver door speaker, and a 15" MTX sub in the trunk that could be easily removed for when I needed to load up the truck.

I wish people would heed your advice and use that nifty search function

Sent from my BlackBerry Key2 using Tapatalk
Good to know, WE47B1ME.
We haven't touched the bass module under the DS, so if HE decides to add it into the mix, it'll be there. I'm fine with the AM radio news and traffic reports and my BT on iphone with the collection of 60s, 70s & 80s REAL music.

My son has been sifting thru my unorganized subscribed threads and is in the process of re-organizing them into vehicle class folders and topic specific to make it easier to review the good threads. He's planning to sift thru each subscribed thread and note the post# in a saved word doc for each category with key phrases to use his doc search function. Same way he organizes his school stuff for studies.
khomer2 is online now  
Sponsored Links
Advertisement
 
Reply

  Mercedes-Benz Forum > Mercedes-Benz Vans/Trucks/SUV/Others > W163 M-Class

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Mercedes-Benz Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in











Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Topic Author Forum Replies Last Post
heater trim cover for 2 din radio pablo_can W245 B-Class 4 12-16-2018 05:13 AM
New pioneer 8400bh double din radio! e420benz W210 E-Class 11 01-22-2017 04:11 AM
Easy Do-It-Yourself Radio Replacement in 1998-2005 ML (W163) rollingtones Audio & Telematics Forum 2 07-22-2016 09:46 PM
Radio and double din w210 parts jdurzua For Sale/Wanted/Trade/Giveaway 1 09-18-2012 02:52 AM
Double DIN 1998 E430? docfuture Audio & Telematics Forum 1 02-27-2007 12:28 AM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 

Title goes here

close
video goes here
description goes here. Read Full Story
For the best viewing experience please update your browser to Google Chrome