Second set of eyes on AC project - Mercedes-Benz Forum
 
LinkBack Thread Tools Display Modes
post #1 of 6 (permalink) Old 04-14-2019, 03:20 PM Thread Starter
BenzWorld Newbie
 
papaghiro's Avatar
 
Date registered: Apr 2019
Vehicle: 2005 ML-500 SE
Location: Arizona
Posts: 4
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
(Thread Starter)
Question Second set of eyes on AC project

Hello All,

I have a 05 ML500 which has recently began to have AC issues. About every 2 weeks the AC runs hot due to loss of freon. I did the quick fix with the UV dye to find the leak. After checking all the normal parts, the only place I see the leak is on the expansion valve. I have done other fixes to AC system in other cars, but wanted just to get a second set of eyes from anyone out there to tell me if the pictures attached look to be saying "expansion valve leak". Its almost summer here in Arizona, so wanted to make sure my project was correct before starting!

Thank you!

John
Attached Thumbnails
Click image for larger version

Name:	Pic1.jpg
Views:	9
Size:	28.8 KB
ID:	2504434   Click image for larger version

Name:	pic2.jpg
Views:	7
Size:	31.0 KB
ID:	2504436  
papaghiro is offline  
Sponsored Links
Advertisement
 
post #2 of 6 (permalink) Old 04-14-2019, 03:50 PM
BenzWorld Elite
 
Witek_M's Avatar
 
Date registered: Sep 2008
Vehicle: 1972
Location: Dallas, Texas
Posts: 6,092
Mentioned: 11 Post(s)
Quoted: 779 Post(s)
I am not sure I understand. Full charge leaks out in two weeks?

Another area to examine is inlet from high pressure hose to condenser and compressor front shaft.

1972 280SEL 4.5
1999 ML320
2000 E320
2003 ML350
Witek_M is offline  
post #3 of 6 (permalink) Old 04-14-2019, 05:41 PM Thread Starter
BenzWorld Newbie
 
papaghiro's Avatar
 
Date registered: Apr 2019
Vehicle: 2005 ML-500 SE
Location: Arizona
Posts: 4
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
(Thread Starter)
I don't think I can call it a full charge, but a treatment of the off the shelf AC Pro quick fix does take 2 to 3 weeks before the AC runs hot again. Another treatment will get me 2 to 3 weeks again. I did check over the rest of the system with the UV light. no other leaks show up. Compressor is clean and both lines for low and high pressure look clean under the UV light. Condenser was replaced about 2 years ago at the dealer , and it shows no leaks. even the schrader valves were showing no leaks. The pictures are the only place I see a leak with the UV.

I think my main concern is that i am not sure what I would see if the evaporator had a leak. From what I have read that is a full removal of the dashboard and would go well beyond my time to work on the vehicle. I was hoping someone may have had to change their expansion valve and saw the same leak pattern as in the pictures.

Thank you
papaghiro is offline  
Sponsored Links
Advertisement
 
post #4 of 6 (permalink) Old 04-15-2019, 03:27 AM
BenzWorld Elite
 
Witek_M's Avatar
 
Date registered: Sep 2008
Vehicle: 1972
Location: Dallas, Texas
Posts: 6,092
Mentioned: 11 Post(s)
Quoted: 779 Post(s)
Remove cabin filter and you are looking right at the evaporator.
papaghiro likes this.

1972 280SEL 4.5
1999 ML320
2000 E320
2003 ML350

Last edited by Witek_M; 04-15-2019 at 05:23 AM.
Witek_M is offline  
post #5 of 6 (permalink) Old 04-15-2019, 01:05 PM Thread Starter
BenzWorld Newbie
 
papaghiro's Avatar
 
Date registered: Apr 2019
Vehicle: 2005 ML-500 SE
Location: Arizona
Posts: 4
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
(Thread Starter)
Thank you for that suggestion! I will do that later on today!

John
papaghiro is offline  
post #6 of 6 (permalink) Old 04-15-2019, 05:46 PM Thread Starter
BenzWorld Newbie
 
papaghiro's Avatar
 
Date registered: Apr 2019
Vehicle: 2005 ML-500 SE
Location: Arizona
Posts: 4
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
(Thread Starter)
Jumped into the car again and took a look inside the interior air filter. The evaporator looks good, but can see the UV dye again right around the high pressure line where it passes through the firewall (see pictures below). I am more comfortable now with the idea its the valve and will be replacing it this weekend! Thank you again Witek_M for the way to see the evaporator!
Attached Thumbnails
Click image for larger version

Name:	pic5.jpg
Views:	3
Size:	35.8 KB
ID:	2504718  
papaghiro is offline  
Sponsored Links
Advertisement
 
Reply

  Mercedes-Benz Forum > Mercedes-Benz Vans/Trucks/SUV/Others > W163 M-Class

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Mercedes-Benz Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in











Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Topic Author Forum Replies Last Post
Lower Control Arm/Stuck Airmatic Set Screw/Inner Tie Rod oceanliner W220 S-Class 23 01-01-2016 10:33 PM
My 84 300sd restoration project sfraise W126 S,SE,SEC,SEL,SD,SDL Class 85 03-10-2015 07:14 PM
126 Euro Headlights and a Failed 107 Project strife2 W126 S,SE,SEC,SEL,SD,SDL Class 0 02-29-2008 10:58 PM
Brand New Set of 20" Zauber Gettin Wheels w/tires oplandj C215 CL-Class 0 09-08-2005 07:08 AM
FS-Complete Gasket Set with Extras scripley For Sale/Wanted/Trade/Giveaway 2 08-14-2005 03:26 PM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 

Title goes here

close
video goes here
description goes here. Read Full Story
For the best viewing experience please update your browser to Google Chrome