Finally enjoying my ML.... - Page 2 - Mercedes-Benz Forum
Reply
 
LinkBack Thread Tools Display Modes
post #11 of 20 (permalink) Old 03-28-2018, 05:18 PM
BenzWorld Member
 
ciprianmuresan's Avatar
 
Date registered: Mar 2018
Vehicle: 1999 ML320
Location: Michigan USA
Posts: 59
Mentioned: 0 Post(s)
Quoted: 10 Post(s)
Quote:
Originally Posted by khomer2 View Post
Agreed. Your choice of tire size fills it in nicely to give this beast the proper look it deserves.

None of that OEM size rubber...


Seriously, the oem tire size on the 99 ml320 is an abomination. Makes the car look like crap.


Sent from my iPhone using Tapatalk
ciprianmuresan is online now  
Sponsored Links
Advertisement
 
post #12 of 20 (permalink) Old 03-29-2018, 01:55 AM Thread Starter
BenzWorld Member
 
Kensk74's Avatar
 
Date registered: Jan 2018
Vehicle: 2001 ML320
Location: SW Florida
Posts: 78
Mentioned: 0 Post(s)
Quoted: 17 Post(s)
(Thread Starter)
Thank you Springer 🙂 I was contemplating using shell rotella 5w40 synthetic as I've had awesome luck with it in my Rover. I've got 185k miles on it.....that's extremely rare on that motor. But, after considering it only comes in 4qt jugs, not 5 like the Mobile 1, I'd have to buy 2 plus one more qt. I might just as well go with the M 1.

My ML I gave $3200 for and it had 134k miles on it (I've literally put 6k on it in the 3 months I've owned it)
Kensk74 is offline  
post #13 of 20 (permalink) Old 03-29-2018, 02:01 AM Thread Starter
BenzWorld Member
 
Kensk74's Avatar
 
Date registered: Jan 2018
Vehicle: 2001 ML320
Location: SW Florida
Posts: 78
Mentioned: 0 Post(s)
Quoted: 17 Post(s)
(Thread Starter)
Quote:
Originally Posted by ciprianmuresan View Post
Quote:
Originally Posted by khomer2 View Post
Agreed. Your choice of tire size fills it in nicely to give this beast the proper look it deserves.

None of that OEM size rubber...


Seriously, the oem tire size on the 99 ml320 is an abomination. Makes the car look like crap.


Sent from my iPhone using Tapatalk
Lol, I cranked the torsion bars to level with the rear, and I was like-them tires look like crap! Huge fender gap made them look dinky. I knew I was gonna go oversized for the off road use anyways, I was just pleasantly surprised at the difference it made in looks.

If you don't mind me asking, are your headlights like or the ones they sell on eBay? Any trouble installing or aiming them? I've been looking at them.....
Kensk74 is offline  
Sponsored Links
Advertisement
 
post #14 of 20 (permalink) Old 03-29-2018, 02:04 AM Thread Starter
BenzWorld Member
 
Kensk74's Avatar
 
Date registered: Jan 2018
Vehicle: 2001 ML320
Location: SW Florida
Posts: 78
Mentioned: 0 Post(s)
Quoted: 17 Post(s)
(Thread Starter)
Quote:
Originally Posted by khomer2 View Post
Agreed. Your choice of tire size fills it in nicely to give this beast the proper look it deserves.
None of that OEM size rubber...
Agreed, and they also don't Rob too much HP or mpg. I was worried about that. I put 31's on a Bronco 2 I had back in the day, literally lost around 3mpg
Kensk74 is offline  
post #15 of 20 (permalink) Old 03-29-2018, 04:20 AM
BenzWorld Member
 
ciprianmuresan's Avatar
 
Date registered: Mar 2018
Vehicle: 1999 ML320
Location: Michigan USA
Posts: 59
Mentioned: 0 Post(s)
Quoted: 10 Post(s)
Quote:
Originally Posted by Kensk74 View Post
Agreed, and they also don't Rob too much HP or mpg. I was worried about that. I put 31's on a Bronco 2 I had back in the day, literally lost around 3mpg


Well, if you are hoping to save fuel in an ML, regardless of the tire size, condition or mileage, then you bought the wrong car. Even my dad's 2.7 CDI in Europe has a horrible fuel mileage. At least we are lucky to have cheap fuel here in the great US. Over there they pay 5-6-7-sometimes even 10$ per gasoline gallon, depending on which part of Europe you are in.


Sent from my iPhone using Tapatalk
ciprianmuresan is online now  
post #16 of 20 (permalink) Old 03-29-2018, 08:16 AM Thread Starter
BenzWorld Member
 
Kensk74's Avatar
 
Date registered: Jan 2018
Vehicle: 2001 ML320
Location: SW Florida
Posts: 78
Mentioned: 0 Post(s)
Quoted: 17 Post(s)
(Thread Starter)
Lol, I'm definitely not complaining. I'm averaging 18mpg, which is awesome compared to the 11-12 my Rover gets
Kensk74 is offline  
post #17 of 20 (permalink) Old 03-29-2018, 08:26 AM
BenzWorld Newbie
 
Date registered: Mar 2018
Vehicle: 1999 ML430, 2006 ML500, 2013 C300
Location: Denver
Posts: 2
Mentioned: 0 Post(s)
Quoted: 1 Post(s)
ML 430 99 Headlight Change

Ordered new headlights for my ML430. They fit perfectly except they are for a 2002,2003. Now the high beams are on when you turn the lights on but no low beams. turn signals work. How can I get the low beams to work without sending these back. original lights were to faded to cleanup,tried..
Any help..
SteveS2018 is offline  
post #18 of 20 (permalink) Old 03-29-2018, 12:15 PM
BenzWorld Member
 
ciprianmuresan's Avatar
 
Date registered: Mar 2018
Vehicle: 1999 ML320
Location: Michigan USA
Posts: 59
Mentioned: 0 Post(s)
Quoted: 10 Post(s)
Quote:
Originally Posted by SteveS2018 View Post
Ordered new headlights for my ML430. They fit perfectly except they are for a 2002,2003. Now the high beams are on when you turn the lights on but no low beams. turn signals work. How can I get the low beams to work without sending these back. original lights were to faded to cleanup,tried..

Any help..


As far as I know you need to make some modifications in the headlight plug. There used to be a harness conversion adapter but again, as far as I know, nobody sells them anymore. Veterans of this forum will probably be able to give you details


Sent from my iPhone using Tapatalk
ciprianmuresan is online now  
post #19 of 20 (permalink) Old 03-29-2018, 12:22 PM
BenzWorld Member
 
ciprianmuresan's Avatar
 
Date registered: Mar 2018
Vehicle: 1999 ML320
Location: Michigan USA
Posts: 59
Mentioned: 0 Post(s)
Quoted: 10 Post(s)
Quote:
Originally Posted by Kensk74 View Post
If you don't mind me asking, are your headlights like or the ones they sell on eBay? Any trouble installing or aiming them? I've been looking at them.....


I apologize I just noticed this question. Yes they are eBay ching chong Chinese crap. I hate the ones with the goofy drl bar under the headlight so I looked for a pair that doesn't have one. I also wanted headlights that don't have any white color on them. I have to warn you, the light pattern is hilarious. I had to put a morimoto hid kit otherwise I couldn't see anything at night. They look good on the car but they are really bad at night. How much you paid for the 2002-2003 headlights? Are they hella OEM?


Sent from my iPhone using Tapatalk
ciprianmuresan is online now  
post #20 of 20 (permalink) Old 03-29-2018, 01:34 PM
BenzWorld Newbie
 
Date registered: Mar 2018
Vehicle: 1999 ML430, 2006 ML500, 2013 C300
Location: Denver
Posts: 2
Mentioned: 0 Post(s)
Quoted: 1 Post(s)
ML 430 99 Headlight Change

My new ones look the the black ones shown but chrome not black. Back side looks the same, definitely Tiawan. If I can't get an answer I'll just send them back, so far amazon takes everything back.. My wife even got a complete replacement for something they told her to throw away they did not want to pay the return shipping on.
SteveS2018 is offline  
Sponsored Links
Advertisement
 
Reply

  Mercedes-Benz Forum > Mercedes-Benz Vans/Trucks/SUV/Others > W163 M-Class

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Mercedes-Benz Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in











Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 

Title goes here

close
video goes here
description goes here. Read Full Story
For the best viewing experience please update your browser to Google Chrome