DTC P185800 & 1858-002??? - Mercedes-Benz Forum
Reply
 
LinkBack Thread Tools Display Modes
post #1 of 18 (permalink) Old 09-12-2014, 06:08 PM Thread Starter
BenzWorld Junior Member
 
Date registered: May 2008
Vehicle: 1972 450SL, 2014 ML350
Location: San Jose, USA
Posts: 30
Mentioned: 0 Post(s)
Quoted: 5 Post(s)
(Thread Starter)
DTC P185800 & 1858-002???

I have searched the site, the web, and am still trying to figure this out.

1998 ML320
CEL on
Intermit ETS and ABS

My new i980 iCarsoft scanner gives me:
P110108
P185800
P1858-002
P170300
P170302

As far as I can figure:
P110108 = right front wheel speed sensor

and now the probs begin:
P185800: ratio of HFM sensor signal to intake manifold pressure out of range
P1858-002 =?
P170200= ?
P170302= ?

Can anyone help me out with these?
What needs to be replaced to address "ratio of HFM etc ..."

Thanks for your time,

Alex

Last edited by Halexb; 09-12-2014 at 06:10 PM. Reason: Titlle should read P1858-002
Halexb is offline  
Sponsored Links
Advertisement
 
post #2 of 18 (permalink) Old 09-13-2014, 12:48 AM
Lifetime Premium Member
 
Date registered: Aug 2006
Vehicle: 02 ML320 06 ML500
Location: Bronx, New York
Posts: 16,588
Mentioned: 24 Post(s)
Quoted: 1543 Post(s)
Lifetime Premium Member
You have been a member since 2008 and never visited this site before?

Please UPDATE YOUR PROFILE in USER CP.
Attached Thumbnails
Click image for larger version

Name:	AAAAAAAAAA.jpg
Views:	208
Size:	56.5 KB
ID:	1121490  
43sqd is offline  
post #3 of 18 (permalink) Old 09-13-2014, 01:46 AM
Lifetime Premium Member
 
Date registered: Aug 2006
Vehicle: 02 ML320 06 ML500
Location: Bronx, New York
Posts: 16,588
Mentioned: 24 Post(s)
Quoted: 1543 Post(s)
Lifetime Premium Member
None of the codes you posted are "P" codes. You must be reading them incorrectly or the scanner is spitting out in invalid codes.
43sqd is offline  
Sponsored Links
Advertisement
 
post #4 of 18 (permalink) Old 09-13-2014, 10:03 AM Thread Starter
BenzWorld Junior Member
 
Date registered: May 2008
Vehicle: 1972 450SL, 2014 ML350
Location: San Jose, USA
Posts: 30
Mentioned: 0 Post(s)
Quoted: 5 Post(s)
(Thread Starter)
That makes sense. I'll recheck.

Thanks,

Alex
Halexb is offline  
post #5 of 18 (permalink) Old 09-14-2014, 08:53 AM Thread Starter
BenzWorld Junior Member
 
Date registered: May 2008
Vehicle: 1972 450SL, 2014 ML350
Location: San Jose, USA
Posts: 30
Mentioned: 0 Post(s)
Quoted: 5 Post(s)
(Thread Starter)
"Upgraded" code reader.
Cleared DTC log.
Drove car ~20miles.
Error P0130
Will check right front O2 sensor. It may not be connected any longer... since I replaced the exh system.

Thanks for the help!

Alex
Halexb is offline  
post #6 of 18 (permalink) Old 10-01-2014, 04:37 PM Thread Starter
BenzWorld Junior Member
 
Date registered: May 2008
Vehicle: 1972 450SL, 2014 ML350
Location: San Jose, USA
Posts: 30
Mentioned: 0 Post(s)
Quoted: 5 Post(s)
(Thread Starter)
Repl. right front wheel speed sensor:
ETS/ABS light out. Brake shudder gone.

Repl. O2 sensor.
CEL on
P0170 DTC
Repl MAF (Bosch)
Drive, clear codes, so far so good... no lights.


Thanks to you all for a great site!

and now 35,000 more miles till that 1M KM badge...
Halexb is offline  
post #7 of 18 (permalink) Old 10-02-2014, 01:46 PM Thread Starter
BenzWorld Junior Member
 
Date registered: May 2008
Vehicle: 1972 450SL, 2014 ML350
Location: San Jose, USA
Posts: 30
Mentioned: 0 Post(s)
Quoted: 5 Post(s)
(Thread Starter)
Ooops now CEL on again. P0170 and P0713

Short term trim bouncing all over the place (i980 Scanner)... Long term climbing (6.1 and rising)
Time to look for leaks
Halexb is offline  
post #8 of 18 (permalink) Old 10-03-2014, 04:50 AM
Lifetime Premium Member
 
Date registered: Aug 2006
Vehicle: 02 ML320 06 ML500
Location: Bronx, New York
Posts: 16,588
Mentioned: 24 Post(s)
Quoted: 1543 Post(s)
Lifetime Premium Member
Quote:
Originally Posted by Halexb View Post
Ooops now CEL on again. P0170 and P0713

Short term trim bouncing all over the place (i980 Scanner)... Long term climbing (6.1 and rising)
Time to look for leaks
Fuel trim readings are supposed to rise and fall constantly. Start looking for vacuum leaks.
43sqd is offline  
post #9 of 18 (permalink) Old 11-02-2014, 03:49 PM Thread Starter
BenzWorld Junior Member
 
Date registered: May 2008
Vehicle: 1972 450SL, 2014 ML350
Location: San Jose, USA
Posts: 30
Mentioned: 0 Post(s)
Quoted: 5 Post(s)
(Thread Starter)
I addressed a bad seal on throttle body to intake duct. Cleaned and resealed cyl head valve cover vents.
Replaced MAF (Bosch), fuel pump and fuel filter. Replaced loose (leaking?) brake vac hose to intake manifold clip/seal.
Went thru 3 cans of brake cleaner looking for vac leaks.... engine is now cleaner but could not detect any vacuum leaks.
Missed my annual regestration due to MIL ... but still looking for what is causing the remaining P0170.
Thanks again for assistance.

Quite frustrating
Halexb is offline  
post #10 of 18 (permalink) Old 11-03-2014, 02:42 AM
Lifetime Premium Member
 
Date registered: Aug 2006
Vehicle: 02 ML320 06 ML500
Location: Bronx, New York
Posts: 16,588
Mentioned: 24 Post(s)
Quoted: 1543 Post(s)
Lifetime Premium Member
So now you are saying that there is only code P0170?
43sqd is offline  
Sponsored Links
Advertisement
 
Reply

  Mercedes-Benz Forum > Mercedes-Benz Vans/Trucks/SUV/Others > W163 M-Class

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Mercedes-Benz Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in











Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 

Title goes here

close
video goes here
description goes here. Read Full Story
For the best viewing experience please update your browser to Google Chrome