w163 ML270 cdi abs pump - Mercedes-Benz Forum
Reply
 
LinkBack Thread Tools Display Modes
post #1 of 12 (permalink) Old 03-28-2011, 06:04 AM Thread Starter
BenzWorld Junior Member
 
Date registered: Feb 2011
Vehicle: 2001 ML270 cdi
Location: Philippines
Posts: 9
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
(Thread Starter)
w163 ML270 cdi abs pump

hi, i need your help. my ABS pump for my 2001 ML270 cdi is busted, no brake fluid is pumped out on one of the holes from the silver metal box of the ABS pump.
The part number of the unit is A1634310712, problem is I am having a hard time looking for the exact part number. would anyone know if other part numbers would work with my car? will an ML320 ABS pump with the same year work on my car?
I am from the Philippines and the car was originally an import so I am having a hard time looking for parts here. If anyone could help, I would greatly appreciate it, I couldn't use my car for more than a month already. thanks
gjo507 is offline  
Sponsored Links
Advertisement
 
post #2 of 12 (permalink) Old 03-28-2011, 06:15 AM
BenzWorld Elite
 
Witek_M's Avatar
 
Date registered: Sep 2008
Vehicle: 1972
Location: Dallas, Texas
Posts: 6,228
Mentioned: 15 Post(s)
Quoted: 828 Post(s)
Post your VIN number.

Some owners ware successful repairing pump motor.

https://www.benzworld.org/forums/w163...light=ABS+pump

1972 280SEL 4.5
1999 ML320
2000 E320
2003 ML350
Witek_M is offline  
post #3 of 12 (permalink) Old 03-28-2011, 06:21 AM Thread Starter
BenzWorld Junior Member
 
Date registered: Feb 2011
Vehicle: 2001 ML270 cdi
Location: Philippines
Posts: 9
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
(Thread Starter)
thanks for the reply,
my chassis no. is WDC1631131X739739
I had been searching these forums for almost a month already, and honestly read most of the articles regarding ABS pump, even tried some of the suggestions like resoldering the circuit board, but to no avail. it really seems that the mechanical part of my ABS is the busted one and not the electrical part.
I did a test on the 4 holes on the silver metal box connected to the 4 tires. I bled the brakes and loosened the 4 knots on the metal box, 3 of the holes emitted fluid except for the one problematic one.
gjo507 is offline  
Sponsored Links
Advertisement
 
post #4 of 12 (permalink) Old 03-28-2011, 07:43 AM
BenzWorld Elite
 
Witek_M's Avatar
 
Date registered: Sep 2008
Vehicle: 1972
Location: Dallas, Texas
Posts: 6,228
Mentioned: 15 Post(s)
Quoted: 828 Post(s)
Quote:
Originally Posted by gjo507 View Post
thanks for the reply,
my chassis no. is WDC1631131X739739
I had been searching these forums for almost a month already, and honestly read most of the articles regarding ABS pump, even tried some of the suggestions like resoldering the circuit board, but to no avail. it really seems that the mechanical part of my ABS is the busted one and not the electrical part.
I did a test on the 4 holes on the silver metal box connected to the 4 tires. I bled the brakes and loosened the 4 knots on the metal box, 3 of the holes emitted fluid except for the one problematic one.
What kind of problem are you having?

1972 280SEL 4.5
1999 ML320
2000 E320
2003 ML350
Witek_M is offline  
post #5 of 12 (permalink) Old 03-28-2011, 07:55 AM Thread Starter
BenzWorld Junior Member
 
Date registered: Feb 2011
Vehicle: 2001 ML270 cdi
Location: Philippines
Posts: 9
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
(Thread Starter)
As stated on my previous post, there is no brake fluid coming out on one of the holes of the metal box of the ABS pump, which specifically leads to the rear, left tire. As a result, my brake system is not working, and the brake pedal is down straight to the floor. The motor of the ABS Pump is working bec. 3 out of the 4 holes, there's fluid seeping through and when I bleed the from the 3 tires connected to those 3 holes, there's fluid coming out.
The part numbers of mercedes is so confusing and wondering maybe other part numbers aside from the one I posted would work. I kinda am giving up on trying to repair the unit anymore.
gjo507 is offline  
post #6 of 12 (permalink) Old 03-28-2011, 08:27 AM
BenzWorld Elite
 
Witek_M's Avatar
 
Date registered: Sep 2008
Vehicle: 1972
Location: Dallas, Texas
Posts: 6,228
Mentioned: 15 Post(s)
Quoted: 828 Post(s)
Hydraulic unit with pump. Part number 004 431 04 12. $1940.00 MSRP. Fits all ML up to 2002.

.
Attached Thumbnails
Click image for larger version

Name:	abs_pump.jpg
Views:	1389
Size:	65.3 KB
ID:	365948  

1972 280SEL 4.5
1999 ML320
2000 E320
2003 ML350
Witek_M is offline  
post #7 of 12 (permalink) Old 03-28-2011, 08:37 AM
BenzWorld Elite
 
Witek_M's Avatar
 
Date registered: Sep 2008
Vehicle: 1972
Location: Dallas, Texas
Posts: 6,228
Mentioned: 15 Post(s)
Quoted: 828 Post(s)
Witek_M is offline  
post #8 of 12 (permalink) Old 03-28-2011, 08:45 AM Thread Starter
BenzWorld Junior Member
 
Date registered: Feb 2011
Vehicle: 2001 ML270 cdi
Location: Philippines
Posts: 9
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
(Thread Starter)
Great. Thanks. Will check those out.
gjo507 is offline  
post #9 of 12 (permalink) Old 03-28-2011, 01:56 PM
Purple Moderator
 
Date registered: Jul 2005
Vehicle: 99 ML430, 00 ML320, 05 E500 4matic Wagon
Location: WI
Posts: 21,461
Mentioned: 34 Post(s)
Quoted: 1495 Post(s)
Lifetime Premium Member
It is a shame parts.com does not ship overseas. The MB OEM part is $1350 their.

If you have a friend or family member in the US you can get it that way.
Noodles is offline  
post #10 of 12 (permalink) Old 09-02-2011, 08:10 PM
BenzWorld Newbie
 
Date registered: Sep 2011
Posts: 1
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
My left front tire blew while driving today prompting my ABS light to come on. It now stays on while driving. I drive a ML320.
Thanks

Last edited by lawrence Nwolisa; 09-02-2011 at 08:19 PM. Reason: Added model of vehicle.
lawrence Nwolisa is offline  
Sponsored Links
Advertisement
 
Reply

  Mercedes-Benz Forum > Mercedes-Benz Vans/Trucks/SUV/Others > W163 M-Class

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Mercedes-Benz Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in











Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Topic Author Forum Replies Last Post
ETS ABS EPC ML270 CDI 2003 eviebo W163 M-Class 2 12-23-2010 05:40 PM
w163 2001 ml270 cdi tiptronic auto 5 speed mercsl320 W163 M-Class 1 04-19-2010 04:55 PM
Carlsson C-Tronic ML270 ( W163 ) Haydn W163 M-Class 0 12-01-2009 10:10 AM
ML270 / W163 Window mechanism BriBar W163 M-Class 3 11-13-2009 05:37 AM
ML270 CDI Year 2002 ABS and ETS light jonastra1 W163 M-Class 4 09-21-2007 06:27 AM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 

Title goes here

close
video goes here
description goes here. Read Full Story
For the best viewing experience please update your browser to Google Chrome