Interior lights are out – I’m a bozo - Mercedes-Benz Forum
Reply
 
LinkBack Thread Tools Display Modes
post #1 of 12 (permalink) Old 09-08-2010, 10:44 AM Thread Starter
BenzWorld Member
 
Date registered: Aug 2002
Vehicle: 2002 ML320
Location: CT
Posts: 247
Mentioned: 0 Post(s)
Quoted: 1 Post(s)
(Thread Starter)
Interior lights are out – I’m a bozo

A few weeks ago I posted a thread that my interior lights were no longer functioning (front dome lights, rear passenger reading lights), the glove box, visor, and rear hatch area lights were still working. I checked the fuses and bulbs and everything looked okay. Board member 43sqd provided me with assistance and helped me look at various possibilities (thanks 43sqd!!!). One thing that I noticed, with a test light the rear lights would start to illuminate indicating there was a ground issue. After a number of weeks trying things I finally made an appointment with the dealer to figure out the issue. Well, they figured it out and the issue was me.

Unknown to me, after 9 years of ownership, there is a switch on the overhead console to shut off the 4 interior lights. Why? I don’t know. I’m thinking it is for when you have a small child in the rear seat sleeping and you want to open the car door without having the lights wake the child??? On all my other vehicles, this functionality is part of the main front light switch. If you don’t want the lights on, you hit the button and they stay off for the car, and it is the same button you would hit to turn them all on. The ML has a separate button for the off function. Well, as you could probably guess by this point, somehow the button on my ML got hit and rendered the 4 lights off. When dropping the car off for service and showing them the issue the dealer quickly alerted me to that fact and with a simple hit of the switch, I’m working again (and I didn’t have to spend a dime at the dealer!!!, when was the last time that happened?)

So, for anyone else who has lost their interior lights and does a search on the topic, look for that switch and make sure it is in the proper position. Learn from my mistake.

Thanks

2002 ML320, black, inspiration leather interior, 7 passenger seating, MB DVD system
jeff968 is offline  
Sponsored Links
Advertisement
 
post #2 of 12 (permalink) Old 09-08-2010, 11:36 AM
BenzWorld Senior Member
 
Date registered: Aug 2010
Vehicle: 2001 ML430 Sport bought in very nice shape despite 156K miles in August 2010
Location: McLean, VA
Posts: 540
Mentioned: 0 Post(s)
Quoted: 3 Post(s)
You are not alone. Just bought an ML recently, and had a fairly long list of minor bugs to flatten including 'no interior lights'. After finally finding a user manual online, I discovered the switch. That discovery saved a lot a futile diagnostic work.
APKhaos is offline  
post #3 of 12 (permalink) Old 09-08-2010, 12:07 PM
BenzWorld Senior Member
 
Date registered: Sep 2009
Vehicle: 2000 Mercedes ML55 AMG, 2006 Mercedes ML350
Location: Canada
Posts: 493
Mentioned: 0 Post(s)
Quoted: 14 Post(s)
wait a second... where is this switch?
Brettriehl101 is offline  
Sponsored Links
Advertisement
 
post #4 of 12 (permalink) Old 09-08-2010, 12:39 PM
W163 Crash Test Driver
 
Planethill's Avatar
 
Date registered: Jun 2010
Vehicle: 2008 ML350 (Me!), 2010 GLK350 (Wife), 2003 ML-350 (Deceased)
Location: Putnam County, New York
Posts: 1,234
Mentioned: 0 Post(s)
Quoted: 183 Post(s)
Garage
Don't feel too bad. I have had my ML for a week or two and one of the things on MY list was "Low Range doesn't engage". I would push the button, the light would blink a few times, but no "clunk" etc. I was reading threads about frozen motors, etc, wondering what hoops I would have to go through to get it working.

Then over the weekend I was re-reading the manual and saw that it only engages if you are stopped, and in nuetral. Walked outside, started the truck, shifted to Neutral, pushed the button..."CLUNK!". The low range light on the dash lit up.
Planethill is offline  
post #5 of 12 (permalink) Old 09-08-2010, 12:41 PM
Lifetime Premium Member
 
Date registered: Aug 2006
Vehicle: 02 ML320 06 ML500
Location: Bronx, New York
Posts: 16,523
Mentioned: 23 Post(s)
Quoted: 1518 Post(s)
Lifetime Premium Member
Quote:
Originally Posted by Brettriehl101 View Post
wait a second... where is this switch?
It's on page 130 on the 2002 ML, I don't know on yours.
Attached Thumbnails
Click image for larger version

Name:	2010-09-08_153937.jpg
Views:	216
Size:	51.2 KB
ID:	329808  
43sqd is offline  
post #6 of 12 (permalink) Old 09-08-2010, 03:40 PM
BenzWorld Senior Member
 
Date registered: Sep 2009
Vehicle: 2000 Mercedes ML55 AMG, 2006 Mercedes ML350
Location: Canada
Posts: 493
Mentioned: 0 Post(s)
Quoted: 14 Post(s)
weird. dont think that switch is in the 00 models
Brettriehl101 is offline  
post #7 of 12 (permalink) Old 09-08-2010, 05:16 PM
BenzWorld Elite
 
Date registered: May 2006
Vehicle: 1990 190E 2.6,.... 1998 ML320, 2005 ML500SE
Location: New England
Posts: 3,077
Mentioned: 0 Post(s)
Quoted: 92 Post(s)
It's in the overhead console. You have to be laying on your back with your feet sticking out of the sunroof to see the switch.
Mike

Last edited by Mike's ML; 09-08-2010 at 05:26 PM.
Mike's ML is offline  
post #8 of 12 (permalink) Old 09-08-2010, 05:48 PM
BenzWorld Elite
 
megadamp's Avatar
 
Date registered: May 2008
Vehicle: 1999 ML320
Location: Manchester England
Posts: 2,800
Mentioned: 1 Post(s)
Quoted: 95 Post(s)
Don't think that switch is in the 99 ml. I have had my legs out the sunroof a few times. Never seen that one?.
megadamp is offline  
post #9 of 12 (permalink) Old 09-08-2010, 06:06 PM
BenzWorld Elite
 
bocabenz's Avatar
 
Date registered: Jul 2006
Vehicle: 2000 ML430 SOLD, 2007 BMW 328i Coupe, 2014 BMW i3
Location: South Florida
Posts: 2,982
Mentioned: 0 Post(s)
Quoted: 1 Post(s)
I don't know if the pre-facelift models have that switch... I can't say I've ever had my feet out the sunroof, but I know I don't have that switch on my overhead console.


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
bocabenz is offline  
post #10 of 12 (permalink) Old 09-08-2010, 06:52 PM
BenzWorld Elite
 
Michael Pillay's Avatar
 
Date registered: Oct 2003
Vehicle: 500SE AMG, E350 4matic, GL 450
Location: Michigan
Posts: 5,530
Mentioned: 0 Post(s)
Quoted: 124 Post(s)
My 01 has it.

Mike
Michael Pillay is online now  
Sponsored Links
Advertisement
 
Reply

  Mercedes-Benz Forum > Mercedes-Benz Vans/Trucks/SUV/Others > W163 M-Class

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Mercedes-Benz Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in











Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Topic Author Forum Replies Last Post
What part of this remains unclear? (Warning: Bozo Content) mlfun Off-Topic 16 01-09-2009 04:58 PM
RIP BOZO Multipurpose Off-Topic 1 07-03-2008 09:18 PM
Where can I find colored interior dome lights, door lights etc for the 126 560sel W126 S,SE,SEC,SEL,SD,SDL Class 7 05-07-2005 09:25 PM
interior lights went on brookolli W126 S,SE,SEC,SEL,SD,SDL Class 1 11-04-2002 04:59 PM
Interior lights elroythekid W126 S,SE,SEC,SEL,SD,SDL Class 1 10-02-2002 08:28 PM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 

Title goes here

close
video goes here
description goes here. Read Full Story
For the best viewing experience please update your browser to Google Chrome