BAS/ESP ETS ABS SRS All Lights are on! - Mercedes-Benz Forum
 
LinkBack Thread Tools Display Modes
post #1 of 5 (permalink) Old 05-08-2007, 03:40 PM Thread Starter
BenzWorld Newbie
 
Date registered: Apr 2007
Posts: 4
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
(Thread Starter)
BAS/ESP ETS ABS SRS All Lights are on!

Anyone know what would cause BAS/ESP, ETS, ABS, and the SRS lights to all come on? Check engine light isnt on though. Tried my basic scanner but it doesnt show anything since the engine light isnt on.

Thanks a lot.
noreason is offline  
Sponsored Links
Advertisement
 
post #2 of 5 (permalink) Old 05-29-2007, 08:26 AM
BenzWorld Member
 
Date registered: Jul 2004
Vehicle: 2000 E320 Wagon, 1999 E320 Sedan
Location: Seven Lakes, NC
Posts: 67
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
How to Fix BAS ESP ABS Malfunctions

BAS ESP ABS Malfunctions

I was successful (Haven't had the problem in about two months) in eliminating the problem by doing the following:

1. Start the car.
2. Step hard on the foot brake and hold it.
3. Step hard on the parking brake and hold it.
4. Release foot brake slowly.
5. Step hard on foot brake and release it slowly.
6. Step hard on foot brake and release it fast.
7. Step hard on foot brake and release it fast.
8. Release parking brake.
9. Turn off ignition.
10. Restart car and drive.

If the 3 malfunctions reoccur, repeat the above 10 steps two more times.
My malfunctions disappeared after two tries of the above.

Let me know if this works for you. I cannot be sure that my problem will not recur but it works for now. The car has been free of the malfunction lights for two months now.

UPDATE: The problem has recurred on September 15, 2007. I repeated steps 1-10 above (three times) and the malfunctions disappeared. Must be a good solution.

UPDATE: December 1, 2007 I was wrong about the above. My problem recurred and I replaced the brake light switch. Sorry if I misled anyone.

Ctrivett

Last edited by ctrivett; 12-01-2007 at 07:26 PM.
ctrivett is offline  
post #3 of 5 (permalink) Old 05-29-2007, 04:54 PM
BenzWorld Junior Member
 
Date registered: Apr 2007
Vehicle: 04 C240 4Matic, 03 C230 Komp Cpe, 00 ML55 AMG, 98 E320
Location: Arizona
Posts: 11
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Brake Switch ?? Try Replacing it..... $11.00 US from the dealer
StampsAuto is offline  
Sponsored Links
Advertisement
 
post #4 of 5 (permalink) Old 06-02-2007, 11:57 AM
BenzWorld Member
 
Benz_Boi's Avatar
 
Date registered: Feb 2007
Vehicle: 2001 Ml 430 Sport
Location: Michigan
Posts: 78
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Send a message via Yahoo to Benz_Boi
BRAKE SWITCH ! ! ! ! !

Costed me about 12 bucks at the dealer, only takes about 7 minutes to change. Do a forum search for detailed pics on this procedure...

She loves me, She loves me not...
Benz_Boi is offline  
post #5 of 5 (permalink) Old 06-02-2007, 04:27 PM
BenzWorld Elite
 
Date registered: Jan 2007
Vehicle: 2002 honda civic (sold), 2009 Mercedes ML350
Location: Miami, florida
Posts: 1,344
Mentioned: 0 Post(s)
Quoted: 4 Post(s)
I just worked on a 2000 ML with the exact same issue, ETS/BAS, ESP, SRS, check engine light on. the srs light was caused by a faulty child seat sensor, $100 says that is why your light is on, very common, and the others issues turned out to be that the trailer wiring harness was shorted to ground causing the brake light fuse to blow thus throwing codes for the stop lamp switch. probably not the issue with yours though, but hey who knows.
Streetglower is offline  
Sponsored Links
Advertisement
 
Reply

  Mercedes-Benz Forum > Mercedes-Benz Vans/Trucks/SUV/Others > W163 M-Class

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Mercedes-Benz Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in











Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Topic Author Forum Replies Last Post
ML320 - My ABS, BAS, ESP, ETS lights are on and the Tranny wont shift out of 1st gear Wephunk1 W163 M-Class 92 04-20-2012 07:41 PM
BAS/ESP ETS and ABS lights on LarryHarrison W163 M-Class 11 01-30-2012 06:49 AM
BAS/ESP ETS ABS lights staying on aussie1 W163 M-Class 6 01-11-2007 09:59 AM
ML 430 - 2000 - I NEED HELP!My BAS/ESP, ETS(ABS) and (Check Engine) lights come on. T nhaile W163 M-Class 3 09-19-2006 08:20 PM
01 ML320 ABS/ETS/BAS-ESP Lights On hlai W163 M-Class 6 06-21-2006 05:45 AM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 

Title goes here

close
video goes here
description goes here. Read Full Story
For the best viewing experience please update your browser to Google Chrome