ML 430 - 2000 - I NEED HELP!My BAS/ESP, ETS(ABS) and (Check Engine) lights come on. T - Mercedes-Benz Forum
 
LinkBack Thread Tools Display Modes
post #1 of 4 (permalink) Old 09-16-2006, 06:32 AM Thread Starter
BenzWorld Newbie
 
Date registered: Sep 2006
Posts: 2
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
(Thread Starter)
ML 430 - 2000 - I NEED HELP!My BAS/ESP, ETS(ABS) and (Check Engine) lights come on. T

My BAS/ESP, ETS(ABS) and (Check Engine) lights come on. The (Check Engine) light does not come off, however, the other lights come on and off. Today, they all came on and it was making a funny noise.

Can someone tell me what to do, or if you have similar problem how did you fix it and how much is the damage.

Thanking you in advance,
nhaile is offline  
Sponsored Links
Advertisement
 
post #2 of 4 (permalink) Old 09-16-2006, 08:18 AM
BenzWorld Elite
 
Wolfgang's Avatar
 
Date registered: Aug 2002
Vehicle: MBs
Location: Northern California
Posts: 2,656
Mentioned: 0 Post(s)
Quoted: 1 Post(s)
Probably your brake light switch. see timf's repair instructions:

https://www.benzworld.org/forums/w163...light-fix.html


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
Wolfgang is offline  
post #3 of 4 (permalink) Old 09-19-2006, 07:01 PM
BenzWorld Newbie
 
Date registered: Sep 2006
Posts: 2
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Hi, my wife has a 01 ml320. The car has had similar problems since we bought it.
The bas/ets, brake, lights come on every so often. This has been happening for over a year and 3 mechanics, and the dealership and a few thousand dollars later, it still happens. Every componet has been tested and retested. There are absouletly no mechanical or electrical problems with the car than the technicians can find.
We have replaced: Brake light switch 2 times, and reset it 4 times.
Replaced the battery, front brake pads, all four tires, and 3 dealership 4 wheel alignments. The BAS relay was replaced 2 times and some switches that have to do with the position of the front wheels. There was also 1 other relay that was changed but can't remember what it was.
The dealerships next plan for us to spend money on is to remove the entire steering column and replace some kind of switches under there. Approximately $2000.00 !!!
Not only do those lights come on...the chimer comes on as well.
There is no way to make these come on to demostrate to the service department and the only way to make them go off is to pull off the road, put the car in park and turn off the engine, trick it by opening the door to make it think you got out, wait 2 or so minutes and restart it and off you go!
Several several tecnicians from Mercedes have put their 2 cents in on this and we have spent almost $3000.00 in parts and labor......
The car is almost paid off, I told my wife to drive it for a few more months...then we are getting rid of it. I promise we have spent many hours with MB service people trying to figure this out and soon my wife will be driving a
2006 Hummer H3.
Good luck I sincerley hope your problem is something simple like the brake light switch, they only cost about $17...
pscarboni is offline  
Sponsored Links
Advertisement
 
post #4 of 4 (permalink) Old 09-19-2006, 08:20 PM
BenzWorld Elite
 
Wolfgang's Avatar
 
Date registered: Aug 2002
Vehicle: MBs
Location: Northern California
Posts: 2,656
Mentioned: 0 Post(s)
Quoted: 1 Post(s)
Quote:
Originally Posted by pscarboni
Not only do those lights come on...the chimer comes on as well.
The buzzer indicates an EBV malfunction. Might be a ABS sensor, connector or wiring problem. It can be difficult to troubleshoot if its intermittant... Wait until it fails hard next time and have it flatbedded to the dealer...



To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
Wolfgang is offline  
Sponsored Links
Advertisement
 
Reply

  Mercedes-Benz Forum > Mercedes-Benz Vans/Trucks/SUV/Others > W163 M-Class

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Mercedes-Benz Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in











Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Topic Author Forum Replies Last Post
BAS ESP and Check Engine Lights On dominic888 W163 M-Class 14 01-13-2009 07:12 AM
01 ML320 ABS/ETS/BAS-ESP Lights On hlai W163 M-Class 6 06-21-2006 05:45 AM
ML 320 problems, ESP BAS, ETS and ABS DSchonemann W163 M-Class 2 02-23-2006 08:13 PM
Help with BAS/ESP ETS ABS ByByeAmericanPie W163 M-Class 8 09-28-2005 04:40 PM
BAS/ETS, Brake & Check Engine lights came on bigcatny W163 M-Class 2 06-25-2003 12:59 AM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 

Title goes here

close
video goes here
description goes here. Read Full Story
For the best viewing experience please update your browser to Google Chrome