What is this squeaking sound in my engine - Mercedes-Benz Forum
 
LinkBack Thread Tools Display Modes
post #1 of 5 (permalink) Old 06-20-2019, 10:18 AM Thread Starter
BenzWorld Member
 
Date registered: Jul 2007
Vehicle: 2002 CL500, 2001 S500, 1997 S500, 1999 S320, 2005 ML500, 2005 CLK320, 2009 BMW 535xi, & 1975 Midget
Location: Atlanta, GA
Posts: 177
Mentioned: 1 Post(s)
Quoted: 28 Post(s)
(Thread Starter)
What is this squeaking sound in my engine

Hi all! I’ve replaced the exhaust system on my 97 S500 (132k miles) and getting it back on the road after a few months.

There’s a strange squeak coming from the back of the engine every 30 seconds or so.

I’ll attach a video here...

Well I can’t because I’m on my iPhone.

I’ll attach when I can...
MercedesMikeNAtlanta is offline  
Sponsored Links
Advertisement
 
post #2 of 5 (permalink) Old 06-20-2019, 01:37 PM Thread Starter
BenzWorld Member
 
Date registered: Jul 2007
Vehicle: 2002 CL500, 2001 S500, 1997 S500, 1999 S320, 2005 ML500, 2005 CLK320, 2009 BMW 535xi, & 1975 Midget
Location: Atlanta, GA
Posts: 177
Mentioned: 1 Post(s)
Quoted: 28 Post(s)
(Thread Starter)
Here's the video -




Please let me know your thoughts!

Thanks!!
MercedesMikeNAtlanta is offline  
post #3 of 5 (permalink) Old 06-22-2019, 10:57 AM
Moderator
 
Thom_7's Avatar
 
Date registered: Sep 2012
Vehicle: 1995 Mercedes S420, 2000 Land Rover Discovery II, 1985 Lotus Turbo Esprit
Location: New York, NY
Posts: 1,560
Mentioned: 7 Post(s)
Quoted: 218 Post(s)
Lifetime Premium Member
Hmmm are you sure it's coming from the back? Almost sounds like a belt or a bearing squeaking but that can't be if it's coming from the back.
Thom_7 is offline  
Sponsored Links
Advertisement
 
post #4 of 5 (permalink) Old 06-24-2019, 02:21 PM
Moderator
 
z168's Avatar
 
Date registered: Oct 2005
Vehicle: M20
Location: California
Posts: 4,737
Mentioned: 2 Post(s)
Quoted: 139 Post(s)
Lifetime Premium Member
Sounds like an intermittent vacuum leak. Either that or something is thriving back there

Deutsche Tourenwagen Meisterschaft
z168 is offline  
post #5 of 5 (permalink) Old 06-24-2019, 04:49 PM
BenzWorld Member
 
Mlthoma's Avatar
 
Date registered: Dec 2014
Vehicle: 96 S420
Location: Albuquerque, New Mexico, USA
Posts: 74
Mentioned: 0 Post(s)
Quoted: 18 Post(s)
squeaking sound

To me it sounds like the AC compressor clutch kicking. This would of course be on the front of the engine as well so I could be way off base. It is down low, though so you might hear it from underneath. Hit the econ button on your climate control to disable the AC compressor and see if it goes away. I once chased a hissing air leak behind the gauge cluster for half a day until I found it under the drivers seat.

MikeinABQ

You treat that car like it's a Mercedes or something!.
Mlthoma is offline  
Sponsored Links
Advertisement
 
Reply

  Mercedes-Benz Forum > Mercedes-Benz Sedan Forums > W140 S-Class

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Mercedes-Benz Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in











Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 

Title goes here

close
video goes here
description goes here. Read Full Story
For the best viewing experience please update your browser to Google Chrome