I hope ya'll don't think any less of me... - Mercedes-Benz Forum
 
LinkBack Thread Tools Display Modes
post #1 of 3 (permalink) Old 06-16-2019, 02:09 PM Thread Starter
BenzWorld Member
 
Date registered: Sep 2012
Vehicle: '95 S500 (sold), '97 E420
Posts: 227
Mentioned: 0 Post(s)
Quoted: 6 Post(s)
(Thread Starter)
I hope ya'll don't think any less of me...

But, in my search for another 140, I ran accross an E420 that was priced right, and got it.
I'm hoping that with a little TLC, I can drive it with a for sale sign in the window, and find another S500, or mabe a "beast".
Joe-V12 likes this.

Thanx,
Shorty.

"If you set out to fail, and succeed, which have you done?"
bluerooster is offline  
Sponsored Links
Advertisement
 
post #2 of 3 (permalink) Old 06-16-2019, 06:27 PM
BenzWorld Member
 
Date registered: Dec 2016
Posts: 58
Mentioned: 0 Post(s)
Quoted: 7 Post(s)
Congratulations! I had a w124 e420 several years ago. I assume yours is not a w210. It was a great car. Handled more nimbly than my s420. They seem to have similar issues as the w140s from around that era (wiring harnesses, evaporator). Having owned a few w124 chassis and spent thousand of miles in them, in my view, the w124 was among the most refined and rock solid chassis Mercedes ever made.

I will add that it must have taken quite a bit of engineering to shoehorn that motor into the engine bay. The worst job was trying to change the valve cover gaskets. The passenger side was practically against the firewall. If you ever do this job, make sure you have a very small 5 mm allen socket and lots of small extensions.

Best,
Brian
‘97 s420
Joe-V12 likes this.
BrianA77 is offline  
post #3 of 3 (permalink) Old 06-17-2019, 04:54 AM Thread Starter
BenzWorld Member
 
Date registered: Sep 2012
Vehicle: '95 S500 (sold), '97 E420
Posts: 227
Mentioned: 0 Post(s)
Quoted: 6 Post(s)
(Thread Starter)
It's a W210. I did the oil tubes on the left side, and plan to do the right side in a week or so.

Thanx,
Shorty.

"If you set out to fail, and succeed, which have you done?"
bluerooster is offline  
Sponsored Links
Advertisement
 
Reply

  Mercedes-Benz Forum > Mercedes-Benz Sedan Forums > W140 S-Class

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Mercedes-Benz Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in











Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 

Title goes here

close
video goes here
description goes here. Read Full Story
For the best viewing experience please update your browser to Google Chrome