Need Help ..... - Mercedes-Benz Forum
 
LinkBack Thread Tools Display Modes
post #1 of 6 (permalink) Old 04-22-2018, 11:33 AM Thread Starter
BenzWorld Member
 
Snipersking's Avatar
 
Date registered: Sep 2011
Vehicle: W140 1998 S320
Location: Iraq
Posts: 297
Mentioned: 0 Post(s)
Quoted: 31 Post(s)
(Thread Starter)
Unhappy Need Help .....

Hi everyone, this time it might be unusual problem am asking to help me out with. It's about this website I set an order from more than 6 months ago, https://www.transmissionpartsusa.com/ I ordered transmission parts since 11th of August 2017 and the parts still in the US, the seller unwilling either to refund or send me new order with a different shipping company. Please if you have any kind of experience with such an issue please PM me for more info so I can send the order info.


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
Snipersking is offline  
Sponsored Links
Advertisement
 
post #2 of 6 (permalink) Old 04-22-2018, 12:07 PM
BenzWorld Senior Member
 
GTO71's Avatar
 
Date registered: Apr 2014
Vehicle: W463,W204,W210, W123, W140
Location: North America & Скопје
Posts: 553
Mentioned: 1 Post(s)
Quoted: 90 Post(s)
Garage
Hard to say....is it a credit card purchase? Stop payment....if could be difficult to ship too Iraq from here.

1996 E320 Daily Driver
2008 C300 Wife's Daily
2002 Lifted G500 - Dream Car
1978 300D - Low Key Classic
1992 300SE - Limousine
1971 Pontiac GTO - Numbers Match
1995 Lifted Jeep Grand Cherokee
1985 CH150D Honda Elite
GTO71 is offline  
post #3 of 6 (permalink) Old 04-22-2018, 12:10 PM Thread Starter
BenzWorld Member
 
Snipersking's Avatar
 
Date registered: Sep 2011
Vehicle: W140 1998 S320
Location: Iraq
Posts: 297
Mentioned: 0 Post(s)
Quoted: 31 Post(s)
(Thread Starter)
Quote:
Originally Posted by GTO71 View Post
Hard to say....is it a credit card purchase? Stop payment....if could be difficult to ship too Iraq from here.


The problem is the shipping company lost the order


Sent from my iPhone using Tapatalk


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
Snipersking is offline  
Sponsored Links
Advertisement
 
post #4 of 6 (permalink) Old 04-22-2018, 12:44 PM
Moderator
Outstanding Contributor
 
MAVA's Avatar
 
Date registered: May 2006
Vehicle: 93 SL500, 95 SL320, 96 S320, 98 S500, 2002 E320 4Matic Wagon & A little 91 5.0 FORD Mustang
Location: Sacramento, California & El Dorado Hills, California, USA
Posts: 7,802
Mentioned: 37 Post(s)
Quoted: 1225 Post(s)
Lifetime Premium Member
You must have ordered 722.6 parts? I have placed orders from them-A few small ones, and one large one, and they all came.

I would bought it through ebay for someone like you in Iraq as ebay protects their buyers.

Or...

Found some US Service-Man there where they have special mail service, and you and the Service Man could have met-up.

Martin
Snipersking likes this.
MAVA is offline  
post #5 of 6 (permalink) Old 04-22-2018, 12:57 PM Thread Starter
BenzWorld Member
 
Snipersking's Avatar
 
Date registered: Sep 2011
Vehicle: W140 1998 S320
Location: Iraq
Posts: 297
Mentioned: 0 Post(s)
Quoted: 31 Post(s)
(Thread Starter)
Quote:
Originally Posted by MAVA View Post
You must have ordered 722.6 parts? I have placed orders from them-A few small ones, and one large one, and they all came.

I would bought it through ebay for someone like you in Iraq as ebay protects their buyers.

Or...

Found some US Service-Man there where they have special mail service, and you and the Service Man could have met-up.

Martin


Yes exactly its 722.6 parts small one and they confirmed they will ship it to Iraq and we have a daily mail from the US but for some reason it was lost


Sent from my iPhone using Tapatalk


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
Snipersking is offline  
post #6 of 6 (permalink) Old 07-10-2018, 11:15 PM Thread Starter
BenzWorld Member
 
Snipersking's Avatar
 
Date registered: Sep 2011
Vehicle: W140 1998 S320
Location: Iraq
Posts: 297
Mentioned: 0 Post(s)
Quoted: 31 Post(s)
(Thread Starter)
Update on the subject

Guys is there away any one in the area can contact this company because they literally ignore all my recent emails and the told me the will refund but it has been more than a month
I would appreciate any efforts from you guys


Sent from my iPhone using Tapatalk


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
Snipersking is offline  
Sponsored Links
Advertisement
 
Reply

  Mercedes-Benz Forum > Mercedes-Benz Sedan Forums > W140 S-Class

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Mercedes-Benz Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in











Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 

Title goes here

close
video goes here
description goes here. Read Full Story
For the best viewing experience please update your browser to Google Chrome