93 500SEL VS 95 S500 Alternator - Mercedes-Benz Forum
 
LinkBack Thread Tools Display Modes
post #1 of 5 (permalink) Old 02-23-2015, 12:03 PM Thread Starter
BenzWorld Extremist
 
Date registered: Apr 2008
Vehicle: 1995 Mercede-Benz S500
Location: USA
Posts: 1,169
Mentioned: 0 Post(s)
Quoted: 10 Post(s)
(Thread Starter)
93 500SEL VS 95 S500 Alternator

The alternator on my 95' S500 is slowly giving out to the point where i need to jump start it. The thing is that im trying to save a little bit of money by replacing it with an alternator from my old 93' that i still lifetime warranty from the auto parts shop. The 93' alternator has an output of 120amp VS the 95' alt putting out 143amp. Would you guys think it would be okay to drop a few amps?
hellah fresh is offline  
Sponsored Links
Advertisement
 
post #2 of 5 (permalink) Old 02-23-2015, 01:03 PM
BenzWorld Senior Member
 
The donut man's Avatar
 
Date registered: Aug 2012
Vehicle: 1996 s320 swb
Location: g'burg
Posts: 465
Mentioned: 0 Post(s)
Quoted: 56 Post(s)
These cars can be finicky....jump starting them is a gamble. The regulators for the alt are relatively inexpensive so that would be my route...I would load test your battery if it has been though some deep discharge cycles.

What is your output voltage? A battery on its way out WILL take the altenator with it.
The donut man is offline  
post #3 of 5 (permalink) Old 02-23-2015, 01:31 PM
Moderator
 
Jayare's Avatar
 
Date registered: Jun 2005
Vehicle: 86 190E 2.3L 16V, 2 95 320TE's, 02 S500
Location: Seminole, FL
Posts: 12,540
Mentioned: 10 Post(s)
Quoted: 1103 Post(s)
Lifetime Premium Member
Quote:
Originally Posted by hellah fresh View Post
The alternator on my 95' S500 is slowly giving out to the point where i need to jump start it. The thing is that im trying to save a little bit of money by replacing it with an alternator from my old 93' that i still lifetime warranty from the auto parts shop. The 93' alternator has an output of 120amp VS the 95' alt putting out 143amp. Would you guys think it would be okay to drop a few amps?
It's not OK. Spend the low money on a replacement voltage regulator.
Jayare is offline  
Sponsored Links
Advertisement
 
post #4 of 5 (permalink) Old 02-23-2015, 03:58 PM
BenzWorld Veteran
 
Date registered: Oct 2011
Vehicle: 1998 S320LWB
Location: Bay Area, Ca
Posts: 651
Mentioned: 0 Post(s)
Quoted: 55 Post(s)
I agree replace the VR
shimshon is offline  
post #5 of 5 (permalink) Old 02-23-2015, 06:25 PM Thread Starter
BenzWorld Extremist
 
Date registered: Apr 2008
Vehicle: 1995 Mercede-Benz S500
Location: USA
Posts: 1,169
Mentioned: 0 Post(s)
Quoted: 10 Post(s)
(Thread Starter)
Oh man i totally forgot to give you guys a background story a leaky valve cover gasket wore out the alternator. I took care of the gaskets using oem ones from the dealership. Luckly my battery isnt dead from being parked for 2 weeks so the alternator is charging but not much.
hellah fresh is offline  
Sponsored Links
Advertisement
 
Reply

  Mercedes-Benz Forum > Mercedes-Benz Sedan Forums > W140 S-Class

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Mercedes-Benz Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in











Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 

Title goes here

close
video goes here
description goes here. Read Full Story
For the best viewing experience please update your browser to Google Chrome