ABS ASR SPEEDOMETER QUESTION? - Page 2 - Mercedes-Benz Forum
Reply
 
LinkBack Thread Tools Display Modes
post #11 of 11 (permalink) Old 07-07-2015, 03:24 PM
BenzWorld Extremist
 
Date registered: Apr 2008
Vehicle: 1995 Mercede-Benz S500
Location: USA
Posts: 1,169
Mentioned: 0 Post(s)
Quoted: 10 Post(s)
Quote:
Originally Posted by alchemy View Post
Thanks Charles! You helped me fix mine
https://www.benzworld.org/forums/r129...ml#post5286657

note that my problems were the same yet I KNOW mine was caused during the reading and clearing of codes


!!!!!! I want to thank you for this information!

For the past 8 months i have been having problems after problems with my car starting with the dead battery, abs/asr light, clogged cat, car running rough, car dying on the road. Almost to the point of where i was thinking about selling the car smh. As of today i finally got the ABS/ASR light removed and its all because of that 10amp fuse that blew.

Im guessing that fuse went sometime when my battery was dying out. I was really trying to find an alternative/cheap fix before i pulled the trigger on a new speed sensor.

The lights are off, check engine lights are off and my speedometer is working again along with my steering wheel. It feels like a new car now.

Again i got lucky i came across this thread before making a new one but Thanks again for this great info! Cheers!

Now the next fix is my pse and ac system
hellah fresh is offline  
Sponsored Links
Advertisement
 
Reply

  Mercedes-Benz Forum > Mercedes-Benz Sedan Forums > W140 S-Class

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Mercedes-Benz Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in











Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Topic Author Forum Replies Last Post
OK! New problem! Just fixed the asr light, today, both the asr and the abs lights has come on! Cabbe W140 S-Class 23 04-12-2015 10:13 PM
Inoperable speedometer, ABS & ASR lights on due to "crossed" jumpstart petern12 W140 S-Class 8 01-24-2011 10:31 PM
300E ASR/ABS/Dealer says ABS Speed Sensor kasteveb W124 E,CE,D,TD Class 7 07-03-2009 06:39 AM
ETS and ABS lights on and no Speedometer markmck W210 E-Class 4 07-28-2008 12:31 PM
Speedometer / Abs / Traction Control Shipsake W210 E-Class 14 09-26-2007 11:40 AM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 

Title goes here

close
video goes here
description goes here. Read Full Story
For the best viewing experience please update your browser to Google Chrome