New Owner of a 1988 560SEL from SoCal OC - Mercedes-Benz Forum
 
LinkBack Thread Tools Display Modes
post #1 of 10 (permalink) Old 08-10-2019, 11:42 PM Thread Starter
BenzWorld Junior Member
 
ty423's Avatar
 
Date registered: Nov 2012
Vehicle: 1988 560SEL
Location: Buena Park SoCal
Posts: 7
Mentioned: 1 Post(s)
Quoted: 1 Post(s)
Garage
(Thread Starter)
New Owner of a 1988 560SEL from SoCal OC

Hello everyone,
Just got a benz. Friend's dad had it since new and didn't want to sell for awhile. I expressed my interest years ago and got the call that they want to sell. It's got some issues such as rear sag and transmission issues. Starts right up and almost everything works even the sunroof. Registered it to my name the other day but under Plan Of Non-operation for now until it is road worthy. I've lurked on here for about a week now and seems like I've got alot of reading and catching up to do. I am looking forward to chat with you guys. Cheers!
Attached Thumbnails
Click image for larger version

Name:	20190806_180002.jpg
Views:	11
Size:	3.88 MB
ID:	2533706  
ty423 is online now  
Sponsored Links
Advertisement
 
post #2 of 10 (permalink) Old 08-11-2019, 01:42 AM
Moderator
 
ianrandom's Avatar
 
Date registered: Jul 2008
Vehicle: 1986/1990 W126
Location: Berkshire & Devon, UK
Posts: 13,030
Mentioned: 28 Post(s)
Quoted: 1201 Post(s)
Lifetime Premium Member
Nice. Welcome!

'86 420SE
'90 420SEC


Daily transport 9spd Giant DH Comp downhill bike
ianrandom is online now  
post #3 of 10 (permalink) Old 08-11-2019, 09:49 AM
BenzWorld Senior Member
 
Date registered: Nov 2018
Vehicle: 1991 560SEL
Location: Richmond Virginia, USA
Posts: 508
Mentioned: 4 Post(s)
Quoted: 121 Post(s)
welcome! If you have SLS (Self Leveling) rear suspension, chances are the rear sag is due to the spheres under the rear. Ntt an expensive nor excessively difficult fix.
lesguy is offline  
Sponsored Links
Advertisement
 
post #4 of 10 (permalink) Old 08-11-2019, 03:35 PM
BenzWorld Elite
 
vdubpower's Avatar
 
Date registered: Nov 2003
Vehicle: 1985 500sel and 500sec 2012 E63 1989 Porsche 911
Location: So-Cal
Posts: 4,905
Mentioned: 13 Post(s)
Quoted: 568 Post(s)
nice...where about OC are u

theres a few of us around

kick the ferrari out of garage , put the mercs in side
vdubpower is offline  
post #5 of 10 (permalink) Old 08-12-2019, 01:44 AM Thread Starter
BenzWorld Junior Member
 
ty423's Avatar
 
Date registered: Nov 2012
Vehicle: 1988 560SEL
Location: Buena Park SoCal
Posts: 7
Mentioned: 1 Post(s)
Quoted: 1 Post(s)
Garage
(Thread Starter)
Quote:
Originally Posted by ianrandom View Post
Nice. Welcome!
Thank you!

Quote:
Originally Posted by lesguy View Post
welcome! If you have SLS (Self Leveling) rear suspension, chances are the rear sag is due to the spheres under the rear. Ntt an expensive nor excessively difficult fix.
Spheres? Are you talking about the accumulators? I was thinking maybe the leveler. I'm hoping it isn't the struts. Thanks for the advice!

Quote:
Originally Posted by vdubpower View Post
nice...where about OC are u

theres a few of us around

kick the ferrari out of garage , put the mercs in side
Lol I'm in Buena Park. I figure there is a SoCal group since there is so many car guys and all types of cars. Do you guys have a meet up once in awhile?

Ferrari and Benz is parked inside LOL my 2018 Volvo S90 is now outside. (Leased anyways lol)
ty423 is online now  
post #6 of 10 (permalink) Old 08-12-2019, 01:49 AM Thread Starter
BenzWorld Junior Member
 
ty423's Avatar
 
Date registered: Nov 2012
Vehicle: 1988 560SEL
Location: Buena Park SoCal
Posts: 7
Mentioned: 1 Post(s)
Quoted: 1 Post(s)
Garage
(Thread Starter)
So far went to LKQ Junkyard and picked up a few pieces that were broken. I wanted to get a new trunk iid chrome bar but all 4 W126 that were there were in bad shape.

Today fixed the left manual mirror. Was hard to adjust. Watched youtube and lubed all the joints. Smooth as butter now. I will fix the right side soon. It's not moving. I'm suspecting same problem that the joints are dirty and need lubing. I'm guessing electric motor is not strong enough to move it now. After that I'm guessing the switch is the problem. Also watched how to adjust the cable for the rear seat reclining mechanism. Going to do that as well. Mine is not moving but you can hear the motor. Haven't tried the heated seats but I don't mind that not working.
ty423 is online now  
post #7 of 10 (permalink) Old 08-12-2019, 07:28 AM
BenzWorld Senior Member
 
Date registered: Nov 2018
Vehicle: 1991 560SEL
Location: Richmond Virginia, USA
Posts: 508
Mentioned: 4 Post(s)
Quoted: 121 Post(s)
@ty423 : Yes..these

https://www.fcpeuro.com/products/mer...SABEgLG6vD_BwE

Easy way to check existing accumulators: Remove the line leading to them (use proper procedures) and GENTLY stick something ling in there..like a plastic chopstick with the dull end...you should encounter resistance within about an inch or 1.5 inches after insertion. If not, diaphram is no longer intact inside.
lesguy is offline  
post #8 of 10 (permalink) Old 08-12-2019, 07:28 AM
BenzWorld Senior Member
 
Date registered: Nov 2018
Vehicle: 1991 560SEL
Location: Richmond Virginia, USA
Posts: 508
Mentioned: 4 Post(s)
Quoted: 121 Post(s)
FYI. FCP has been my friend on my refresh project. 100% lifetime warranty on everything they sell...even motor oil/filters, etc.
lesguy is offline  
post #9 of 10 (permalink) Old Today, 01:14 AM
CH4S Artist
Outstanding Contributor
 
Teutone's Avatar
 
Date registered: Sep 2004
Vehicle: 1985 500SEC, 1991 190E 2.6.
Location: Los Angeles / Hannover Germany
Posts: 38,830
Mentioned: 19 Post(s)
Quoted: 1892 Post(s)
Lifetime Premium Member
Quote:
Originally Posted by ty423 View Post
So far went to LKQ Junkyard and picked up a few pieces that were broken. I wanted to get a new trunk iid chrome bar but all 4 W126 that were there were in bad shape.

Today fixed the left manual mirror. Was hard to adjust. Watched youtube and lubed all the joints. Smooth as butter now. I will fix the right side soon. It's not moving. I'm suspecting same problem that the joints are dirty and need lubing. I'm guessing electric motor is not strong enough to move it now. After that I'm guessing the switch is the problem. Also watched how to adjust the cable for the rear seat reclining mechanism. Going to do that as well. Mine is not moving but you can hear the motor. Haven't tried the heated seats but I don't mind that not working.
Btw, See 'Service Manual & Index sticky on top. The link to the free for US residents by Mercedes Benz USA (MBUSA) hosted W126 manual is there. It does require adobe.
It says disc 1 or 2 (like the NLA CD manual). One of them are all W126 diesel cars, the other gassers.
Cheers
Teutone is offline  
post #10 of 10 (permalink) Old Today, 01:25 AM Thread Starter
BenzWorld Junior Member
 
ty423's Avatar
 
Date registered: Nov 2012
Vehicle: 1988 560SEL
Location: Buena Park SoCal
Posts: 7
Mentioned: 1 Post(s)
Quoted: 1 Post(s)
Garage
(Thread Starter)
Quote:
Originally Posted by Teutone View Post
Btw, See 'Service Manual & Index sticky on top. The link to the free for US residents by Mercedes Benz USA (MBUSA) hosted W126 manual is there. It does require adobe.
It says disc 1 or 2 (like the NLA CD manual). One of them are all W126 diesel cars, the other gassers.
Cheers
Will do!
ty423 is online now  
Sponsored Links
Advertisement
 
Reply

  Mercedes-Benz Forum > Mercedes-Benz Sedan Forums > W126 S,SE,SEC,SEL,SD,SDL Class

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Mercedes-Benz Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in











Currently Active Users Viewing This Thread: 5 (1 members and 4 guests)
ty423



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 

Title goes here

close
video goes here
description goes here. Read Full Story
For the best viewing experience please update your browser to Google Chrome