Oil leak by Turbo - Mercedes-Benz Forum
 
LinkBack Thread Tools Display Modes
post #1 of 7 (permalink) Old 06-22-2019, 07:18 PM Thread Starter
BenzWorld Member
 
Petethemedic's Avatar
 
Date registered: Jun 2012
Vehicle: 1984 300 SD
Location: Galveston via Houston Via Detroit
Posts: 194
Mentioned: 0 Post(s)
Quoted: 15 Post(s)
(Thread Starter)
Oil leak by Turbo

Does anyone have an idea of the origin of this leak from looking at the picture?
All The Best,
Peter
Attached Thumbnails
Click image for larger version

Name:	20190622_210636_1561256211358.jpg
Views:	8
Size:	5.00 MB
ID:	2523056  
Petethemedic is offline  
Sponsored Links
Advertisement
 
post #2 of 7 (permalink) Old 06-24-2019, 01:17 PM
BenzWorld Member
 
Date registered: Jul 2018
Vehicle: 1981 300SD W126
Location: California USA
Posts: 66
Mentioned: 0 Post(s)
Quoted: 15 Post(s)
I would be interested in the reply as well as mine has a similar leak but not as much. Thanks in Advance
81300SD is offline  
post #3 of 7 (permalink) Old 06-24-2019, 05:27 PM Thread Starter
BenzWorld Member
 
Petethemedic's Avatar
 
Date registered: Jun 2012
Vehicle: 1984 300 SD
Location: Galveston via Houston Via Detroit
Posts: 194
Mentioned: 0 Post(s)
Quoted: 15 Post(s)
(Thread Starter)
I cleaned it up l, changed the big hose. Drovefrom Galveston to Biloxi and back.
I'll put it up on ramps and take a look tomorrow.
Petethemedic is offline  
Sponsored Links
Advertisement
 
post #4 of 7 (permalink) Old 06-29-2019, 07:47 AM
BenzWorld Member
 
Stewpot's Avatar
 
Date registered: Mar 2017
Vehicle: 1985 MB 500sel (Euro)
Location: Vero Beach, Florida
Posts: 89
Mentioned: 1 Post(s)
Quoted: 16 Post(s)
so what happened? could it be a leak from the power steering reservoir which might be above where the photo was taken?
Stewpot is offline  
post #5 of 7 (permalink) Old 06-29-2019, 01:30 PM Thread Starter
BenzWorld Member
 
Petethemedic's Avatar
 
Date registered: Jun 2012
Vehicle: 1984 300 SD
Location: Galveston via Houston Via Detroit
Posts: 194
Mentioned: 0 Post(s)
Quoted: 15 Post(s)
(Thread Starter)
It was the braided hose on the turbo/wastegate
Petethemedic is offline  
post #6 of 7 (permalink) Old 06-30-2019, 10:25 PM
BenzWorld Member
 
Date registered: Jul 2018
Vehicle: 1981 300SD W126
Location: California USA
Posts: 66
Mentioned: 0 Post(s)
Quoted: 15 Post(s)
Yours is branded? I thought they are suppose to be made out of silicon, did you replace it or......??
81300SD is offline  
post #7 of 7 (permalink) Old 07-02-2019, 04:15 PM
BenzWorld Junior Member
 
Date registered: Apr 2019
Vehicle: '83 240D Auto, '83 240D 4spd, '83 300SD, '83 300D, '89 300SEL, '10 E63
Location: Louisiana, USA
Posts: 10
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Hard to tell from that photo, but maybe the turbo oil feed line? That's at least where mine leaked
D1nman is offline  
Sponsored Links
Advertisement
 
Reply

  Mercedes-Benz Forum > Mercedes-Benz Sedan Forums > W126 S,SE,SEC,SEL,SD,SDL Class

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Mercedes-Benz Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in











Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 

Title goes here

close
video goes here
description goes here. Read Full Story
For the best viewing experience please update your browser to Google Chrome