ICV Weirdness (among other things) - Mercedes-Benz Forum
 
LinkBack Thread Tools Display Modes
post #1 of 7 (permalink) Old 05-18-2019, 06:02 PM Thread Starter
BenzWorld Junior Member
 
Date registered: Sep 2010
Vehicle: 1986 Aust. spec 420SEL, U1700L Unimog ex.ADF
Location: Canberra, Australia
Posts: 39
Mentioned: 0 Post(s)
Quoted: 1 Post(s)
(Thread Starter)
ICV Weirdness (among other things)

Hi all,

I recently bought my w126 1986 420SEL Australia model and I bought it in a hot climate so didn't realise the cold start issues it has. However, I did know it has a high idle in park and neutral (wish I had done this research more before buying the car). Anyway, it was cheap so I cannot complain too much.

So, I've been trying to track down the issues. And this is what I've found:

1) idle in park is at 650ish cold, 1150 hot. In drive 600ish forever.
2) has a strong fuel smell when idling for an extended period, like it's too rich.
3) the idle is a bit "bumpy" when stopped at traffic lights and it stutters while revving when you peg the throttle quickly (eg. no acceleration enrichment).
4) the OVP relay had a blown fuse in it (so, literally no computer or tuning, explains pretty much everything above - correct?).
5) replacing the OVP fuse causes too low an idle and the stalling condition on idle once warmer (even when driving down-hill etc, literally not drivable, so fuse removed again).
6) I tested the ICV in the car, gets a click with a 9v battery attached.
7) replaced the voltage regulator in the back of the alternator (brushes were pretty darn worn).
8) new OVP ordered (less than 2 weeks away from arriving)
9) pulled the idle controller from the passenger footwell, opened it up and noticed that two resistors were replaced with a single one in the middle of the board (not on the little daughter board part). But job looked good everything on the board appears fine (photo attached).
10) pulled the ICV out of the car, found as per the attached photos (cracked housing, hose stuffed down the guts, suspicions about the little crossover tube etc.)

My questions are:
1) do you think I'm on track/going the right way about this?
2) do the things I have encountered all add up?
3) with the ICV in the photos, why would have someone shoved a hose down into it?
4) is the little crossover tube that by passes the ICV meant to have an open end (aka so air can flow through it) or is mine correct with the closed end, as per the photo? (want to know if I need to replace that little tube too).
5) I'm going to be buying a new ICV, putting the new OVP in and provided my idle controller is okay, do you think this *should* fix my problems? (basically I'm asking does everything add up right)

Notes:
1) I'm also thinking of changing all the injectors out for new
2) putting a new bosch fuel pump in
3) new fuel filter and accumulator
4) apparently the distributor and leads were done on it, but you know how can I trust that in any way (but, they don't seem to be a problem).

Be really keen to hear from people!

Appreciate any help!

Aaron.
Attached Thumbnails
Click image for larger version

Name:	20190519_005715319_iOS.jpg
Views:	5
Size:	39.9 KB
ID:	2513902   Click image for larger version

Name:	20190519_005706572_iOS.jpg
Views:	4
Size:	46.0 KB
ID:	2513904   Click image for larger version

Name:	20190519_005701052_iOS.jpg
Views:	7
Size:	40.1 KB
ID:	2513906   Click image for larger version

Name:	20190518_062327259_iOS.jpg
Views:	7
Size:	64.2 KB
ID:	2513908   Click image for larger version

Name:	20190518_062304602_iOS.jpg
Views:	9
Size:	58.4 KB
ID:	2513910  

STOIE is offline  
Sponsored Links
Advertisement
 
post #2 of 7 (permalink) Old 05-18-2019, 06:44 PM
Outstanding Contributor
 
luckymike's Avatar
 
Date registered: Mar 2010
Vehicle: 1989 560SEC, 1989 560SEL, 1995 E420
Location: NorCal
Posts: 3,835
Mentioned: 9 Post(s)
Quoted: 567 Post(s)
Wow. You've got so much going on here I'm going to suggest carefully following the troubleshooting guide in the manual (available in the 'stickies' of this site) step by step, confirming along the way that each component meets specs. Surely in this manner you're apt to find what's wrong. See section 073-121.

You'll find great info there.
STOIE likes this.
luckymike is offline  
post #3 of 7 (permalink) Old 05-25-2019, 03:48 PM
BenzWorld Member
 
alexstorm's Avatar
 
Date registered: Jan 2011
Vehicle: 1983 380-SEL, '67 220D (sold), '65 200D (sold), '75 L-206D (sold)
Location: Los Angeles area
Posts: 284
Mentioned: 2 Post(s)
Quoted: 55 Post(s)
I fixed an high idle by resoldering the Idle Control Unit. It should be a last resort step, because you may damage it. If the solder contacts look milky, then this may be the issue. In these cars in California and in Europe I have fixed AC controllers, cruise controls and idle control boards all by resoldering. Obviously this step is useful due to the cost of replacing the boards. If you have access to an alternate board, that would be a good way to test prior to attempting any solder fix.

Hope that helps.
alexstorm is offline  
Sponsored Links
Advertisement
 
post #4 of 7 (permalink) Old 06-16-2019, 09:49 AM
BenzWorld Junior Member
 
Date registered: Apr 2019
Vehicle: 1990 420 SEC
Location: Finland
Posts: 20
Mentioned: 0 Post(s)
Quoted: 5 Post(s)
Have been trying to fix idle control too. Resoldering the controller helped a bit. Still idle is too high but there is some current to the valve. Next i have to check the capacitors and big transistors if they are ok. A notice on the troubleshooting guide. The TF voltages stated in the guide seem to be 10 times too high compared what they actually are. My car is model year 1990.

signal TF signal TD - PeachParts Mercedes-Benz Forum
Heikkif is offline  
post #5 of 7 (permalink) Old 06-16-2019, 10:37 AM
BenzWorld Member
 
alexstorm's Avatar
 
Date registered: Jan 2011
Vehicle: 1983 380-SEL, '67 220D (sold), '65 200D (sold), '75 L-206D (sold)
Location: Los Angeles area
Posts: 284
Mentioned: 2 Post(s)
Quoted: 55 Post(s)
I believe a vacuum leak can also cause a high idle. There are vacuum tests. Maybe just pull the vacuum off the timing advance on your distributor to see if the idle gets worse. I assume you have a distributor on that model.

If someone has fiddled with the throttle connecting bars adjustments, that also can cause a high idle. It's a bit of a process to get the throttle bar setting back to correct, but luckily, most people never touch those bars. The idle is automatically regulated, from what I understand, so tweaking the throttle bar spacing is an incorrect fix.

Having the timing off would make the idle rough rather than too high. It might be a factor. I think your SEL still has settings that can be done with a timing light. I set my 380 SEL at 14 degrees advanced for regular gas.

My guesses are a perfect example of why troubleshooting is a much better step to do first. You can go broke and waste a lot of time, trying to fix everything that might be causing an issue.

Previous post about a similar issue. I mentioned my steps to get my 380 SEL to start and idle like new. Lots of other people also commented on their fixes. Maybe something in this post is helpful.
https://www.benzworld.org/forums/w12...ark-issue.html
alexstorm is offline  
post #6 of 7 (permalink) Old 06-16-2019, 11:08 AM
BenzWorld Junior Member
 
Date registered: Apr 2019
Vehicle: 1990 420 SEC
Location: Finland
Posts: 20
Mentioned: 0 Post(s)
Quoted: 5 Post(s)
On my car now controller outputs around 1000 mA but idle on neutral is still around 900 rpm. Guide defines current 700-1000 mA when engine is idling warm. 12 v shortly to ICV will stall the engine. Possibly there are vacuum leaks as the car is old but economy gauge goes all the way to left on idle. Anyhow some previous owner had partially plugged idle air passage at front of ICV to make the car idle somehow. It is possible that he has adjusted air flap stop too to get idle adjusted.Throttle bar is not under tension when idling. Idle switch gets activated when pedal is not pushed. I'll take a look how and where the air flap stop is adjusted.
Heikkif is offline  
post #7 of 7 (permalink) Old 06-16-2019, 02:31 PM
BenzWorld Member
 
alexstorm's Avatar
 
Date registered: Jan 2011
Vehicle: 1983 380-SEL, '67 220D (sold), '65 200D (sold), '75 L-206D (sold)
Location: Los Angeles area
Posts: 284
Mentioned: 2 Post(s)
Quoted: 55 Post(s)
Nice video on a Mercedes R107 500SL
How to repair Mercedes High idle troubleshoot and cheap fix pt. 1

Part 2
alexstorm is offline  
Sponsored Links
Advertisement
 
Reply

  Mercedes-Benz Forum > Mercedes-Benz Sedan Forums > W126 S,SE,SEC,SEL,SD,SDL Class

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Mercedes-Benz Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in











Currently Active Users Viewing This Thread: 2 (0 members and 2 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Topic Author Forum Replies Last Post
'88 190e 2.3 - Vibration in Drive - Idle microswitch and ICV seem to be doing nothing adamdallas W201 190-Class 4 03-20-2019 01:11 PM
Odd idle issue Skunkwerks W126 S,SE,SEC,SEL,SD,SDL Class 111 01-01-2019 10:40 AM
Replace the ICV or ? StoreThomas W126 S,SE,SEC,SEL,SD,SDL Class 9 05-09-2012 06:56 PM
An Open Letter to those who don't understand What the Occupy Movement is about The Proctologist Off-Topic 1431 02-07-2012 08:41 AM
Need some help in finding the location of some things in my slk 230....o Kompressed230xs R170 SLK-Class 3 10-09-2011 09:42 PM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 

Title goes here

close
video goes here
description goes here. Read Full Story
For the best viewing experience please update your browser to Google Chrome