Rear window defroster - Mercedes-Benz Forum
 
LinkBack Thread Tools Display Modes
post #1 of 3 (permalink) Old 12-09-2018, 06:36 AM Thread Starter
Lifetime Premium Member
 
Tom Kaiser's Avatar
 
Date registered: Jul 2010
Vehicle: 1989 SEL 560
Location: Council Bluffs, Iowa
Posts: 505
Mentioned: 1 Post(s)
Quoted: 134 Post(s)
Lifetime Premium Member
(Thread Starter)
Rear window defroster

While testing to see if my vehicle starts better in cold weather I am able to document that the rear window defroster is not functioning properly. Has anyone seen this defrost pattern before and what is the solution?
Attached Thumbnails
Click image for larger version

Name:	DSCN3568.jpg
Views:	30
Size:	94.6 KB
ID:	2471766   Click image for larger version

Name:	DSCN3570.jpg
Views:	23
Size:	94.9 KB
ID:	2471768   Click image for larger version

Name:	DSCN3575.jpg
Views:	21
Size:	74.7 KB
ID:	2471770  
Tom Kaiser is offline  
Sponsored Links
Advertisement
 
post #2 of 3 (permalink) Old 12-09-2018, 06:56 AM
Lifetime Premium Member
 
281lxm's Avatar
 
Date registered: Dec 2011
Vehicle: 1991 560 SEC 1994 E500 2014 E350 Cab
Location: Houston, TX
Posts: 7,012
Mentioned: 3 Post(s)
Quoted: 435 Post(s)
Lifetime Premium Member
Garage
If you have ever seen the glass edge not installed, you may have seen the silver metal along the lower vertical edge and curve. Possible that the copper wires have pulled away as the glass separates over time or they have just broken the contact. For me, the few times I need to defrost, i just scrape. I removed the plug from the switch to avoid heating the glue that holds the glass halves together.


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

_____________________________________________
1991 560SEC 199 /268, 17" RS90'S, Eibach springs, Bilstein HD shocks, Custom rear sway bar, Euro Headlights, Custom ceramic coated headers and down pipes with stainless dual exhaust, W140 glass sunroof, dog ear trunk spoiler, OEM Skid Plate, Euro bumpers, wood refinish and restored.
281lxm is offline  
post #3 of 3 (permalink) Old 12-09-2018, 09:31 AM
BenzWorld Member
 
kevdupuis's Avatar
 
Date registered: May 2016
Vehicle: 1985 300 TD 1981 300 SD
Location: Belleville On. Ca.
Posts: 273
Mentioned: 1 Post(s)
Quoted: 37 Post(s)
Quote:
Originally Posted by Tom Kaiser View Post
While testing to see if my vehicle starts better in cold weather I am able to document that the rear window defroster is not functioning properly. Has anyone seen this defrost pattern before and what is the solution?
Yours is in better shape than mine I only get one thin line across the the middle, once I have some extra time I'll stop in at a local glass shop and see if they have or can get an after market defroster grid and have that installed on my 81.
kevdupuis is offline  
Sponsored Links
Advertisement
 
Reply

  Mercedes-Benz Forum > Mercedes-Benz Sedan Forums > W126 S,SE,SEC,SEL,SD,SDL Class

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Mercedes-Benz Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in











Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 

Title goes here

close
video goes here
description goes here. Read Full Story
For the best viewing experience please update your browser to Google Chrome