Brand new aftermarket water pump leaking, anyone had this?? - Mercedes-Benz Forum
 
LinkBack Thread Tools Display Modes
post #1 of 8 (permalink) Old 01-11-2016, 01:30 PM Thread Starter
BenzWorld Elite
 
StreekG's Avatar
 
Date registered: Oct 2005
Vehicle: 1978 C123 280CE, 1988 500SEC, MY10 W204 C200 CGI
Location: Melbourne, Australia
Posts: 1,377
Mentioned: 1 Post(s)
Quoted: 48 Post(s)
Send a message via MSN to StreekG
(Thread Starter)
Brand new aftermarket water pump leaking, anyone had this??

Hi guys,

Replaced my water pump a few months ago with an aftermarket german brand. I have noticed this weekend coolant leaking all over my new concrete driveway. I inspected and it's coming from that little plug/weep hole on the water pump. What kind of madness is this? There was no pressure going through the main hose to the water pump either. Aside from this the entire cooling system is brand new!

I'm seriously chasing my tail right now with this car, luckily i bought myself a daily last week (MY10 W204 C200 CGI)

'88 500SEC M117.965 - Feind Stage II Cams, Feind Adjustable cam gears, Dkubus FrankenCIS DPR, Dkubus Race coil ignition [EZL Delete],Dkubus 2000rpm Hi-Stall torque converter, Full S/S Twin 2.5" Magnaflow exhaust, Eibach Springs, Bilstein B8 Sprint Shocks, Dkubus thick rear sway bar.

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
StreekG is offline  
Sponsored Links
Advertisement
 
post #2 of 8 (permalink) Old 01-11-2016, 04:56 PM
Lifetime Premium Member
 
281lxm's Avatar
 
Date registered: Dec 2011
Vehicle: 1991 560 SEC 1994 E500 2014 E350 Cab
Location: Houston, TX
Posts: 7,012
Mentioned: 3 Post(s)
Quoted: 435 Post(s)
Lifetime Premium Member
Garage
I bought the same brand that my car had from Autohausaz. Original had MB star on it, and the one from Autohausaz did not, but they were identical when I did the job. Cannot remember it just now, but I feel you, its not a job I wish to do again/.
mramay likes this.


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

_____________________________________________
1991 560SEC 199 /268, 17" RS90'S, Eibach springs, Bilstein HD shocks, Custom rear sway bar, Euro Headlights, Custom ceramic coated headers and down pipes with stainless dual exhaust, W140 glass sunroof, dog ear trunk spoiler, OEM Skid Plate, Euro bumpers, wood refinish and restored.
281lxm is offline  
post #3 of 8 (permalink) Old 01-11-2016, 05:43 PM
BenzWorld Elite
 
mramay's Avatar
 
Date registered: Feb 2005
Vehicle: Two '87 570SECs, one '87 560SEL
Location: Las Vegas, NV
Posts: 4,401
Mentioned: 6 Post(s)
Quoted: 249 Post(s)
For the next pump, slot the bottom hole in the pump so it slides over that bottom bolt. From that point on, the harmonic balancer won't have to be removed to get that @#$%^& bolt out. Just remember to put a decent washer on the bolt when you put it back in that last time.

Blasphemous Mike
US '87 560SEC with Euro headlights, clear markers, H&Rs, 17x8.5/Nitto's, ATE slotted rotors with ceramic pads, BergWerks FGS, 3.07 Limited Slip. '87 560SEL with Euro Headlights, lowered, 235/40/17's
mramay is offline  
Sponsored Links
Advertisement
 
post #4 of 8 (permalink) Old 01-11-2016, 06:20 PM
Outstanding Contributor
 
John350's Avatar
 
Date registered: Nov 2014
Vehicle: 1990 350SDL, "Grandpa's Roadster" Project Car
Location: New Hampshire
Posts: 2,828
Mentioned: 9 Post(s)
Quoted: 800 Post(s)
Quote:
Originally Posted by StreekG View Post
There was no pressure going through the main hose to the water pump either.
What do you mean by that? There are two reasons coolant comes out the weep hole: first, the impeller seal is bad and second, the system has excess pressure (combustion pressure leaking into the cooling system.)

John
"Real engines don't have spark plugs!"
John350 is offline  
post #5 of 8 (permalink) Old 01-11-2016, 07:09 PM Thread Starter
BenzWorld Elite
 
StreekG's Avatar
 
Date registered: Oct 2005
Vehicle: 1978 C123 280CE, 1988 500SEC, MY10 W204 C200 CGI
Location: Melbourne, Australia
Posts: 1,377
Mentioned: 1 Post(s)
Quoted: 48 Post(s)
Send a message via MSN to StreekG
(Thread Starter)
Quote:
Originally Posted by John350 View Post
What do you mean by that? There are two reasons coolant comes out the weep hole: first, the impeller seal is bad and second, the system has excess pressure (combustion pressure leaking into the cooling system.)
Ok, so the coolant on the weep hole was deceiving, we identified the problem as that short little hose that goes from the pump to the engine. New hose clamps and repositioning fix the issue and a pressure test was done, all good! Saved me a lot of money.
mramay likes this.

'88 500SEC M117.965 - Feind Stage II Cams, Feind Adjustable cam gears, Dkubus FrankenCIS DPR, Dkubus Race coil ignition [EZL Delete],Dkubus 2000rpm Hi-Stall torque converter, Full S/S Twin 2.5" Magnaflow exhaust, Eibach Springs, Bilstein B8 Sprint Shocks, Dkubus thick rear sway bar.

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
StreekG is offline  
post #6 of 8 (permalink) Old 01-12-2016, 05:13 AM
Outstanding Contributor
 
John350's Avatar
 
Date registered: Nov 2014
Vehicle: 1990 350SDL, "Grandpa's Roadster" Project Car
Location: New Hampshire
Posts: 2,828
Mentioned: 9 Post(s)
Quoted: 800 Post(s)
Gotta love a cheap fix!

John
"Real engines don't have spark plugs!"
John350 is offline  
post #7 of 8 (permalink) Old 01-12-2016, 10:31 AM
BenzWorld Elite
 
dadrab's Avatar
 
Date registered: Sep 2013
Vehicle: 1986 560 SEL
Location: Augusta, Ga.
Posts: 1,485
Mentioned: 3 Post(s)
Quoted: 283 Post(s)
Attaboy.

Glad she's fixed.
dadrab is offline  
post #8 of 8 (permalink) Old 01-12-2016, 12:36 PM
Lifetime Premium Member
 
281lxm's Avatar
 
Date registered: Dec 2011
Vehicle: 1991 560 SEC 1994 E500 2014 E350 Cab
Location: Houston, TX
Posts: 7,012
Mentioned: 3 Post(s)
Quoted: 435 Post(s)
Lifetime Premium Member
Garage
The notch issue IIRC @mramay was to dremel out the cast hole at or about the 5 o'clock area on the housing of a WP prior to install. This way an upside down horseshoe look will cover over a bolt you can loosen and not remove from the engine, thus leaving the HB firmly attached and saving *(&^)&^%(^*&*%&^%#@&^% language, sore back from bending and about 2-3 hours of extra hassle.


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

_____________________________________________
1991 560SEC 199 /268, 17" RS90'S, Eibach springs, Bilstein HD shocks, Custom rear sway bar, Euro Headlights, Custom ceramic coated headers and down pipes with stainless dual exhaust, W140 glass sunroof, dog ear trunk spoiler, OEM Skid Plate, Euro bumpers, wood refinish and restored.
281lxm is offline  
Sponsored Links
Advertisement
 
Reply

  Mercedes-Benz Forum > Mercedes-Benz Sedan Forums > W126 S,SE,SEC,SEL,SD,SDL Class

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Mercedes-Benz Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in











Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 

Title goes here

close
video goes here
description goes here. Read Full Story
For the best viewing experience please update your browser to Google Chrome