HVAC question... - Mercedes-Benz Forum
Reply
 
LinkBack Thread Tools Display Modes
post #1 of 15 (permalink) Old 05-19-2019, 09:57 PM Thread Starter
BenzWorld Veteran
 
Robert Kyle's Avatar
 
Date registered: Feb 2018
Vehicle: 1994 e320 coupe (sold), 1990 300CE ($400 beater)
Location: Seattle, WA, USA
Posts: 705
Mentioned: 1 Post(s)
Quoted: 160 Post(s)
(Thread Starter)
HVAC question...

When the button is set to blow air to your feet, does some air still blow through the defrost?

I can see the Pod move from the different settings, but some still go through the vents as aforementioned.

Would the Pod be needing replaced? If I force the lever more, no air gets through.
Attached Thumbnails
Click image for larger version

Name:	20190517_184104-1.jpg
Views:	10
Size:	61.8 KB
ID:	2514200  
Robert Kyle is offline  
Sponsored Links
Advertisement
 
post #2 of 15 (permalink) Old 05-20-2019, 04:58 AM
BenzWorld Elite
 
tuttebenne's Avatar
 
Date registered: Jul 2005
Vehicle: W124
Location: Long Island
Posts: 4,533
Mentioned: 6 Post(s)
Quoted: 474 Post(s)
My understanding has been that there is not a setting for footwell only. There is "footwell and defrost " and "footwell with less deftrost"
Jayare and Real1shepherd like this.

'
'93 400E
'93 500E
'94 E320TE
'00 E320
'02 E320
'73 Alfa GTV
'77 308GTB
tuttebenne is offline  
post #3 of 15 (permalink) Old 05-22-2019, 05:18 PM Thread Starter
BenzWorld Veteran
 
Robert Kyle's Avatar
 
Date registered: Feb 2018
Vehicle: 1994 e320 coupe (sold), 1990 300CE ($400 beater)
Location: Seattle, WA, USA
Posts: 705
Mentioned: 1 Post(s)
Quoted: 160 Post(s)
(Thread Starter)
Hmm...so this is normal?
Attached Thumbnails
Click image for larger version

Name:	Clipboard01.jpg
Views:	9
Size:	43.0 KB
ID:	2514928  
Robert Kyle is offline  
Sponsored Links
Advertisement
 
post #4 of 15 (permalink) Old 05-22-2019, 10:32 PM
Lifetime Premium Member
 
Real1shepherd's Avatar
 
Date registered: Jul 2009
Vehicle: '92 300TE 4matic 280,000miles, '92 300TE 4Matic 'Ice Blue Metalic' 101,000miles
Location: Washington
Posts: 9,895
Mentioned: 2 Post(s)
Quoted: 482 Post(s)
Lifetime Premium Member
On the TE's because there is so much glass, which is a bad thing in the summer......we found that the button second from the left allows some defrost air, which is actually cold air with the AC on. This helps in dispelling some of the heat coming through the windshield, especially sitting in traffic. Button third from the left does not allow 'enough' defrost air to hit windshield. Now the 'economy' button I'd have to play with to give you an answer there, but I don't think it gives 'enough' defrost air to do anything and it bypasses the AC. If memory serves....anytime the windshield is starting to cloud (like on rainy days), you have to retreat back to the second button from the left.

I've always found the HVAC control switching a very strange functioning array on the 124's. Logical yes, but poor ergonomics. And as your pods wear, the system gets downright funky.

Kevin

Last edited by Real1shepherd; 05-22-2019 at 10:36 PM.
Real1shepherd is offline  
post #5 of 15 (permalink) Old 05-23-2019, 05:18 AM Thread Starter
BenzWorld Veteran
 
Robert Kyle's Avatar
 
Date registered: Feb 2018
Vehicle: 1994 e320 coupe (sold), 1990 300CE ($400 beater)
Location: Seattle, WA, USA
Posts: 705
Mentioned: 1 Post(s)
Quoted: 160 Post(s)
(Thread Starter)
I prefer NO defrost air on any settings except the far left button.

Dries my eyes
Robert Kyle is offline  
post #6 of 15 (permalink) Old 05-23-2019, 05:28 AM
Lifetime Premium Member
 
Aero I's Avatar
 
Date registered: Sep 2008
Vehicle: 04 E500 359; 00 SL500 040/Pano; 99 SL500 366/Pano; 94 E420 744; 92 500E 481; 92 500E 199; 92 300CE
Location: Mid Hudson Valley, NY
Posts: 1,886
Mentioned: 5 Post(s)
Quoted: 175 Post(s)
Lifetime Premium Member
Just general info on the vacuum pods that may be useful.
Check out this link, a thread in another forum specifically on 124 vacuum pods for the HVAC system.

https://www.500eboard.co/forums/inde...-update.10906/

Spoiler alert - as you read through the tread you will see that in the last 2 years several of the pods are NLA.

I was reading this thread in real time 2 years ago, and decided to source new pods for all 4 of my 124's, and I was able to get them all, including the parts to rebuild the center vent pods.

I haven't done anything with them yet, they are all sitting on the shelf for when I get more time.

I need to change out the pods in the 94 E420 first, at least 3 of them are not working right, and the center pod on my 92 Bornite 500E isn't working.

Hopefully Mercedes may do another run of these critical parts some day, or a aftermarket company will.

I'm still in favor of the old fashion controls that used manually operated cables to operate the flaps. They never break and will out last the car. I really don't need a thermostat to maintain temps, easy enough to manually set controls. The last car/truck I seen with manual heater/AC controls on was my old 94 Pathfinder, they worked perfect, never failed and if a cable was to ever fail, any old generic choke cable could be modified to fit.

All these USA Mercedes features are nice until they stop making replacement parts for them.


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
Ms. Bornite
Daily Drivers:
06 Lexus GX470
94 E420-744

Seasonal Daily Drivers:
00 SL500-040/Pano
99 SL500-366/Pano
92 500E-199
92 300CE-199

Seasonal Week-End Warriors:
04 E500-359
92 500E-481/498

Retired:
99-SL500-040 (T-Boned Parts Car RIP)
94 Pathfinder - "Old Rusty" sold
81-380SL-735 (Sold & exported to China)
Aero I is offline  
post #7 of 15 (permalink) Old 05-23-2019, 07:49 AM Thread Starter
BenzWorld Veteran
 
Robert Kyle's Avatar
 
Date registered: Feb 2018
Vehicle: 1994 e320 coupe (sold), 1990 300CE ($400 beater)
Location: Seattle, WA, USA
Posts: 705
Mentioned: 1 Post(s)
Quoted: 160 Post(s)
(Thread Starter)
Okay, thanks for the info on the pods, but I still need confirmation on what the OEM behaviour is.

The far right buttons (not including the Off button), one is STILL to get air coming out of the defroster vent?

I feel like stuff a rag in those vents to keep my eyes from drying out.
Robert Kyle is offline  
post #8 of 15 (permalink) Old 05-23-2019, 08:14 AM
Outstanding Contributor
 
luckymike's Avatar
 
Date registered: Mar 2010
Vehicle: 1989 560SEC, 1989 560SEL, 1995 E420
Location: NorCal
Posts: 3,788
Mentioned: 7 Post(s)
Quoted: 553 Post(s)
Quote:
Originally Posted by Robert Kyle View Post
Okay, thanks for the info on the pods, but I still need confirmation on what the OEM behaviour is.

The far right buttons (not including the Off button), one is STILL to get air coming out of the defroster vent?

I feel like stuff a rag in those vents to keep my eyes from drying out.
Section 83-600 of the manual describes how the system is designed to work. You should find your answer there.

I tried to attach it but it's too big. Available on this site, though.
luckymike is online now  
post #9 of 15 (permalink) Old 05-23-2019, 08:56 AM Thread Starter
BenzWorld Veteran
 
Robert Kyle's Avatar
 
Date registered: Feb 2018
Vehicle: 1994 e320 coupe (sold), 1990 300CE ($400 beater)
Location: Seattle, WA, USA
Posts: 705
Mentioned: 1 Post(s)
Quoted: 160 Post(s)
(Thread Starter)
From this, it looks like there IS supposed to be "enough" air coming out of the defroster vents from those last two right buttons:
Attached Thumbnails
Click image for larger version

Name:	Clipboard01.jpg
Views:	10
Size:	56.6 KB
ID:	2515030  
Robert Kyle is offline  
post #10 of 15 (permalink) Old 05-23-2019, 09:06 AM
Outstanding Contributor
 
luckymike's Avatar
 
Date registered: Mar 2010
Vehicle: 1989 560SEC, 1989 560SEL, 1995 E420
Location: NorCal
Posts: 3,788
Mentioned: 7 Post(s)
Quoted: 553 Post(s)
Quote:
Originally Posted by Robert Kyle View Post
From this, it looks like there IS supposed to be "enough" air coming out of the defroster vents from those last two right buttons:
Yes, but apparently only when the system is heating. Is that how yours is working?
luckymike is online now  
Sponsored Links
Advertisement
 
Reply

  Mercedes-Benz Forum > Mercedes-Benz Sedan Forums > W124 E,CE,D,TD Class

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Mercedes-Benz Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in











Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Topic Author Forum Replies Last Post
HVAC box rebuild and install 91 SEC alydon W126 S,SE,SEC,SEL,SD,SDL Class 16 08-09-2014 05:14 AM
HVAC ctr vent and controller question Gungatim R129 SL-Class 3 05-31-2011 04:55 AM
The Question of God by Steve Martin Nightbird Off-Topic 8 11-28-2010 01:41 PM
Introduction and a question Porschescum W163 M-Class 5 07-19-2006 12:09 PM
President Bush authorized the leak MBZ300CD Off-Topic 79 04-10-2006 08:48 PM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 

Title goes here

close
video goes here
description goes here. Read Full Story
For the best viewing experience please update your browser to Google Chrome