Rough idle stall when at operating temp - Mercedes-Benz Forum
 
LinkBack Thread Tools Display Modes
post #1 of 7 (permalink) Old 05-18-2019, 06:12 PM Thread Starter
BenzWorld Newbie
 
Date registered: May 2019
Posts: 3
Mentioned: 0 Post(s)
Quoted: 1 Post(s)
(Thread Starter)
Rough idle stall when at operating temp

My parents have a 94 E420. If you start it and go it runs great but as soon as the temp gague hits about halfway it has a rough idle and if you go into gear it hesitates and runs really rough and will stall if you don't feather the gas. Any ideas?
richmas99 is offline  
Sponsored Links
Advertisement
 
post #2 of 7 (permalink) Old 05-19-2019, 09:53 PM
BenzWorld Veteran
 
Robert Kyle's Avatar
 
Date registered: Feb 2018
Vehicle: 1994 e320 coupe (sold), 1990 300CE ($400 beater)
Location: Seattle, WA, USA
Posts: 705
Mentioned: 1 Post(s)
Quoted: 160 Post(s)
Bio harness upgraded?
Robert Kyle is offline  
post #3 of 7 (permalink) Old 05-19-2019, 09:59 PM Thread Starter
BenzWorld Newbie
 
Date registered: May 2019
Posts: 3
Mentioned: 0 Post(s)
Quoted: 1 Post(s)
(Thread Starter)
Yup harness replaced. Fuel pumps replaced. Rotors caps and coils all replaced to.
richmas99 is offline  
Sponsored Links
Advertisement
 
post #4 of 7 (permalink) Old 05-20-2019, 11:11 AM
Moderator
 
Jayare's Avatar
 
Date registered: Jun 2005
Vehicle: 86 190E 2.3L 16V, 2 95 320TE's, 02 S500
Location: Seminole, FL
Posts: 12,443
Mentioned: 10 Post(s)
Quoted: 1064 Post(s)
Lifetime Premium Member
Check the caps and rotors again. They have a propensity to cause problems. If the suppressor disk weren't replaced, they most likely need to be.

Jayare

Sent from my XT1710-02 using Tapatalk
Real1shepherd likes this.
Jayare is offline  
post #5 of 7 (permalink) Old 05-20-2019, 11:21 AM Thread Starter
BenzWorld Newbie
 
Date registered: May 2019
Posts: 3
Mentioned: 0 Post(s)
Quoted: 1 Post(s)
(Thread Starter)
What are surpressor disks? Lol
richmas99 is offline  
post #6 of 7 (permalink) Old 05-20-2019, 12:08 PM
BenzWorld Extremist
 
speed9644's Avatar
 
Date registered: May 2013
Vehicle: '94 E220
Location: Israel
Posts: 1,186
Mentioned: 1 Post(s)
Quoted: 158 Post(s)
Garage
check the fuel pressure regulator


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.


- Samir
speed9644 is offline  
post #7 of 7 (permalink) Old 05-20-2019, 12:39 PM
Moderator
 
Jayare's Avatar
 
Date registered: Jun 2005
Vehicle: 86 190E 2.3L 16V, 2 95 320TE's, 02 S500
Location: Seminole, FL
Posts: 12,443
Mentioned: 10 Post(s)
Quoted: 1064 Post(s)
Lifetime Premium Member
Quote:
Originally Posted by richmas99 View Post
What are surpressor disks? Lol
The orange disk that sits behind the rotor. You have to remove the rotor bracket to replace them. It's a very simple job. In the meantime, pull the caps, clean them and spray them with some WD 40. See if that doesn't solve the rough running condition. This is a common problem on V8 models. Especially if they aren't driven daily.

Sent from my XT1710-02 using Tapatalk
tuttebenne likes this.
Jayare is offline  
Sponsored Links
Advertisement
 
Reply

  Mercedes-Benz Forum > Mercedes-Benz Sedan Forums > W124 E,CE,D,TD Class

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Mercedes-Benz Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in











Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Topic Author Forum Replies Last Post
'82 230E, rough idle / no reaction from idle screw osprey W123 E,CE,D,CD,TD,TE Class 14 11-08-2015 11:34 AM
Summer temp up -rough idle gone??? darraghodonnell R129 SL-Class 0 07-12-2010 01:44 PM
89 420SEL rough idle, and stall at start up, economy gauge.... Hiendguy W126 S,SE,SEC,SEL,SD,SDL Class 0 07-05-2010 10:03 PM
Intermittent engine stall causes? 500SEL drcvd W140 S-Class 12 12-04-2009 09:26 AM
ROUGH IDLE, IDLE CONTROL UNIT LOCATION, TIMING & RPM verdejor General Mercedes-Benz 5 01-22-2006 08:41 PM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 

Title goes here

close
video goes here
description goes here. Read Full Story
For the best viewing experience please update your browser to Google Chrome