Eco junk disease rears its ugly head again - Page 2 - Mercedes-Benz Forum
Reply
 
LinkBack Thread Tools Display Modes
post #11 of 15 (permalink) Old 07-24-2018, 05:43 PM
BenzWorld Elite
 
tuttebenne's Avatar
 
Date registered: Jul 2005
Vehicle: W124
Location: Long Island
Posts: 4,533
Mentioned: 6 Post(s)
Quoted: 474 Post(s)
Quote:
Originally Posted by Verbal View Post
How could this be? Porsche is highly rated by J D Power.
JD Power like many others is just a "rating for hire". You pay, they give you an award.
Real1shepherd likes this.

'
'93 400E
'93 500E
'94 E320TE
'00 E320
'02 E320
'73 Alfa GTV
'77 308GTB
tuttebenne is offline  
Sponsored Links
Advertisement
 
post #12 of 15 (permalink) Old 07-25-2018, 11:24 AM
BenzWorld Senior Member
 
Verbal's Avatar
 
Date registered: Mar 2014
Vehicle: 1994 E320, 1997 E420, 1999 E320 4MATIC
Location: Seattle
Posts: 581
Mentioned: 0 Post(s)
Quoted: 158 Post(s)
Garage
My J D Power question was in jest, of course.
tuttebenne likes this.

"I think of a man, and I take away reason and accountability."
Verbal is offline  
post #13 of 15 (permalink) Old 07-29-2018, 02:42 AM
Lifetime Premium Member
 
LeftCoastGeek's Avatar
 
Date registered: Jul 2011
Vehicle: 1993 300CE Cabriolet (mine) ; 1994 E320 Wagon (wife's) ; 1990 Benz 300E 2.6 (son's)
Location: S'Cruzin Around on the Left Coast
Posts: 6,506
Mentioned: 14 Post(s)
Quoted: 1296 Post(s)
Lifetime Premium Member
Quote:
Originally Posted by 126guyMD View Post
Itís a known fact that some Volvo models had eco-junk harnesses as well. So itís good to know per this thread that s.Baertís diagnostic expertise extends to non MB eco-junk Marques as well. Havenít seen him on the Porsche and Volvo forums, though.

Question: does ChingChangChung and LongDuckDong Ltd. also make smelly rubber parts for Porsche and Volvo?
The Volvos with the bad harnesses were 1982 or 83 to mid 1987. mostly 240 and early 740 models. our late 87 240 went nearly a half million miles, albeit with a broken odometer for the 2nd half of that journey.


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
. . . . .
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
. . . . .
LeftCoastGeek is offline  
Sponsored Links
Advertisement
 
post #14 of 15 (permalink) Old 07-30-2018, 11:07 AM
BenzWorld Veteran
 
Date registered: Apr 2010
Vehicle: '89 560SEC, '90 560SEL
Location: God's country, near Billings MT
Posts: 656
Mentioned: 2 Post(s)
Quoted: 108 Post(s)
Hmmm, my Dad had a 760, I think '89, that would randomly die because of wiring issues. Could it have been the eco junk wiring in that too? Anyway, considering how much electronics new cars have on them, using anything other than top-grade wiring falls somewhere between planned obsolescence and criminal negligence. Either way, not something I want anything to do with. Meanwhile, the wiring in my old Fairlane shows no significant degradation despite being 54 years old. No wonder we can't put a man on the moon anymore: we can't even make good wiring!

'89 560SEC, 234K, pearl white with palomino interior - Liesl
'90 560SEL, 192K, champagne with mushroom interior - Ingrid
'97 Ford F250, 189K, diesel, blue, 4x4, manual
'64 Ford Fairlane with approximately 240K
MT_Merc is offline  
post #15 of 15 (permalink) Old 07-30-2018, 11:32 AM
Lifetime Premium Member
 
LeftCoastGeek's Avatar
 
Date registered: Jul 2011
Vehicle: 1993 300CE Cabriolet (mine) ; 1994 E320 Wagon (wife's) ; 1990 Benz 300E 2.6 (son's)
Location: S'Cruzin Around on the Left Coast
Posts: 6,506
Mentioned: 14 Post(s)
Quoted: 1296 Post(s)
Lifetime Premium Member
the 760 V6's had their own set of issues, the PRV (peugeot/renault/volvo) 2.8L V6 was a problematic motor, ate camshafts, etc. the 760 turbo 4's had the same engines as 740/940 turbos, generally reliable as long as they weren't in the ecojunk years of 82-87


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
. . . . .
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
. . . . .
LeftCoastGeek is offline  
Sponsored Links
Advertisement
 
Reply

  Mercedes-Benz Forum > Mercedes-Benz Sedan Forums > W124 E,CE,D,TD Class

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Mercedes-Benz Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in











Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 

Title goes here

close
video goes here
description goes here. Read Full Story
For the best viewing experience please update your browser to Google Chrome