300E 2.6 throttle cable repair - Mercedes-Benz Forum
 
LinkBack Thread Tools Display Modes
post #1 of 3 (permalink) Old 04-07-2014, 06:24 PM Thread Starter
BenzWorld Junior Member
 
Date registered: Oct 2013
Vehicle: 1990 300E Sedan
Location: Georgia, USA
Posts: 21
Mentioned: 0 Post(s)
Quoted: 2 Post(s)
(Thread Starter)
300E 2.6 throttle cable repair

Anybody got a good close-up photo of how the throttle cable is SUPPOSED to attach the the throttle lever on the engine?

Today I had the exact problem as described in this video, and on the side of the road I fixed it almost the same way. Fortunately I had some cable ties in my American Express Kit (I never leave home without it).

The end of the throttle cable was just laying there, not connected to anything. The throttle lever has a (now empty) square hole in it. Obviously, the cable goes through the hole and then something goes in the hole to retain it. What does that something look like? Just a plain rubber or plastic grommet, or something more elaborate?

Axel Griese is offline  
Sponsored Links
Advertisement
 
post #2 of 3 (permalink) Old 04-07-2014, 07:00 PM
Lifetime Premium Member
 
LeftCoastGeek's Avatar
 
Date registered: Jul 2011
Vehicle: 1993 300CE Cabriolet (mine) ; 1994 E320 Wagon (wife's) ; 1990 Benz 300E 2.6 (son's)
Location: S'Cruzin Around on the Left Coast
Posts: 6,495
Mentioned: 14 Post(s)
Quoted: 1294 Post(s)
Lifetime Premium Member
I might have a picture showing the linkage on my 1990 300E 2.6, let me look...



hope that helps. not as clear as I'd like, it was a side thought to take since I'd removed the fuel distributor assembly.
Axel Griese likes this.
LeftCoastGeek is offline  
post #3 of 3 (permalink) Old 04-07-2014, 07:30 PM Thread Starter
BenzWorld Junior Member
 
Date registered: Oct 2013
Vehicle: 1990 300E Sedan
Location: Georgia, USA
Posts: 21
Mentioned: 0 Post(s)
Quoted: 2 Post(s)
(Thread Starter)
Ah, so ALL the hardware on the end of the cable ends up on the other side of the grommet. That's what had me confused.

Thanks.
Axel Griese is offline  
Sponsored Links
Advertisement
 
Reply

  Mercedes-Benz Forum > Mercedes-Benz Sedan Forums > W124 E,CE,D,TD Class

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Mercedes-Benz Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in











Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 

Title goes here

close
video goes here
description goes here. Read Full Story
For the best viewing experience please update your browser to Google Chrome