Leaking prechambers OM603 - Mercedes-Benz Forum
 
LinkBack Thread Tools Display Modes
post #1 of 9 (permalink) Old 12-10-2009, 02:21 PM Thread Starter
BenzWorld Junior Member
 
Date registered: May 2008
Posts: 37
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
(Thread Starter)
Leaking prechambers OM603

Hi, I have a `91 300 TD Turbo(Euro/Norwegian).
OM603.960 engine
I ofcoarse have trouble with leaks around the prechambers, some small leaks at cyl 3 and 4, but after I checked my nozzles, I`ve got a decent leak at cylinder 1, It`s squirting diesel out of the half-moon next to the prechamber-locking-nut, and the engine runs om 5 cylinders at idle.

I have ofcoarse checked the nozzle/injector, changed the injector seal ring. But Cant find anything.

I have bought a socket with the correct splines(KLANN KL-0369-3), and will try to pull them out tomorrow, but I dont have the grinding tool, or shims, I`m going to make a tool for pulling out the prechamber from a used nozzle.

Do you have any tips forr me, what I should do, how?
I`m thinking about using a thin copper or aluminium washer for the seal if I need to, and maybe take a little cut in the prechambers to keep correct position of them.

Do you have anything for me, experinces, other stuff.

Thanks from Norway...

W124.023

I`m from Norway and not so good at English
brEinar is offline  
Sponsored Links
Advertisement
 
post #2 of 9 (permalink) Old 12-10-2009, 03:58 PM
Lifetime Premium Member
 
Real1shepherd's Avatar
 
Date registered: Jul 2009
Vehicle: '92 300TE 4matic 280,000miles, '92 300TE 4Matic 'Ice Blue Metalic' 101,000miles
Location: Washington
Posts: 9,924
Mentioned: 2 Post(s)
Quoted: 487 Post(s)
Lifetime Premium Member
Quote:
Originally Posted by brEinar View Post
Hi, I have a `91 300 TD Turbo(Euro/Norwegian).
OM603.960 engine
I ofcoarse have trouble with leaks around the prechambers, some small leaks at cyl 3 and 4, but after I checked my nozzles, I`ve got a decent leak at cylinder 1, It`s squirting diesel out of the half-moon next to the prechamber-locking-nut, and the engine runs om 5 cylinders at idle.

I have ofcoarse checked the nozzle/injector, changed the injector seal ring. But Cant find anything.

I have bought a socket with the correct splines(KLANN KL-0369-3), and will try to pull them out tomorrow, but I dont have the grinding tool, or shims, I`m going to make a tool for pulling out the prechamber from a used nozzle.

Do you have any tips forr me, what I should do, how?
I`m thinking about using a thin copper or aluminium washer for the seal if I need to, and maybe take a little cut in the prechambers to keep correct position of them.

Do you have anything for me, experinces, other stuff.

Thanks from Norway...
Not to turn you away, but I think this site offers a forum just for diesel MB owners, although many are in here as well. I stumbled into a discussion once in there about compression leakdown testing. Check it out.

Kevin
Real1shepherd is offline  
post #3 of 9 (permalink) Old 12-10-2009, 05:03 PM
Cruise Control
 
Zeitgeist's Avatar
 
Date registered: Sep 2004
Vehicle: '87 300TD/'90 300D/'94 Quattro/'89 Vanagon TDI/'01 EV Weekender VR6
Location: Cascadia
Posts: 52,233
Mentioned: 8 Post(s)
Quoted: 1682 Post(s)
Lifetime Premium Member
Did you install new pre-chambers? Sometimes these will interfere with the bosses in the head, which requires some machining to ensure a tight seal.
Zeitgeist is offline  
Sponsored Links
Advertisement
 
post #4 of 9 (permalink) Old 12-11-2009, 01:54 AM Thread Starter
BenzWorld Junior Member
 
Date registered: May 2008
Posts: 37
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
(Thread Starter)
The prechambers in my head have been there from the factory, but I got a hell of a leak after disassembling the injectors(Checking spray pattern/pressure).
But I may change them, I got a Spare head with cracks, so if it`s somthing wrong with them I`ve got 6 "new ones".

W124.023

I`m from Norway and not so good at English
brEinar is offline  
post #5 of 9 (permalink) Old 12-11-2009, 02:19 AM
Cruise Control
 
Zeitgeist's Avatar
 
Date registered: Sep 2004
Vehicle: '87 300TD/'90 300D/'94 Quattro/'89 Vanagon TDI/'01 EV Weekender VR6
Location: Cascadia
Posts: 52,233
Mentioned: 8 Post(s)
Quoted: 1682 Post(s)
Lifetime Premium Member
So, you didn't remove the pre-chambers at all, and just had the injectors out--right? Are you sure the injector heat shields are installed correctly, with the curved surface facing downward? I can't imagine how diesel could possibly make its way out around the outside of the pre-chamber.

Years ago I installed a new cylinder head and had a couple of pre-chambers leak combustion gases around the outside. So, I removed them and ground off a little bit of the surface where they were interfering with the head.
Zeitgeist is offline  
post #6 of 9 (permalink) Old 12-11-2009, 03:45 AM Thread Starter
BenzWorld Junior Member
 
Date registered: May 2008
Posts: 37
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
(Thread Starter)
The injector seal ring is correctly mounted as you describe, also tried to change it, the engine is not running on cylinder 1 at idle after this, I think that is why it "squirts" diesel.
i tried disassembling them on my old cylinder head, but i Need some longer tools, not enought power.

W124.023

I`m from Norway and not so good at English
brEinar is offline  
post #7 of 9 (permalink) Old 12-11-2009, 07:20 AM Thread Starter
BenzWorld Junior Member
 
Date registered: May 2008
Posts: 37
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
(Thread Starter)
The problem is fixed for now.
The prechamber nut was loose, a bit cleaning, w/o removing the prechamber, and a good tightening, and the problem was gone, :-)

But I have the normal leak at a couple of other cylinders, so any tips is great.

Have a Nice day....

W124.023

I`m from Norway and not so good at English
brEinar is offline  
post #8 of 9 (permalink) Old 07-13-2019, 02:55 AM
BenzWorld Newbie
 
Date registered: Dec 2018
Vehicle: W124 OM603.960, 1991 300 TDT
Location: Norway
Posts: 2
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Hei,

Jeg har en mb124 300 TDT fra 91, med samme problem som du hadde. Hos meg lekker det eksos fra en av sylindrene.

Har kjøpt pipen for å kunne ta ut forkammeret, (samme som du har kjøpt) men mutteren sitter bom-fast. Er nå litt usikker på om jeg ikke har fjernet nok før jeg prøver.

Har tatt ut dysen og glødeplugg fra denne ene sylinderen, ellers har jeg ikke fjernet noe. Må man fjerne topplokket for å kunne ta ut forkammeret?

Tipper at det hos meg er tetningsringen under forkammeret som er skadet. Fikk tak i ny ring.

Om du heller vil ringe, du når meg på 92200314.

All nyttig info er velkommen

Hilsen Rob.

--------------------------------------------------

Hi, I have the same problem but are not able to loosen the pre-chamber nut. Could you contact me?
robhazes is offline  
post #9 of 9 (permalink) Old 07-15-2019, 03:23 AM
BenzWorld Newbie
 
Date registered: Dec 2018
Vehicle: W124 OM603.960, 1991 300 TDT
Location: Norway
Posts: 2
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
I could not remove the nut locking the pre-chamber. I tried again with a warm engine and then it came loose without problems.
Jayare likes this.
robhazes is offline  
Sponsored Links
Advertisement
 
Reply

  Mercedes-Benz Forum > Mercedes-Benz Sedan Forums > W124 E,CE,D,TD Class

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Mercedes-Benz Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in











Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Topic Author Forum Replies Last Post
OM603 engine help dodgethis9271 W124 E,CE,D,TD Class 11 02-03-2019 08:03 AM
om603 and om606 whelanrob2002 W124 E,CE,D,TD Class 17 01-22-2015 02:49 PM
OM603 or OM602? Funky Mad W124 E,CE,D,TD Class 10 07-07-2009 10:24 AM
om603 motor JamesDean W126 S,SE,SEC,SEL,SD,SDL Class 0 08-24-2007 08:32 PM
Wtb: Om603 bboybaroo For Sale/Wanted/Trade/Giveaway 0 09-28-2006 05:37 PM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 

Title goes here

close
video goes here
description goes here. Read Full Story
For the best viewing experience please update your browser to Google Chrome