*Help* M110 280e Engine - Page 6 - Mercedes-Benz Forum
Reply
 
LinkBack Thread Tools Display Modes
post #51 of 65 (permalink) Old 02-17-2019, 09:16 PM Thread Starter
BenzWorld Member
 
Irfaan_ZA's Avatar
 
Date registered: Mar 2015
Vehicle: 1983 W123 280e
Location: Johannessburg, South Africa
Posts: 67
Mentioned: 0 Post(s)
Quoted: 10 Post(s)
(Thread Starter)
Back at it again

Picked up the car from my mech.

He removed the Fuel Pump relay, did some cleaning and soldering and it now seems 100%

Took the car for a very long 60km drive , partially spirited at high speeds to make the motor get quite hot. Stopped at my 1st end point , and tried to start. It starts immediately. Drove home from there, did the same test.

Im praying its sorted, it really does look it is sorted out now.

Another thing is that after the Radiator flush, the temperature stays around 90 Degrees at most, where previously it had risen to around the 100 degree marker
Irfaan_ZA is offline  
Sponsored Links
Advertisement
 
post #52 of 65 (permalink) Old 02-19-2019, 03:09 PM
Premium Member
 
Dr.Grillz's Avatar
 
Date registered: Aug 2002
Vehicle: Mercedes
Location: NA
Posts: 9,038
Mentioned: 2 Post(s)
Quoted: 277 Post(s)
Lifetime Premium Member
Happy to hear that your car appears to be sorted out and you're enjoying it!

1980 Mercedes 280TE AMG
1990 Mercedes 560SEL with AMG parts modifications
1991 Mercedes 190E AMG with Brabus 4-cyl M102 2.6
Dr.Grillz is offline  
post #53 of 65 (permalink) Old 02-19-2019, 09:09 PM Thread Starter
BenzWorld Member
 
Irfaan_ZA's Avatar
 
Date registered: Mar 2015
Vehicle: 1983 W123 280e
Location: Johannessburg, South Africa
Posts: 67
Mentioned: 0 Post(s)
Quoted: 10 Post(s)
(Thread Starter)
Quote:
Originally Posted by Dr.Grillz View Post
Happy to hear that your car appears to be sorted out and you're enjoying it!
Thank Dr.

I've been using it daily with no issue. Man I missed this car! It's thirsty as hell but its worth the feeling I get when driving it
Irfaan_ZA is offline  
Sponsored Links
Advertisement
 
post #54 of 65 (permalink) Old 02-19-2019, 10:42 PM
 
Nutz 4 Benz's Avatar
 
Date registered: Aug 2005
Vehicle: '81 280E turbo M119 project, 85 Audi Coupe Quattro, 71 BMW turbo 2002, '73 BMW 2002tii +others
Location: Hawai'i (Maui)
Posts: 17,423
Mentioned: 0 Post(s)
Quoted: 22 Post(s)
Lifetime Premium Member
Garage
Think of it as smiles per gallon.
Nutz 4 Benz is offline  
post #55 of 65 (permalink) Old 02-25-2019, 02:55 AM Thread Starter
BenzWorld Member
 
Irfaan_ZA's Avatar
 
Date registered: Mar 2015
Vehicle: 1983 W123 280e
Location: Johannessburg, South Africa
Posts: 67
Mentioned: 0 Post(s)
Quoted: 10 Post(s)
(Thread Starter)
And it's all systems go.

After sorting out the fuel pump relay it starts every time.
PlaneCrazy likes this.
Irfaan_ZA is offline  
post #56 of 65 (permalink) Old 02-25-2019, 03:14 AM
BenzWorld Elite
 
PlaneCrazy's Avatar
 
Date registered: Oct 2010
Vehicle: '86 W123 200, OM617 non-turbo, bastard 5-speed; '95 W202 C250 Diesel, OM605 non-turbo, 5-spd man
Location: With my head in the clouds
Posts: 4,070
Mentioned: 8 Post(s)
Quoted: 495 Post(s)
Garage
I'm happy for you. It's always the little things.


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.



W202 C250 Diesel, OM605 NA engine, 5-speed manual
1986 200, OM617 NA engine, 5-speed manual, rev counter
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.


Donkey, not gone, never forgotten...
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.


PlaneCrazy - it's more than a name, it's a life choice!




QUOTES FROM CONSTERNATIUS:

"Inside every small problem is a big problem screaming to get out."
PlaneCrazy is offline  
post #57 of 65 (permalink) Old 03-10-2019, 10:50 PM Thread Starter
BenzWorld Member
 
Irfaan_ZA's Avatar
 
Date registered: Mar 2015
Vehicle: 1983 W123 280e
Location: Johannessburg, South Africa
Posts: 67
Mentioned: 0 Post(s)
Quoted: 10 Post(s)
(Thread Starter)


And we back to square one

It happened again! I have no idea now what to do. It's going back to the mechanic this evening.
Irfaan_ZA is offline  
post #58 of 65 (permalink) Old 03-10-2019, 11:05 PM
BenzWorld Member
 
Date registered: Nov 2008
Vehicle: 1995 MB 600SL, !982 G-Wagen 280GE, BMW 1150RT
Location: South Africa, Highveld
Posts: 84
Mentioned: 0 Post(s)
Quoted: 3 Post(s)
Sorry to hear, have you figured out if it is fuel or spark, mine turned out to be the coil, it showed no symptoms but replaced with the correct blue high voltage Bosch coil from Diesel-Electrick and I am surprised with the allround better behavior of the engine.
Rudi Raaths is offline  
post #59 of 65 (permalink) Old 03-10-2019, 11:18 PM Thread Starter
BenzWorld Member
 
Irfaan_ZA's Avatar
 
Date registered: Mar 2015
Vehicle: 1983 W123 280e
Location: Johannessburg, South Africa
Posts: 67
Mentioned: 0 Post(s)
Quoted: 10 Post(s)
(Thread Starter)
Quote:
Originally Posted by Rudi Raaths View Post
Sorry to hear, have you figured out if it is fuel or spark, mine turned out to be the coil, it showed no symptoms but replaced with the correct blue high voltage Bosch coil from Diesel-Electrick and I am surprised with the allround better behavior of the engine.
Hey Rudi,

Not sure as yet, i had 0 tools or multimeter or anything. And being on the side of the N1 alone I couldn't even hear if the Fuel pump buzzed.

So fokkit, Im replacing the coil, fuel pump relay and fuel pump now. Im gatvol so just gonna do this and see.
Irfaan_ZA is offline  
post #60 of 65 (permalink) Old 03-13-2019, 05:01 AM
VON
BenzWorld Elite
 
VON's Avatar
 
Date registered: Apr 2004
Vehicle: 1973 416 Doka, 1978 416 Doka, 1980 416 Doka..... Help me, I can't stop buying them!!!
Location: Fairport, New York
Posts: 2,596
Mentioned: 6 Post(s)
Quoted: 184 Post(s)
Garage
This is why when I got my 280CE with a seized motor, I put in a turbo diesel instead of rebuilding the M110. With the car sitting 25 years not running, I didn't want the headaches and cost of the M110. The turbo diesel with a 5 speed is a joy to drive and starts every time. If you were in the US I would have every part you are looking for from the two 280CE's I have the parts off of.
Irfaan_ZA likes this.

Von
Fairport, NY
1973 Unimog 416 Doka
1980 Unimog 416 Doka
1984 Euro 280CE w/diesel conversion
1985 300TD Estate wagon
(I really need to stop buying these things!)

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
VON is online now  
Sponsored Links
Advertisement
 
Reply

  Mercedes-Benz Forum > Mercedes-Benz Sedan Forums > W123 E,CE,D,CD,TD,TE Class

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Mercedes-Benz Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in











Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 

Title goes here

close
video goes here
description goes here. Read Full Story
For the best viewing experience please update your browser to Google Chrome