How bad is your turbo lag? - Mercedes-Benz Forum
 
LinkBack Thread Tools Display Modes
post #1 of 10 (permalink) Old 11-19-2014, 04:24 PM Thread Starter
BenzWorld Member
 
Date registered: Jan 2012
Vehicle: 1984 MERCEDES-BENZ 300 TURBO DIESEL, 1978 CHEVROLET K20 CUSTOM DELUXE
Location: NEW YORK
Posts: 365
Mentioned: 0 Post(s)
Quoted: 13 Post(s)
(Thread Starter)
How bad is your turbo lag?

Today is the first day in a while that i have driven my car in a city environment. One thing that annoyed me was i went to step on it and it would proceed slowly until the turbo kicked in then spin a rear tire. How long is your turbo lag and what is the norm?
joe green is offline  
Sponsored Links
Advertisement
 
post #2 of 10 (permalink) Old 11-19-2014, 05:49 PM
BenzWorld Elite
 
Date registered: Jan 2012
Vehicle: 1979 & 1985 300D's
Location: Tucson, AZ
Posts: 2,537
Mentioned: 0 Post(s)
Quoted: 144 Post(s)
The turbo doesn't really do much until over 2500RPM. Lag is normal. Tire spin isn't normally an issue, but you're dealing with snow obviously. In the dry environments I drive in you can just get on it and let it spool up and it takes off pretty well.

1979 300D 040 Black on Black - 1985 300D Maaco job (sadly sprayed over 199 Black Pearl Metallic) on Palamino


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.


The Baja Arizona Oil Burners Send a message if you'd like to join the fun
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

Left to Right - UberWasser, Iridium, Stuttgart-->Seattle,, mannys9130


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
uberwasser is offline  
post #3 of 10 (permalink) Old 11-19-2014, 05:49 PM
BenzWorld Extremist
 
Master7Chief's Avatar
 
Date registered: Jun 2011
Vehicle: 1981 Mercedes-Benz 300TD
Location: Richmond, VA & Atlanta, GA
Posts: 871
Mentioned: 2 Post(s)
Quoted: 26 Post(s)
From a dead stop to WOT about 3 seconds. With engine rpm's above 2500 while driving, about 1.5 seconds. With rpm's over 3000, about one second or less.

1981 300TD 273,000 miles and counting...
Master7Chief is offline  
Sponsored Links
Advertisement
 
post #4 of 10 (permalink) Old 11-19-2014, 06:16 PM Thread Starter
BenzWorld Member
 
Date registered: Jan 2012
Vehicle: 1984 MERCEDES-BENZ 300 TURBO DIESEL, 1978 CHEVROLET K20 CUSTOM DELUXE
Location: NEW YORK
Posts: 365
Mentioned: 0 Post(s)
Quoted: 13 Post(s)
(Thread Starter)
Quote:
Originally Posted by uberwasser View Post
The turbo doesn't really do much until over 2500RPM. Lag is normal. Tire spin isn't normally an issue, but you're dealing with snow obviously. In the dry environments I drive in you can just get on it and let it spool up and it takes off pretty well.

Actually no snow on the ground. I only drive my car on dry days up until they start to salt the roads then it gets put away for the winter.
joe green is offline  
post #5 of 10 (permalink) Old 11-19-2014, 08:07 PM
BenzWorld Elite
 
Date registered: Jan 2012
Vehicle: 1979 & 1985 300D's
Location: Tucson, AZ
Posts: 2,537
Mentioned: 0 Post(s)
Quoted: 144 Post(s)
Well, heck, you should be pretty happy to have wheel spin! Your engine is extra healthy. Or someone thinks its funny to grease your tires

1979 300D 040 Black on Black - 1985 300D Maaco job (sadly sprayed over 199 Black Pearl Metallic) on Palamino


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.


The Baja Arizona Oil Burners Send a message if you'd like to join the fun
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

Left to Right - UberWasser, Iridium, Stuttgart-->Seattle,, mannys9130


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
uberwasser is offline  
post #6 of 10 (permalink) Old 11-20-2014, 12:10 PM
BenzWorld Veteran
 
Nude Easel's Avatar
 
Date registered: Sep 2013
Vehicle: 1978 240D
Location: Uranus
Posts: 691
Mentioned: 0 Post(s)
Quoted: 134 Post(s)
I got my 240D last fall, the turbo still hasn't kicked in
Derekwh likes this.
Nude Easel is offline  
post #7 of 10 (permalink) Old 11-20-2014, 04:59 PM
BenzWorld Member
 
eolon's Avatar
 
Date registered: Jan 2004
Vehicle: 1982 300TD
Location: NW Ohio
Posts: 163
Mentioned: 0 Post(s)
Quoted: 9 Post(s)
My 300TD has excellent same-day throttle response.

Best Regards,

e

.::.
Master7Chief likes this.

New Betty: 1982 300TD 58,000 miles

Old Betty: 1983 300TD 315,000 miles, RIP

1986 560 SEC RIP
1984 500SEL RIP
2000 ML350 ugh

.::.
eolon is offline  
post #8 of 10 (permalink) Old 11-20-2014, 11:54 PM
BenzWorld Elite
 
PlaneCrazy's Avatar
 
Date registered: Oct 2010
Vehicle: '86 W123 200, OM617 non-turbo, bastard 5-speed; '95 W202 C250 Diesel, OM605 non-turbo, 5-spd man
Location: With my head in the clouds
Posts: 4,070
Mentioned: 8 Post(s)
Quoted: 495 Post(s)
Garage
If I put down my foot, in any gear at any speed, it's almost as if nothing happens.

And I don't even have a turbo!


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.



W202 C250 Diesel, OM605 NA engine, 5-speed manual
1986 200, OM617 NA engine, 5-speed manual, rev counter
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.


Donkey, not gone, never forgotten...
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.


PlaneCrazy - it's more than a name, it's a life choice!




QUOTES FROM CONSTERNATIUS:

"Inside every small problem is a big problem screaming to get out."
PlaneCrazy is offline  
post #9 of 10 (permalink) Old 11-21-2014, 07:04 AM
BenzWorld Elite
 
Stretch's Avatar
 
Date registered: Jul 2011
Vehicle: 1981 W123 300D non turbo, 1992 190E 1.8 <=> 2.0
Location: The Netherlands
Posts: 6,561
Mentioned: 8 Post(s)
Quoted: 557 Post(s)
Quote:
Originally Posted by Nude Easel View Post
I got my 240D last fall, the turbo still hasn't kicked in
Quote:
Originally Posted by PlaneCrazy View Post
If I put down my foot, in any gear at any speed, it's almost as if nothing happens.

And I don't even have a turbo!
Like these guys I also have ZERO turbo lag

None

Nada

Zip!

1992 190E 1.8 <=>2.0 201.018 =>
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.


1981 300D (non turbo) 123.130 =>
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.


1965 Land Rover Series 2a Station Wagon =>
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.


Free and legal FSM download =>
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.


Don't leave that there I'll take it to bits
Stretch is offline  
post #10 of 10 (permalink) Old 11-21-2014, 07:22 PM
BenzWorld Extremist
 
Master7Chief's Avatar
 
Date registered: Jun 2011
Vehicle: 1981 Mercedes-Benz 300TD
Location: Richmond, VA & Atlanta, GA
Posts: 871
Mentioned: 2 Post(s)
Quoted: 26 Post(s)
At least its not as much lag as this... that's around 30 seconds based on first hand observation.

How bad is your turbo lag?-ge-turbo.jpg

Not my picture but it is a picture of what I see at work in a locomotive shop. There's more where that came from: Building 4,400hp engines - Cars - GTA Forums

1981 300TD 273,000 miles and counting...
Master7Chief is offline  
Sponsored Links
Advertisement
 
Reply

  Mercedes-Benz Forum > Mercedes-Benz Sedan Forums > W123 E,CE,D,CD,TD,TE Class

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Mercedes-Benz Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in











Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 

Title goes here

close
video goes here
description goes here. Read Full Story
For the best viewing experience please update your browser to Google Chrome