ELBE m117 EFI-kit installation - Mercedes-Benz Forum
Reply
 
LinkBack Thread Tools Display Modes
post #1 of 46 (permalink) Old 11-30-2014, 03:42 AM Thread Starter
BenzWorld Junior Member
 
Date registered: Sep 2014
Posts: 46
Mentioned: 0 Post(s)
Quoted: 17 Post(s)
(Thread Starter)
ELBE m117 EFI-kit installation

Hello,

I have bougth one elbe efi kit and i hope some of you are familliar With this set.

Do i need the original idlespeed actuator? A000 141 14 25

I can not figure out where to put the crank trigger Wheel and sensor?
myhre is offline  
Sponsored Links
Advertisement
 
post #2 of 46 (permalink) Old 11-30-2014, 06:03 AM
BenzWorld Elite
 
rumb's Avatar
 
Date registered: Oct 2012
Vehicle: 68 250S, 91 300se, 98 SL500, 450SEL 6.9, 14 CLS550 Past MB's; 300SD, 300E, 300TE, 190E, ML420
Location: Fort Collins, Colorado
Posts: 3,952
Mentioned: 19 Post(s)
Quoted: 821 Post(s)
Garage
Please complete your profile with location and what car you have.
rumb is offline  
post #3 of 46 (permalink) Old 11-30-2014, 06:10 AM Thread Starter
BenzWorld Junior Member
 
Date registered: Sep 2014
Posts: 46
Mentioned: 0 Post(s)
Quoted: 17 Post(s)
(Thread Starter)
Yes, sorry i forgot
The car is a 500se 85mod
And is located in Norway
myhre is offline  
Sponsored Links
Advertisement
 
post #4 of 46 (permalink) Old 11-30-2014, 08:03 AM
BenzWorld Senior Member
 
trazique's Avatar
 
Date registered: May 2008
Vehicle: '95 E320 Wagon '99 CLK430, 62 220se, 64 220se, 65 220se, 66250se, 85 380sl, 90 190E 2.6
Location: Jacksonville Fl
Posts: 583
Mentioned: 2 Post(s)
Quoted: 67 Post(s)
Send a message via Skype™ to trazique
Quote:
Originally Posted by myhre View Post
Yes, sorry i forgot
The car is a 500se 85mod
And is located in Norway
Take a look see...

https://www.benzworld.org/forums/r-c1...-progress.html
trazique is offline  
post #5 of 46 (permalink) Old 11-30-2014, 08:57 AM Thread Starter
BenzWorld Junior Member
 
Date registered: Sep 2014
Posts: 46
Mentioned: 0 Post(s)
Quoted: 17 Post(s)
(Thread Starter)
I have studied these pics many many times but mine is an kit made for the m117 engine and is slightly different.
But i Guess i can make it like this.

Anyway thanks
myhre is offline  
post #6 of 46 (permalink) Old 11-30-2014, 11:33 AM
BenzWorld Senior Member
 
trazique's Avatar
 
Date registered: May 2008
Vehicle: '95 E320 Wagon '99 CLK430, 62 220se, 64 220se, 65 220se, 66250se, 85 380sl, 90 190E 2.6
Location: Jacksonville Fl
Posts: 583
Mentioned: 2 Post(s)
Quoted: 67 Post(s)
Send a message via Skype™ to trazique
Quote:
Originally Posted by myhre View Post
I have studied these pics many many times but mine is an kit made for the m117 engine and is slightly different.
But i Guess i can make it like this.

Anyway thanks
I looked at the kit that you have, I think you would have to remove the crank pulley, the trigger wheel goes on first, then the crank pulley,

or separate the pulley from the balancer and place the trigger wheel between them that should help you to figure where the pickup sensor goes. I think.
trazique is offline  
post #7 of 46 (permalink) Old 11-30-2014, 12:13 PM Thread Starter
BenzWorld Junior Member
 
Date registered: Sep 2014
Posts: 46
Mentioned: 0 Post(s)
Quoted: 17 Post(s)
(Thread Starter)
Yes, i think so too
I looked at it one more time and i think i found it
myhre is offline  
post #8 of 46 (permalink) Old 11-30-2014, 03:52 PM Thread Starter
BenzWorld Junior Member
 
Date registered: Sep 2014
Posts: 46
Mentioned: 0 Post(s)
Quoted: 17 Post(s)
(Thread Starter)
I got it installd now but, still i cant figure out if i need the idlespeed actuator.
can i try with out and see how it goes?
myhre is offline  
post #9 of 46 (permalink) Old 11-30-2014, 05:46 PM
BenzWorld Senior Member
 
trazique's Avatar
 
Date registered: May 2008
Vehicle: '95 E320 Wagon '99 CLK430, 62 220se, 64 220se, 65 220se, 66250se, 85 380sl, 90 190E 2.6
Location: Jacksonville Fl
Posts: 583
Mentioned: 2 Post(s)
Quoted: 67 Post(s)
Send a message via Skype™ to trazique
Quote:
Originally Posted by myhre View Post
I got it installd now but, still i cant figure out if i need the idlespeed actuator.
can i try with out and see how it goes?
What is the speed actuator, Is it the sensor for the trigger wheel, can you post a picture of it?
trazique is offline  
post #10 of 46 (permalink) Old 12-01-2014, 12:03 AM Thread Starter
BenzWorld Junior Member
 
Date registered: Sep 2014
Posts: 46
Mentioned: 0 Post(s)
Quoted: 17 Post(s)
(Thread Starter)
I can do a pic of it later on when im on my pc.
But it is that thing you have connected between the air filter and the trotthle body.
I belive it's reading/adjusting the airflow/mass at idlespeed.
And you have a black one original it's alu. Coloured
myhre is offline  
Sponsored Links
Advertisement
 
Reply

  Mercedes-Benz Forum > General Mercedes-Benz Forums > Vintage Mercedes-Benz

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Mercedes-Benz Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in











Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 

Title goes here

close
video goes here
description goes here. Read Full Story
For the best viewing experience please update your browser to Google Chrome