Gear change problem! - Page 2 - Mercedes-Benz Forum
Reply
 
LinkBack Thread Tools Display Modes
post #11 of 14 (permalink) Old 04-27-2013, 05:09 AM
BenzWorld Elite
 
Date registered: Jul 2006
Vehicle: Vito 114 tourer 2015: Vito 108d 97: 108d 98: Traveliner 2003 ; Aixam; z1100; xbr500; z440 ++++
Location: lancs/Mcr/mersey
Posts: 2,384
Mentioned: 0 Post(s)
Quoted: 40 Post(s)
obviously I cannot diagnose your vito but I can tell you what commonly happens or is reported.

most gear change problems on 638s are due to wear of the "kit" or "cage" you have replaced and you will have found how easy it is to do.

unfortunately most owners and garages are morons and rather than do 15mins work, at little cost, they will strip the dash out and fiddle for hours with the cables.

of course it doesn't help much as the mechanism has worn out (the cage you've replaced) but it does mean they feel they've saved money by not buying the "cage" and the garage can charge big labour fees for adjustments, again and again.

now you have a good "cage" and accurate gearchange (yes I know its not perfect at the moment) you can try cable adjustment..... it is probably not correct and has been "fiddled with" by various mechanics in the past.

I attach the info on adjustments... you need to remove the ashtray and lower parts of the dash but I have found its often an advantage to remove the dash panel itself for easier viewing... its not complicated but getting to the bits takes time.

I wish you luck and I just wish garages etc would do things correctly.... unfortunately if this doesn't cure the problem, it probably needs a new selector, for this I will need your vin number (you may have given this before but I tend not to keep them) but hopefully it will be ok.

malcolm
Attached Files
File Type: pdf COMPOSITE gear cable adjustment.pdf (973.1 KB, 682 views)
Sponsored Links
Advertisement
 
post #12 of 14 (permalink) Old 04-27-2013, 05:44 AM
BenzWorld Junior Member
 
Date registered: Jul 2009
Vehicle: Vito 108 CDI
Location: Bulgaria
Posts: 12
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Thank you Malcolm - you're so helpful as always.
My VIN is early in this tread - VSA63819413232619

Please tell me the part number of this selector unit to check and have it just in case.
I'll try cable adjustments first.

Thanks and have a nice weekend
kadet4o is offline  
post #13 of 14 (permalink) Old 04-27-2013, 08:12 AM
BenzWorld Elite
 
Date registered: Jul 2006
Vehicle: Vito 114 tourer 2015: Vito 108d 97: 108d 98: Traveliner 2003 ; Aixam; z1100; xbr500; z440 ++++
Location: lancs/Mcr/mersey
Posts: 2,384
Mentioned: 0 Post(s)
Quoted: 40 Post(s)
NO

try the adjustments... check a couple of times if necessay.

the selector is a complex part that goes under or next to the "cage".... the cables fit one to the "cage", the other to the selector (the 2 cables you removed to replace the cage)

the actual selector can be quite expensive.... I really do hope you can solve your problems by adjustment alone (you wouldn't be able to do the adjustments, properly, with your old worn "cage")

good luck

malcolm

(if it doesn't work..... and ONLY then.... I will post the workshop notes on selector changing and will try and get the mb price on the bits as well.
Sponsored Links
Advertisement
 
post #14 of 14 (permalink) Old 07-09-2019, 12:03 PM
BenzWorld Newbie
 
Date registered: Jul 2019
Posts: 1
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Hi Malcolm

I’ve come across your posts regarding the w639 gear issues as I’ve been trying to pin point my own issue on my 2004 Vito 109cdi

Gear changes were a nightmare so I replaced the small white block in the gear lever base and gear changes are no much smoother - all except reverse

Getting into reverse usually meets with a grounding noise but then after a few attempts it finally goes into reverse

I was guessing it needs a new reverse linkage mechanism - the one that bolts into the top of the gearbox but I’m unsure what the part number is - do they even maybe have a reverse gear kit for the w639 Vito??
Shanusanus501 is offline  
Sponsored Links
Advertisement
 
Reply

  Mercedes-Benz Forum > Mercedes-Benz Vans/Trucks/SUV/Others > V-Class

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Mercedes-Benz Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in











Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 

Title goes here

close
video goes here
description goes here. Read Full Story
For the best viewing experience please update your browser to Google Chrome