Transmission problem Vito 639 - Mercedes-Benz Forum
Reply
 
LinkBack Thread Tools Display Modes
post #1 of 15 (permalink) Old 05-02-2012, 09:10 AM Thread Starter
BenzWorld Junior Member
 
Date registered: May 2012
Posts: 9
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
(Thread Starter)
Exclamation Transmission problem Vito 639

I have some problem with transmission some times, the car put in all greas on ex. 40km/h. Also when I drive and stop with brake it feels that car is still pusching forward.
cmdata is offline  
Sponsored Links
Advertisement
 
post #2 of 15 (permalink) Old 05-02-2012, 09:50 AM
BenzWorld Elite
 
zenman 63's Avatar
 
Date registered: Mar 2005
Vehicle: ML63 AMG & 2 350 SLK with AMG kit.
Location: warwickshire
Posts: 2,488
Mentioned: 1 Post(s)
Quoted: 52 Post(s)
Is this an Auto?
zenman 63 is offline  
post #3 of 15 (permalink) Old 05-02-2012, 11:38 PM Thread Starter
BenzWorld Junior Member
 
Date registered: May 2012
Posts: 9
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
(Thread Starter)
Exclamation

Quote:
Originally Posted by zenman 63 View Post
Is this an Auto?
Yes it is automatic
cmdata is offline  
Sponsored Links
Advertisement
 
post #4 of 15 (permalink) Old 05-03-2012, 12:38 AM
BenzWorld Elite
 
zenman 63's Avatar
 
Date registered: Mar 2005
Vehicle: ML63 AMG & 2 350 SLK with AMG kit.
Location: warwickshire
Posts: 2,488
Mentioned: 1 Post(s)
Quoted: 52 Post(s)
Ok good, has it been serviced?
Should be done every 40k
I would get the oil checked and service it with new filter etc.
Google 722.6 gear box.
zenman 63 is offline  
post #5 of 15 (permalink) Old 05-03-2012, 12:46 AM Thread Starter
BenzWorld Junior Member
 
Date registered: May 2012
Posts: 9
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
(Thread Starter)
Smile

Quote:
Originally Posted by zenman 63 View Post
Ok good, has it been serviced?
Should be done every 40k
I would get the oil checked and service it with new filter etc.
Google 722.6 gear box.
It should be changed but I have bought this car as used and I have runnit for 30K. But I will change Oil and filter and replay to you if it helps.

Do you now amout of oil and type of oil?
The is now information in owners manual.
cmdata is offline  
post #6 of 15 (permalink) Old 05-03-2012, 09:58 AM
BenzWorld Elite
 
zenman 63's Avatar
 
Date registered: Mar 2005
Vehicle: ML63 AMG & 2 350 SLK with AMG kit.
Location: warwickshire
Posts: 2,488
Mentioned: 1 Post(s)
Quoted: 52 Post(s)
Is very specialised oil and MB filter, get the oil there as well.
Better still get them to do it.
zenman 63 is offline  
post #7 of 15 (permalink) Old 05-03-2012, 10:06 PM Thread Starter
BenzWorld Junior Member
 
Date registered: May 2012
Posts: 9
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
(Thread Starter)
Smile

Quote:
Originally Posted by zenman 63 View Post
Is very specialised oil and MB filter, get the oil there as well.
Better still get them to do it.
I Have changed filter and oil, it was very dark and very burnd.
It seams to help but I have to run it for a couple of day's to realy see if it help.
Thanks for you tip.
cmdata is offline  
post #8 of 15 (permalink) Old 05-04-2012, 11:30 AM
BenzWorld Elite
 
zenman 63's Avatar
 
Date registered: Mar 2005
Vehicle: ML63 AMG & 2 350 SLK with AMG kit.
Location: warwickshire
Posts: 2,488
Mentioned: 1 Post(s)
Quoted: 52 Post(s)
Did you pump it out the oil cooler hose to drain the torque converter?
zenman 63 is offline  
post #9 of 15 (permalink) Old 05-05-2012, 02:12 PM Thread Starter
BenzWorld Junior Member
 
Date registered: May 2012
Posts: 9
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
(Thread Starter)
Smile

Quote:
Originally Posted by zenman 63 View Post
Did you pump it out the oil cooler hose to drain the torque converter?
I removed oil plug on converter, and lose the hose of oil cooler and remove all oil. I have run car now for two day's and it seam that it help't to change oil.
cmdata is offline  
post #10 of 15 (permalink) Old 05-17-2012, 10:03 AM Thread Starter
BenzWorld Junior Member
 
Date registered: May 2012
Posts: 9
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
(Thread Starter)
Hello, Now I have runned car for a week, in the begining it seams to help change oil, filter.
But now the problem gone forward to a bigger problem. from 0 - 2100 rpm. there are huge vibration in hole car. after 2100 rpm. it's disepers. If I start from 0km/h and push forward vibration is huge, and on 50km/h 4 grear in vibration is bigg. I manual lower gear to 2 or 3 gear and rpm. increas to above 2100 all is okay if I put higher grear the vibration comes back. but if I go on higher rpm. and put higher gear an not rpm. drops. to 2100rmp it's okay. and I can do this on all gears. if I drive in 12okm/h in 5 gear all is okay then rpm. is 2300 if I lower speed so rpm goes down to 2100rpm vibration is back.
cmdata is offline  
Sponsored Links
Advertisement
 
Reply

  Mercedes-Benz Forum > Mercedes-Benz Vans/Trucks/SUV/Others > V-Class

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Mercedes-Benz Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in











Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Topic Author Forum Replies Last Post
Which transmission oil for Vito 108D looser V-Class 14 10-21-2014 05:49 PM
Vito 111cdi auto transmission. seanyc5 V-Class 1 03-23-2011 01:30 AM
Vito 108CDI Electrical problem and Instrument Cluster problem DJDUNKY V-Class 2 03-30-2010 01:05 AM
VITO Automatic transmission problem Dominic1968 General Mercedes-Benz 0 07-12-2006 11:00 PM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 

Title goes here

close
video goes here
description goes here. Read Full Story
For the best viewing experience please update your browser to Google Chrome