Vito LWB 2004 639, had Re-con Gearbox but still hard to engage 2nd and reverse,Fixes? - Mercedes-Benz Forum
Reply
 
LinkBack Thread Tools Display Modes
post #1 of 12 (permalink) Old 03-21-2011, 11:30 AM Thread Starter
BenzWorld Junior Member
 
Date registered: Mar 2011
Vehicle: vito
Location: uk
Posts: 16
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
(Thread Starter)
Vito LWB 2004 639, had Re-con Gearbox but still hard to engage 2nd and reverse,Fixes?

Hi all,
I have just fitted a re-conditioned gearbox, new DMF, new Clutch to my 115 CDI vito 2004, all the noises have gone and it drives well but it’s now hard to engage second and reverse gear, can any adjustment be made on the cables? Or do you know of any fixes?
I know the gearbox is good as its had all new parts, so it must be the cables or gear stick selector part, if I remove the gear gator I can see that the ball part of the gear stick (white nylon bush part) looks very worn out and the gear stick slops around a bit!

I have been quoted;
£55 +vat each for the cables
£227 + vat for the gear selector part (gear stick in the dash)

So want to try a fix or a way of testing to see what part is worn out or stretched.

Thanks,
mataos is offline  
Sponsored Links
Advertisement
 
post #2 of 12 (permalink) Old 03-24-2011, 06:30 AM Thread Starter
BenzWorld Junior Member
 
Date registered: Mar 2011
Vehicle: vito
Location: uk
Posts: 16
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
(Thread Starter)
Any ideas? do the cables stretch on these, so they would need changing?

Thanks
mataos is offline  
post #3 of 12 (permalink) Old 03-24-2011, 02:20 PM
BenzWorld Elite
 
walsi's Avatar
 
Date registered: Mar 2007
Vehicle: 2000 108CDI, 2007 120 CDI long, Suzuki K5 GSXR track bike, 2005 Kawasaki ZX10R
Location: North Cornwall
Posts: 1,423
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Hi ya, yeah the cables can stretch but also the linkage at the gearbox can get worn and cause problems aswell. The cables are adjustable.

Cheers Martin
walsi is offline  
Sponsored Links
Advertisement
 
post #4 of 12 (permalink) Old 03-25-2011, 05:37 AM Thread Starter
BenzWorld Junior Member
 
Date registered: Mar 2011
Vehicle: vito
Location: uk
Posts: 16
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
(Thread Starter)
Thanks Martin,
Do you have any tips for adjusting, or just lenghten the outers and give it a try?
I cant see a way of adjusting at the gearbox end, so i guess there is adjustment in the cab under the gear stick?

It goes in to gear fine with the cables not connected so I think the gearbox linkage is good,

Mat
mataos is offline  
post #5 of 12 (permalink) Old 03-25-2011, 07:31 AM
BenzWorld Elite
 
walsi's Avatar
 
Date registered: Mar 2007
Vehicle: 2000 108CDI, 2007 120 CDI long, Suzuki K5 GSXR track bike, 2005 Kawasaki ZX10R
Location: North Cornwall
Posts: 1,423
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Hi ya, it does sound like stretched cables if there is no free play in the linkage. I have never adjusted a 639 yet myself but the 638 was adjusted at the gear lever end.

Cheers Martin
walsi is offline  
post #6 of 12 (permalink) Old 04-02-2011, 12:42 AM Thread Starter
BenzWorld Junior Member
 
Date registered: Mar 2011
Vehicle: vito
Location: uk
Posts: 16
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
(Thread Starter)
All fixed now, The gear stick part was so worn it had dropped and just slopped about, was full of dirt and grit which would of accelerated the wear, fitted a second hand stick and selector with cables and its perfect now,
There is also some adjustment on the cables if needed.

Mat
mataos is offline  
post #7 of 12 (permalink) Old 04-05-2011, 02:43 PM
BenzWorld Member
 
Date registered: Jun 2009
Vehicle: Dualiner 115 CDI
Location: New Forest
Posts: 61
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Hi Mat, was it an easy'ish fix? I've got issues with 2nd, 5th & 6th. Doesn't feel like gear box and sometimes the change is clean, others it just feels like i'm going to snap the gear stick!Is there any adjustment at the gear stick end? Any info would be greatly received....

Darren.
darrens2 is offline  
post #8 of 12 (permalink) Old 04-05-2011, 03:02 PM
BenzWorld Elite
 
walsi's Avatar
 
Date registered: Mar 2007
Vehicle: 2000 108CDI, 2007 120 CDI long, Suzuki K5 GSXR track bike, 2005 Kawasaki ZX10R
Location: North Cornwall
Posts: 1,423
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Hi Darren, there is adjustment at the gear lever end of the cables, check the top of the gearbox that all the mechanism is moving freely first because that can get all jammed up and cause all sorts of problems. I wouldn't say it is easy to adjust the cables but it can be done, it might just be muck around the ball at the bottom of the lever. Good luck

Cheers Martin
walsi is offline  
post #9 of 12 (permalink) Old 04-06-2011, 04:49 AM Thread Starter
BenzWorld Junior Member
 
Date registered: Mar 2011
Vehicle: vito
Location: uk
Posts: 16
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
(Thread Starter)
Hi Darren, You can check by removing the gear gator and try and put it in 2nd or reverse if it wont go try lifting the cable on the right to give it a bit more pull (lifting up the gear stick slightly) if this helps and your gear stick is worn out then its an easy fix, just replace the gear stick complete, or try adjusting the cables, trial and error!

Mine was so worn that the ball / gearstick had dropped enough so it was not giving correct pull on the cables, yours could be the same, The gear stick ball should have very little play and you should not beable to lift it up and down and wobble it about,

Or to check the gearbox end you can get under the van and remove the cables, then try selecting all gears by moving the selectors by hand.

Hope that helps!
mataos is offline  
post #10 of 12 (permalink) Old 04-06-2011, 10:09 AM
BenzWorld Member
 
Date registered: Jun 2009
Vehicle: Dualiner 115 CDI
Location: New Forest
Posts: 61
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Cheers Guys,

Mataos, the ball could be worn. There is about 2-3mm of vertical movement in the gear stick and that could account for the inconsistant gear changing. Sometimes it just drops in no problem, others it is a battle to get it in! I will have a good look when I get the chance and report back.

Darren.
darrens2 is offline  
Sponsored Links
Advertisement
 
Reply

  Mercedes-Benz Forum > Mercedes-Benz Vans/Trucks/SUV/Others > V-Class

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Mercedes-Benz Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in











Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Topic Author Forum Replies Last Post
639 vito and v class genuine crated gearbox sparkyshep For Sale/Wanted/Trade/Giveaway 1 11-14-2014 03:54 AM
2004 639 Vito 115 CDI - Auto Transmission bladelocks V-Class 0 11-06-2009 04:50 AM
Vito 639 2004 on doors forsale zenman 63 V-Class 0 10-28-2008 10:44 AM
2nd gear won't engage on 6MT masterdog R170 SLK-Class 1 06-07-2008 02:56 PM
Reverse slow to engage ark91se W126 S,SE,SEC,SEL,SD,SDL Class 8 02-22-2008 10:11 AM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 

Title goes here

close
video goes here
description goes here. Read Full Story
For the best viewing experience please update your browser to Google Chrome