Smart passion dash display says -1 yesterday, now -2 today. Ideas? - Mercedes-Benz Forum
 
LinkBack Thread Tools Display Modes
post #1 of 3 (permalink) Old 11-05-2012, 09:19 AM Thread Starter
BenzWorld Junior Member
 
Date registered: Jul 2012
Vehicle: Vito 108D 1998
Location: Staffordshire UK
Posts: 6
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
(Thread Starter)
Smart passion dash display says -1 yesterday, now -2 today. Ideas?

Yesterday the smart showed -1 on the dashboard display. There was a spanner at one point too, shouldn't be so as was serviced February.
Then the key fob failed, found that to be the battery as flashed 9 times.

However today it displayed -2

It's not temperature display by the way....
I'm sure it means something, but can't find it on the Net or in the book.
Ideas?
Sean.Smith is offline  
Sponsored Links
Advertisement
 
post #2 of 3 (permalink) Old 11-21-2012, 06:55 PM
BenzWorld Newbie
 
karlmarx's Avatar
 
Date registered: Nov 2012
Vehicle: 1999 Mercedes Benz C43
Location: North Texas
Posts: 4
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
service/key battery

hello sir. i am in the usa and only worked on one "grey market" vehicle, but i'm sure the standards would hold true. the wrench with the -mileage(1,2,3,...) means you need to have the service light reset. to do this turn the key to position two, press the left button on the instrument cluster twice (within 4 seconds) to bring up the service indicator, switch the ignition off (within 10 seconds) all while holding the left button, switch the ignition back to position 2 still holding the button, wait (aprox. 30 seconds) till the indicator flashes. it will take several tries. please note one wrench means an "a" service is due while two wrenches mean a "b" service is due. now for your nine flashes, this means you need to change the battery in you key fob, instructions should be in your owner's manual. i am a mercedes benz/smart master certified technician so i'm trying to help. feel free to contact me if you need assistance.
beviernie likes this.
karlmarx is offline  
post #3 of 3 (permalink) Old 11-22-2012, 06:13 AM Thread Starter
BenzWorld Junior Member
 
Date registered: Jul 2012
Vehicle: Vito 108D 1998
Location: Staffordshire UK
Posts: 6
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
(Thread Starter)
Cheers, yea figured the fob battery.
Thanks, I have managed to reset it now :-)
It was serviced when the wife bought it earlier this summer. Clearly he never reset it.
Thanks for the help on this.
Sean.Smith is offline  
Sponsored Links
Advertisement
 
Reply

  Mercedes-Benz Forum > Mercedes-Benz Vans/Trucks/SUV/Others > smart

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Mercedes-Benz Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in











Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 

Title goes here

close
video goes here
description goes here. Read Full Story
For the best viewing experience please update your browser to Google Chrome