Roadster over boosting ? - Mercedes-Benz Forum
 
LinkBack Thread Tools
Old 08-12-2012, 03:00 AM Thread Starter
BenzWorld Member
 
dellboy89's Avatar
 
Date registered: Dec 2011
Vehicle: 2000 vito 108cdi , 2000 ml 270 cdi
Location: cottesmore
Posts: 85
Mentioned: 0 Post(s)
Quoted: 15 Post(s)
(Thread Starter)
Roadster over boosting ?

Hi my dad has got a 2005 smart roadster but it seems to be over boosting and then going into limp mode we have took the turbo off and cleaned it and checked all the pipes on the waste gate are correct , please can anyone point us in a direction so we can get it fixed thanks callum
dellboy89 is offline  
Sponsored Links
Advertisement
 
Old 02-13-2013, 11:41 PM
BenzWorld Elite
 
MercedesTheBest's Avatar
 
Date registered: Jul 2012
Vehicle: SL500, GLC300
Location: B.C. Canada
Posts: 1,689
Mentioned: 0 Post(s)
Quoted: 2 Post(s)
there is a smart car roadster?!?! cool!

1995 SL 500 Mercedes Benz
2016 GLC 300 Mercedes Benz


2014 ML 63 Mercedes Benz - (sold)
2012 E 550 2 Door Coupe Mercedes Benz - (sold)
2012 GLK 350 Mercedes Benz - (sold)
2002 CL 500 Mercedes Benz - (sold)
1984 Camaro 5.0L High Output Chevrolet - (sold)
1982 CD 300 Turbo Diesel Mercedes Benz - (sold)
MercedesTheBest is offline  
Old 09-01-2013, 06:17 PM
BenzWorld Member
 
unimoged's Avatar
 
Date registered: Dec 2008
Vehicle: 2004 S500. 2000 CLK430 Cab, 1999 C43 AMG. 1999 S500. 1999 S320. 1977 230 4 spd, 1972 280SEL 4.5
Location: Charlotte NC
Posts: 186
Mentioned: 0 Post(s)
Quoted: 1 Post(s)
check the waste gate actuator diaphragm, the lines going to it and the electrical valve.
unimoged is offline  
Sponsored Links
Advertisement
 
Old 11-24-2016, 08:30 AM
BenzWorld Newbie
 
Date registered: Mar 2009
Vehicle: 2005 smart Roadster, 2002 SLK 200K
Location: Netherlands
Posts: 2
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
I also have a smart Roadster and mine is chip-tuned to ~110 hp.
Boost is higher after tuning: 1.5 bar.
Standard is 1.0 bar I think....
How high does your boost go?
If it's higher than 1.5 bar, then there's something wrong with the waste gate.
You have to lube the actuator arm on a regular base.....try if you can still move it.
Ridder is offline  
Old 04-17-2017, 10:20 AM
BenzWorld Junior Member
 
lostkiwi's Avatar
 
Date registered: Mar 2017
Vehicle: 1993 Mercedes 500SL (r129) , 2001 Mercedes E240 (S210)
Location: Midlands, UK/Aquataine, France
Posts: 17
Mentioned: 0 Post(s)
Quoted: 3 Post(s)
If it lights the engine management light and loses all power and it can be reset by pulling fuse 27 for 5 minutes or clearing the ECU errors then its most likely the cycle valve (Boost control valve). Thats the one thats in a metal case (as opposed to the one in a plastic case).
Swap it out and it should be fine. The Roadsters are susceptible to boost control valve failure and will regularly need a new one. A friend of mine carries a spare in the car and has modified its location to be easy to change he's had so many fail
lostkiwi is offline  
Sponsored Links
Advertisement
 
 

  Mercedes-Benz Forum > Mercedes-Benz Vans/Trucks/SUV/Others > smart

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Mercedes-Benz Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in









Thread Tools



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 

Title goes here

close
video goes here
description goes here. Read Full Story
For the best viewing experience please update your browser to Google Chrome