Mercedes-Benz Forum - Search Results
Advanced Search
Showing results 1 to 25 of 500
Search took 0.03 seconds.
Search: Posts Made By: bossjj98
Forum: W163 M-Class   04-15-2019, 01:29 PM
Replies: 22
Views: 929
Posted By bossjj98
So I don’t need anything else?

So I don’t need anything else?
Forum: W163 M-Class   04-15-2019, 07:04 AM
Replies: 22
Views: 929
Posted By bossjj98
What is the part number for the other part of the...

What is the part number for the other part of the line that the loop end goes to?
Forum: W163 M-Class   04-15-2019, 03:12 AM
Replies: 22
Views: 929
Posted By bossjj98
Thank you for your help

Thank you for your help
Forum: W163 M-Class   04-15-2019, 03:06 AM
Replies: 22
Views: 929
Posted By bossjj98
Thanks for the reply, also what other part would...

Thanks for the reply, also what other part would I need so that I can connect to the fuel service only line? Or does this fuel line come with the part necessary? I will circle the part I am referring...
Forum: W163 M-Class   04-14-2019, 02:53 PM
Replies: 22
Views: 929
Posted By bossjj98
Yes sir

Yes sir
Forum: W163 M-Class   04-13-2019, 08:37 PM
Replies: 22
Views: 929
Posted By bossjj98
https://www.youtube.com/watch?v=JaQniP719uY

https://www.youtube.com/watch?v=JaQniP719uY
Forum: W163 M-Class   04-13-2019, 08:34 PM
Replies: 22
Views: 929
Posted By bossjj98
4JGAB75EX2A323489 and thank you for your help

4JGAB75EX2A323489 and thank you for your help
Forum: W163 M-Class   04-13-2019, 08:29 PM
Replies: 22
Views: 929
Posted By bossjj98
So this post is almost two years old and I've had...

So this post is almost two years old and I've had the vehicle stored, I am looking to get it fixed now and would appreciate any help going forward, I also thank you all who have contributed to this...
Forum: W163 M-Class   06-26-2018, 10:30 AM
Replies: 1
Views: 212
Posted By bossjj98
Replacement Headlight Connector

I’m looking for a replacement w163 headlight connector for a 05 ML 350. Does anyone have a part number or know where I can get one? Both of mine are burnt out. Thanks
Is there any aftermarket way...
Forum: W163 M-Class   12-21-2017, 02:11 AM
Replies: 2
Views: 377
Posted By bossjj98
No Start, new fuel filter and pump no fuel pressure

02 ML 500 vehicle cranks doesn't start, no fuel pressure. I installed a new fuel filter and pump and checked the relay for the fuel pump. The battery and starter are also brand new. I can hear the...
Forum: W163 M-Class   11-06-2017, 10:24 AM
Replies: 22
Views: 929
Posted By bossjj98
https://youtu.be/JaQniP719uY

https://youtu.be/JaQniP719uY
Forum: W163 M-Class   11-06-2017, 10:15 AM
Replies: 22
Views: 929
Posted By bossjj98
This is the line I broke I will also attach a...

This is the line I broke I will also attach a video.
Forum: W163 M-Class   11-06-2017, 10:11 AM
Replies: 22
Views: 929
Posted By bossjj98
I broke the black hose not the metal one that I...

I broke the black hose not the metal one that I pointed with the green arrow. It is at the point right now where there is some type of metal valve almost where I can't see it anymore because it...
Forum: W163 M-Class   11-06-2017, 09:51 AM
Replies: 22
Views: 929
Posted By bossjj98
Broken line is the green one, I removed it passed...

Broken line is the green one, I removed it passed the connector that holds the two lines in place (both the metal and rubber hose) I am at a point now where there is some sort of metal valve similar...
Forum: W163 M-Class   11-06-2017, 09:45 AM
Replies: 22
Views: 929
Posted By bossjj98
Broke fuel line 02ML500 to fuel tank

Hi I have a problem on my 02 ML 500 where it won't start and I'm getting 0 fuel pressure, I checked all fuses and they were fine so I decided to change the fuel pump and filter, I have the new pump...
Forum: W163 M-Class   07-01-2017, 12:04 AM
Replies: 3
Views: 402
Posted By bossjj98
Hello I am replacing the CPS on my 02 ML 500...

Hello I am replacing the CPS on my 02 ML 500 because I am experiencing the usual cps symptoms and also have code P0335 for CPS A Circuit. I am wondering which brand I should go with the Bosch,...
Forum: W163 M-Class   06-30-2017, 11:57 PM
Replies: 3
Views: 402
Posted By bossjj98
Forum: W163 M-Class   12-18-2016, 01:14 PM
Replies: 7
Views: 1,175
Posted By bossjj98
Thanks I'll be sure to contact the dealership...

Thanks I'll be sure to contact the dealership tomorrow to see if they have these parts in stock. Thank you so much.
Forum: W163 M-Class   12-18-2016, 01:12 PM
Replies: 7
Views: 1,175
Posted By bossjj98
Thanks for the quick response the only numbers I...

Thanks for the quick response the only numbers I was able to locate are 168 545 30 20.
Forum: W163 M-Class   12-18-2016, 01:09 PM
Replies: 7
Views: 1,175
Posted By bossjj98
I had the Check Engine Light on and code for the...

I had the Check Engine Light on and code for the cps sensor, symptoms were vehicle not being able to restart while at operating temp. Needed to wait 45 minutes then vehicle would restart. Local junk...
Forum: W163 M-Class   12-15-2016, 01:44 PM
Replies: 7
Views: 1,175
Posted By bossjj98
Broke CPS Connector Need Help

I tried replacing the CPS on my 05 ML350 and ended up breaking the connector. It still connects into the sensor fine but when I'm driving I begin to loose power and the vehicle intermittently shuts...
Forum: W163 M-Class   04-27-2016, 02:44 PM
Replies: 1
Views: 287
Posted By bossjj98
98 ML 320 shifting issues

My friend has a 98 ml 320 with the following codes... He says that when he is driving it is hard to accelerate and that it doesn't shift as it should....
P0170
P0173
P0304
P0301
P0300
P0700...
Forum: W163 M-Class   03-28-2016, 06:14 PM
Replies: 8
Views: 602
Posted By bossjj98
Is this repairable?

Got into a accident and have some damage to my frame... I attached the link to the YouTube video below. Do you guys think it would be safe to have this welded back together? Thanks
...
Forum: W163 M-Class   03-27-2016, 12:19 AM
Replies: 6
Views: 761
Posted By bossjj98
In a accident today ML430

Hey guys... was involved in a accident today in my ML430 and thankfully I'm ok. I was driving straight on a main road and another car ran the stop sign on a side street hit my car causing me to hit a...
Forum: W163 M-Class   03-21-2016, 03:21 AM
Replies: 2
Views: 322
Posted By bossjj98
ML 430 Burns 1qt every 250 miles

I know this is obviously not normal and I know there are a few oil leaks on my car. Do you guys suggest me adding anything to prevent this? Or should I get the leaks fixed? Thanks
Showing results 1 to 25 of 500


 
Forum Jump
 

Title goes here

close
video goes here
description goes here. Read Full Story
For the best viewing experience please update your browser to Google Chrome