Mercedes-Benz Forum - Search Results
Advanced Search
Showing results 1 to 25 of 30
Search took 0.01 seconds.
Search: Posts Made By: jshood
Forum: W221 S-Class   09-22-2018, 11:35 AM
Replies: 12
Views: 1,402
Posted By jshood
Hi I have both a 2007 SL550 and 2007 s600 ,...

Hi

I have both a 2007 SL550 and 2007 s600 , they’re one hell of a pair.

Personally I wouldn’t worry too much about the difference in price between a $20k and $25k s600. There are so many...
Forum: W221 S-Class   11-14-2017, 09:21 PM
Replies: 6
Views: 989
Posted By jshood
Mouhamed, I have the abc system on both my...

Mouhamed,

I have the abc system on both my Sl550 and S600. My understanding this that cars after 2007 have the ABC 2.0 system which included stronger fittings, more filtering of the fluid and...
Forum: W221 S-Class   11-14-2017, 09:11 PM
Replies: 5
Views: 2,473
Posted By jshood
For anyone else that has a similar problem I...

For anyone else that has a similar problem I finally ended up taking it to the dealer and it turns out there was a loose ground at the rear voltage switching module. The tech simply roughed up and...
Forum: W221 S-Class   11-10-2017, 05:59 PM
Replies: 58
Views: 18,790
Posted By jshood
What did you do to your W221 today?

I detailed my S600 saks edition this week and upgraded the wheels with a pair off a 2015 s550. Really happy with the new look

Ride is surprisingly still perfect with the conti run flats that come...
Forum: W221 S-Class   11-09-2017, 10:16 PM
Replies: 1
Views: 502
Posted By jshood
2007 s600 oil in intercooler

When changing my spark plugs this weekend I noticed oil residue in one of the intercoolers in my 2007 S600 140k miles. It’s only on one side . Is this a sign of impending turbo failure or a leak...
Forum: W221 S-Class   11-03-2016, 10:36 PM
Replies: 5
Views: 2,473
Posted By jshood
S600 Voltage low with good battery

Hi,

Last month I scored a great deal on a well used but single owner dealer maintained S600. Its one of 20 of the Saks 5th Avenue launch editions in Designo Mocha to match my Sl550 Designo Mocha!...
Forum: W211 E-Class   06-29-2012, 11:17 PM
Replies: 2
Views: 1,088
Posted By jshood
Panoramic Sunshade Sticking

Picked up my 2003 E500 from the shop today after having my alignment done. Suddenly my front sunshade on the pano roof does not open. The rear opens and closes fine.

If I slightly push up on the...
Forum: C208/A208 CLK-Class   03-13-2012, 04:29 PM
Replies: 0
Views: 775
Posted By jshood
Source for new throttle body / actuator

Local indy wants to replace my Throttle Body / Acutuator on my 2000 CLK320. Car has lost power several times in the past few months. Replaced brake switch and throttle sensor per the fault codes he...
Forum: W211 E-Class   05-27-2011, 11:32 PM
Replies: 14
Views: 9,846
Posted By jshood
Interesting. I hear the same noise on my 2003...

Interesting. I hear the same noise on my 2003 e500 (85k) and my '99 e430 (145k miles).

Both have good plugs, mounts and use chevron 91 octane in California. Really interested if this is just...
Forum: W210 E-Class   04-04-2011, 10:35 PM
Replies: 74
Views: 9,118
Posted By jshood
Sounds like I may have been a bit unlucky. I...

Sounds like I may have been a bit unlucky. I have a '99 E430 sport in desert silver. Purchased it as 3rd owner 4 years ago with 68k miles, it now has 130k. Always been a California car. Interior...
Forum: W210 E-Class   03-22-2011, 09:12 PM
Replies: 2
Views: 746
Posted By jshood
Exclamation Update - .5" of water was in the batery compartment

Tonight while driving home things got worse. I couldn't lock the doors, fog lights kept turning on at random and eventually all the windows rolled down and the sun roof opened in the rain!

I was...
Forum: W210 E-Class   03-22-2011, 01:27 PM
Replies: 2
Views: 746
Posted By jshood
Water near battery! --was: trunk switch light & Tow Light switch "pulsing"

Something very strange started happening on my drive to work today. I noticed that the red light on the "tow / alarm" switch and the red light on the trunk switch were dimming on and off.

The...
Forum: W210 E-Class   01-09-2010, 11:50 AM
Replies: 13
Views: 13,350
Posted By jshood
Thanks for all the great replies. The diagram was...

Thanks for all the great replies. The diagram was helpful. The shop used compressed air to try and test all the relief valves. They say that there is a valve welded into the tank that is the core of...
Forum: W210 E-Class   01-07-2010, 12:23 PM
Replies: 13
Views: 13,350
Posted By jshood
Replace Fuel Tank?

I posted a few days ago about an issue I had where fuel / vapor would rush out of the fuel spout after adding only 2-3 gallons of fuel at a time.

Didn't get any replies so decided to take it to a...
Forum: W210 E-Class   01-02-2010, 11:01 PM
Replies: 0
Views: 510
Posted By jshood
rush of fuel vapor when removing pump

The past few times I've gone to fill up my '99 E430 (115k Miles) I've noticed a rush of fuel vapor when removing the pump. One time during a complete fill up fuel actually shot out. Happens at all...
Forum: W210 E-Class   04-26-2009, 07:50 PM
Replies: 8
Views: 682
Posted By jshood
I traced the main vacuum line to the engine and...

I traced the main vacuum line to the engine and noticed that the connector on the back of the engine had about 1/4" of play. There is some sort of regulator /connector visible in the attached...
Forum: W210 E-Class   04-26-2009, 05:39 PM
Replies: 8
Views: 682
Posted By jshood
I'd love to take a look at the hoses. I see the...

I'd love to take a look at the hoses. I see the main one which goes to the master Cylinder. Are there any others. Does anyone have access to a diagram of the braking /abs system?

Thanks!
Jeff...
Forum: W210 E-Class   04-25-2009, 09:25 PM
Replies: 7
Views: 13,889
Posted By jshood
I have this same problem. As a note you can get...

I have this same problem. As a note you can get the seat to move back by hitting one of the memory buttons.

If you were ever able to fix this I'd love to know what you did.

-Jeff
Forum: W210 E-Class   04-25-2009, 07:19 PM
Replies: 8
Views: 682
Posted By jshood
Sorry Ingmar, A bit of clarification. The...

Sorry Ingmar,

A bit of clarification. The pedal is still very firm for the 1st 1/2" of travel on the pedal. In other words once you push it in a bit it gets much easier. I've driven the car for...
Forum: W210 E-Class   04-25-2009, 12:56 AM
Replies: 8
Views: 682
Posted By jshood
Brake pedal too firm after not driving for a few months

Hey folks. Love your thoughts on this. A few months ago I had to garage my 99 E430 after the transmission failed. We'll this month I finally saved up and found a great transmission shop in the bay...
Forum: W210 E-Class   01-25-2009, 09:32 PM
Replies: 3
Views: 1,035
Posted By jshood
Question DIY Transmission replacement on W210?

Does anybody have experience replacing the transmission on a '99 E430? Mine has gone and it's time for a replacement.

On the DIY scale how complex is it? So far only maintenance I've done on my...
Forum: W210 E-Class   01-22-2009, 10:08 PM
Replies: 9
Views: 9,526
Posted By jshood
Lightbulb DIY Transmsision Replacement

Great info guys! So I'm almost convinced to do it myself.

$5,500 was for rebuilt transmission and radiator replacement (hence the leak I was discussing at the beginning)

So the question is......
Forum: W210 E-Class   12-30-2008, 04:54 PM
Replies: 9
Views: 9,526
Posted By jshood
ohlord, I was actually thinking of putting a...

ohlord,

I was actually thinking of putting a used transmission in the '99 and just trading the whole car in for an '01.

My feeling is that it's $5,500 to get it running. As is w/o a working...
Forum: W210 E-Class   12-30-2008, 12:56 PM
Replies: 9
Views: 9,526
Posted By jshood
Guys, Thanks for the advice. gregs210 thanks...

Guys,

Thanks for the advice. gregs210 thanks for all the detail.

As it turns out test shows NO coolant in the tranny. gregs210, I'm asuming your advice is only good if we're talking about...
Forum: W210 E-Class   12-30-2008, 09:52 AM
Replies: 9
Views: 9,526
Posted By jshood
Transmission fluid foaming / coolant?

I brought my '99 E430 into the shop today immediately after I began noticing the transmission was "slipping". After cold start I noticed it took way to long to get from gear 2 to 3 and then while...
Showing results 1 to 25 of 30


 
Forum Jump
 

Title goes here

close
video goes here
description goes here. Read Full Story
For the best viewing experience please update your browser to Google Chrome