Telephone no power - Mercedes-Benz Forum
 
LinkBack Thread Tools Display Modes
post #1 of 4 (permalink) Old 06-25-2019, 10:14 AM Thread Starter
BenzWorld Newbie
 
Date registered: Jun 2019
Posts: 4
Mentioned: 0 Post(s)
Quoted: 1 Post(s)
(Thread Starter)
Telephone no power

I recently bought an 04 SL500 Mercedes Benz. It is equipped with a phone/cradle in the armrest but there is no power to the cradle. I purchased the compatible puck which is a Motorola V60 puck but have no power. When I select Telephone on the system it says error no phone. Mercedes dealerships says that it can't be powered up. Is this true?
jdwayne1 is offline  
Sponsored Links
Advertisement
 
post #2 of 4 (permalink) Old 06-26-2019, 06:17 AM
BenzWorld Senior Member
 
kbob999's Avatar
 
Date registered: Aug 2013
Vehicle: 2003 SL55; 2011 E350 BTC
Location: Battle Ground, WA
Posts: 428
Mentioned: 4 Post(s)
Quoted: 71 Post(s)
Garage
Does not sound true to me. I’m sure you can get power to the puck, but not sure you can get the phone to work. It may have been disconnected from the fiber optic loop, but you can check that later.

Start with the simple, like a fuse to the cradle. Search for”Fuse Map” and you’re good to go. Likely behind passenger seat. See if there is power at the fuse, and the fuse is good. Blown fuses normally mean something has a short, so it can blow again.

You may want to get a WIS (work instruction) CD off eBay and install it on a laptop.
This will give you tons of info on how to analyses systems, trace wires and trouble shoot. Only about $10.
Or if you consider this car a keeper, get an SDS and learn how to use it. Will pay for itself many times over the life of the car.

'11 E350 Bluetec P2 Sport 55K Mi.
'03 SL55 AMG Pano 95K Mi.
kbob999 is offline  
post #3 of 4 (permalink) Old 06-26-2019, 08:00 PM Thread Starter
BenzWorld Newbie
 
Date registered: Jun 2019
Posts: 4
Mentioned: 0 Post(s)
Quoted: 1 Post(s)
(Thread Starter)
How do I find out if its disconnected from Fiber Optics? Hope can I get it reconnected?
jdwayne1 is offline  
Sponsored Links
Advertisement
 
post #4 of 4 (permalink) Old 06-27-2019, 07:06 AM
BenzWorld Senior Member
 
kbob999's Avatar
 
Date registered: Aug 2013
Vehicle: 2003 SL55; 2011 E350 BTC
Location: Battle Ground, WA
Posts: 428
Mentioned: 4 Post(s)
Quoted: 71 Post(s)
Garage
Quote:
Originally Posted by jdwayne1 View Post
How do I find out if its disconnected from Fiber Optics? Hope can I get it reconnected?
If the phone is disconnected, there will be a fiber optic splice in the line, and the phone will be removed on SDS list of devices in the loop.
You canít just disconnect the fiber line and yank the phone out, as the loop must be complete for the fiber devices to work.

Get the power issue resolved, then work on the communication issue next.

'11 E350 Bluetec P2 Sport 55K Mi.
'03 SL55 AMG Pano 95K Mi.
kbob999 is offline  
Sponsored Links
Advertisement
 
Reply

  Mercedes-Benz Forum > Mercedes-Benz Roadster Forums > R230 SL-Class

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Mercedes-Benz Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in











Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 

Title goes here

close
video goes here
description goes here. Read Full Story
For the best viewing experience please update your browser to Google Chrome