1998 slk 230 works fine and then wont start! - Mercedes-Benz Forum
Reply
 
LinkBack Thread Tools Display Modes
post #1 of 16 (permalink) Old 08-18-2016, 09:33 PM Thread Starter
BenzWorld Junior Member
 
mic93304's Avatar
 
Date registered: Dec 2008
Vehicle: 1998 SLK230
Location: Bakersfield CA
Posts: 19
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
(Thread Starter)
1998 slk 230 works fine and then wont start!

This just stared I drive my car i'm in bakersfield hottest place on earth!!! anyway I take it to a few locations then like on the fourth or fifth place is just cranks and doesn't start. It sucks! then I just leave the car there and come back in say 10 hours and it starts up fine. Maybe its something simple I can fix but i'm not sure what it is. It tries to start but doesnt start.
mic93304 is offline  
Sponsored Links
Advertisement
 
post #2 of 16 (permalink) Old 08-18-2016, 09:52 PM
BenzWorld Member
 
Date registered: Aug 2015
Vehicle: 2005 e320
Location: USA
Posts: 154
Mentioned: 1 Post(s)
Quoted: 22 Post(s)
Crankshaft position sensor?
petrabid is offline  
post #3 of 16 (permalink) Old 08-18-2016, 11:01 PM Thread Starter
BenzWorld Junior Member
 
mic93304's Avatar
 
Date registered: Dec 2008
Vehicle: 1998 SLK230
Location: Bakersfield CA
Posts: 19
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
(Thread Starter)
I just had a mechanic put a new one in , is was dead and some air hoses! I have own the car for 14 years lol I am going to have to take it back it worked great for four months but all in all the car is a tank!
mic93304 is offline  
Sponsored Links
Advertisement
 
post #4 of 16 (permalink) Old 08-18-2016, 11:02 PM Thread Starter
BenzWorld Junior Member
 
mic93304's Avatar
 
Date registered: Dec 2008
Vehicle: 1998 SLK230
Location: Bakersfield CA
Posts: 19
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
(Thread Starter)
I hope I dont get a ticket tonight its still down town!
mic93304 is offline  
post #5 of 16 (permalink) Old 08-18-2016, 11:04 PM
BenzWorld Member
 
Date registered: Aug 2015
Vehicle: 2005 e320
Location: USA
Posts: 154
Mentioned: 1 Post(s)
Quoted: 22 Post(s)
Hell you never know it might start right up now. I will watch this thread and I hope you find some resolution.
petrabid is offline  
post #6 of 16 (permalink) Old 08-18-2016, 11:07 PM
BenzWorld Member
 
Date registered: Aug 2015
Vehicle: 2005 e320
Location: USA
Posts: 154
Mentioned: 1 Post(s)
Quoted: 22 Post(s)
Maybe the sensor is faulty. Everyone says Bosch is the only way to go. I'm putting a new one in the 320 tommorow
petrabid is offline  
post #7 of 16 (permalink) Old 08-18-2016, 11:17 PM Thread Starter
BenzWorld Junior Member
 
mic93304's Avatar
 
Date registered: Dec 2008
Vehicle: 1998 SLK230
Location: Bakersfield CA
Posts: 19
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
(Thread Starter)
What sucks is he charged me $200 for the sensor and I don't think its real! I don't see the Mercedes logo on it like the one he took off. I dont want to think too bad of the guy because he did get the car to pass smog so maybe its just something new. Once I start making lots of money again I really liked just having the dealership fix the car lolololololololol $500 oil change lol
mic93304 is offline  
post #8 of 16 (permalink) Old 08-18-2016, 11:21 PM
BenzWorld Member
 
Date registered: Aug 2015
Vehicle: 2005 e320
Location: USA
Posts: 154
Mentioned: 1 Post(s)
Quoted: 22 Post(s)
Maybe the part is under warranty, and he will stand behind his work. I believe there is a way to test the CPS by measuring its resistance.
Had an Oldsmobile that crapped out and I did everything I knew to make it run. Eventually had it towed to a shop, and $700 later he told me it was the CPS. So don't feel too bad it could have been worse.
petrabid is offline  
post #9 of 16 (permalink) Old 08-18-2016, 11:22 PM Thread Starter
BenzWorld Junior Member
 
mic93304's Avatar
 
Date registered: Dec 2008
Vehicle: 1998 SLK230
Location: Bakersfield CA
Posts: 19
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
(Thread Starter)
I am new poster but I registered on this site in 2008 lol I will find the problem! But maybe someone knows what is going on the check engine light isnt on or anything.
mic93304 is offline  
post #10 of 16 (permalink) Old 08-19-2016, 03:55 AM
Moderator
 
Subby_'s Avatar
 
Date registered: Jan 2007
Vehicle: 1998 SLK 230
Location: Melbourne, AU
Posts: 2,577
Mentioned: 1 Post(s)
Quoted: 70 Post(s)
Lifetime Premium Member
yeah as above if its effected by heat its a very strong chance its the CPS (crankshaft position sensor). there is one also for the camshaft too. if one has failed the other wont be far off.

parts dont necessarily have to have the MB logo or part number on them if aftermarket. if its bosch its OK. just buy from a reputable website (for example Pelican Parts - Porsche, BMW, MINI, Mercedes, Audi, Volkswagen, Saab, Volvo - Auto Parts and Accessories)

just by having a quick browse on there a genuine bosch CPS $65, whilst other brands around $25 and for the camshaft sensor bosch about $86.

fitting them isnt too hard with a basic tool set, from memory its a hex bit to undo the bolt!

- ASP pulley kit
- 87mm supercharger pulley
- Ported Eaton M62 supercharger
- Ported supercharger inlet manifold
- MAF screen & throttle body screen delete
- Automatic intercooler spray kit
- Single 2.5" Magnaflow Hi-flow cat
- Magnaflow rear muffler + Lukey Ultraflo resonator
- Shift-I progressive shift light
- Custom ECU tune
- Air box delete (custom) with BMC airfilter
- 10c degree STAR thermo fan mod
- FireStorm igntion coil booster
- 5 Bar fuel pressure regulator
Subby_ is offline  
Sponsored Links
Advertisement
 
Reply

  Mercedes-Benz Forum > Mercedes-Benz Roadster Forums > R170 SLK-Class

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Mercedes-Benz Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in











Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 

Title goes here

close
video goes here
description goes here. Read Full Story
For the best viewing experience please update your browser to Google Chrome