Erratic climate control - Mercedes-Benz Forum
 
LinkBack Thread Tools Display Modes
post #1 of 8 (permalink) Old 08-09-2019, 12:48 PM Thread Starter
BenzWorld Junior Member
 
Date registered: Oct 2018
Vehicle: 1997 SL320
Location: Upstate SC
Posts: 7
Mentioned: 0 Post(s)
Quoted: 2 Post(s)
(Thread Starter)
Erratic climate control

The climate control on my '97 SL320 has recently started to malfunction. Most of the time I have to turn off the auto function by decreasing the fan speed until the auto light goes out, then increase the fan speed to return it to the auto function. Sometimes the fan will come back on but mostly it won't. I can hear the AC compressor turn on when the auto function light comes on. It blows cold air when the fan works.

Any suggestions are appreciated.

Charles
Hogndogz is offline  
Sponsored Links
Advertisement
 
post #2 of 8 (permalink) Old 08-09-2019, 03:19 PM
One of the BW Old Guard
 
Ears's Avatar
 
Date registered: Aug 2004
Vehicle: 1997 SL500- 40th Anniversary
Location: Fort Payne, Al
Posts: 7,108
Mentioned: 9 Post(s)
Quoted: 514 Post(s)
Lifetime Premium Member
Quote:
Originally Posted by Hogndogz View Post
The climate control on my '97 SL320 has recently started to malfunction. Most of the time I have to turn off the auto function by decreasing the fan speed until the auto light goes out, then increase the fan speed to return it to the auto function. Sometimes the fan will come back on but mostly it won't. I can hear the AC compressor turn on when the auto function light comes on. It blows cold air when the fan works.

Any suggestions are appreciated.

Charles
I could easily be mistaken, but it sure sounds like a fubar blower control regulator... Well documented in this forum, with complete pics and how-to. Search for GADHA Blower replacement for a starter...
Also see: https://www.benzworld.org/forums/r12...otor-heat.html

Best Regards...

RM Smith
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

Where is it again that we are going... And why are we in a handbasket?
Ears is offline  
post #3 of 8 (permalink) Old 08-11-2019, 03:01 AM Thread Starter
BenzWorld Junior Member
 
Date registered: Oct 2018
Vehicle: 1997 SL320
Location: Upstate SC
Posts: 7
Mentioned: 0 Post(s)
Quoted: 2 Post(s)
(Thread Starter)
Thanks Ears!
Hogndogz is offline  
Sponsored Links
Advertisement
 
post #4 of 8 (permalink) Old 08-11-2019, 05:50 AM
Outstanding Contributor
 
Date registered: Jan 2004
Vehicle: '03 SL500, '03 SL55, '97 SL320, (2) '91 300SL, (2) '91 500SL, '00 S500 -- all for sale
Location: Atlanta, USA
Posts: 4,061
Mentioned: 14 Post(s)
Quoted: 602 Post(s)
In most cases problems of this kind are a consequence of a faulty blower speed regulator. But the in-dash controller can be the problem as well, and since that possibility is quickly and easily checked, that is a logical place to begin. You can search my username and the words "blower" and/or "regulator" for details.
bobterry99 is offline  
post #5 of 8 (permalink) Old 08-11-2019, 11:43 AM Thread Starter
BenzWorld Junior Member
 
Date registered: Oct 2018
Vehicle: 1997 SL320
Location: Upstate SC
Posts: 7
Mentioned: 0 Post(s)
Quoted: 2 Post(s)
(Thread Starter)
Thanks BobTerry99. Good to know.
Hogndogz is offline  
post #6 of 8 (permalink) Old 08-13-2019, 03:31 PM
BenzWorld Newbie
 
kinglaw1's Avatar
 
Date registered: Nov 2016
Vehicle: 1991 500 SL R129
Location: Los Angeles
Posts: 2
Mentioned: 0 Post(s)
Quoted: 1 Post(s)
Hi,

I am a novice on this site and believe you have a video on the blower regulator problem. i have a 1991 500SL and have gone through 3 aftermarket regulators (129 821 33 51) two of which are MTC. The first one (cheap from China) actually worked for 2 days and then reverted to the high setting and cannot turn off. The next two when plugged in had a high whine similar to a radio frequency.
Have you seen this before? I saw your point about testing the control unit on the dash; what exactly is tested there (I have some mechanical skills)?

Thank you for any help on this topic

kinglaw1
kinglaw1 is offline  
post #7 of 8 (permalink) Old 08-13-2019, 05:39 PM
Outstanding Contributor
 
Date registered: Jan 2004
Vehicle: '03 SL500, '03 SL55, '97 SL320, (2) '91 300SL, (2) '91 500SL, '00 S500 -- all for sale
Location: Atlanta, USA
Posts: 4,061
Mentioned: 14 Post(s)
Quoted: 602 Post(s)
Quote:
Originally Posted by kinglaw1 View Post
I saw your point about testing the control unit on the dash; what exactly is tested there...
You are checking the voltage signal sent from the in-dash unit to the blower motor regulator. It should vary commensurate with blower speed setting. See this post: https://www.benzworld.org/forums/r12...ml#post3639421.
bobterry99 is offline  
post #8 of 8 (permalink) Old 08-13-2019, 05:45 PM
BenzWorld Newbie
 
kinglaw1's Avatar
 
Date registered: Nov 2016
Vehicle: 1991 500 SL R129
Location: Los Angeles
Posts: 2
Mentioned: 0 Post(s)
Quoted: 1 Post(s)
Thank you so much; I will do that.

BPK
kinglaw1 is offline  
Sponsored Links
Advertisement
 
Reply

  Mercedes-Benz Forum > Mercedes-Benz Roadster Forums > R129 SL-Class

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Mercedes-Benz Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in











Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 

Title goes here

close
video goes here
description goes here. Read Full Story
For the best viewing experience please update your browser to Google Chrome