Re: R129/W140 instrument cluster - Page 2 - Mercedes-Benz Forum
Reply
 
LinkBack Thread Tools Display Modes
post #11 of 42 (permalink) Old 04-29-2019, 01:43 PM
BenzWorld Elite
 
Date registered: Nov 2002
Vehicle: '82 500sec euro, '95 Ford F150
Location: West Palm Beach, Fl
Posts: 1,531
Mentioned: 3 Post(s)
Quoted: 148 Post(s)
Goes without saying, that I’ve wiped the excess tire wet after the application, so it never looked greasy, or shiny. The matt black paint absorbed most of it quite quickly.
roadhouse is offline  
Sponsored Links
Advertisement
 
post #12 of 42 (permalink) Old 04-29-2019, 03:52 PM Thread Starter
BenzWorld Elite
 
Chicky's Avatar
 
Date registered: Apr 2007
Vehicle: 1991 R129 500SL
Location: Manila, Philippines
Posts: 1,698
Mentioned: 1 Post(s)
Quoted: 100 Post(s)
(Thread Starter)
Thumbs up

Quote:
Originally Posted by guzzimike View Post
There was a thread about this type Instrument Cluster a few years ago ( 2011 or 2012 ), and IIRC the price for it back then was around $400 US.

The part Number was also included, as was the seller.. I think it might have been Parts.com, but I'm not sure.

You may want to do a search here under "Silver Arrow instrument cluster" and similar.

Good luck to you.
-
Hi guzzimike,

Thank you for this info, I'll do a search on this in a while.
Chicky is offline  
post #13 of 42 (permalink) Old 04-29-2019, 03:59 PM Thread Starter
BenzWorld Elite
 
Chicky's Avatar
 
Date registered: Apr 2007
Vehicle: 1991 R129 500SL
Location: Manila, Philippines
Posts: 1,698
Mentioned: 1 Post(s)
Quoted: 100 Post(s)
(Thread Starter)
Thumbs up

Quote:
Originally Posted by roadhouse View Post
I washed mine out with dish soap and water. After it dried, it the spots went away for the most part, but they became visible in some areas. I then sprayed foaming tire wet on a paper towel and rubbed it on the black part in a few applications. Then I cleaned the glass from the inside.
The spots have not come back yet in the three years Iíve owned my w140.
Hi roadhouse,

I will definitely tryout your procedure on the "sacrificial cluster"...keeping my fingers crossed that I'll get the same results.

Thank you
Chicky is offline  
Sponsored Links
Advertisement
 
post #14 of 42 (permalink) Old 04-29-2019, 04:14 PM Thread Starter
BenzWorld Elite
 
Chicky's Avatar
 
Date registered: Apr 2007
Vehicle: 1991 R129 500SL
Location: Manila, Philippines
Posts: 1,698
Mentioned: 1 Post(s)
Quoted: 100 Post(s)
(Thread Starter)
Red face

Hello Gentlemen,

I just a call from my indie mechanic, that removal of the clear lens from the cluster housing, was successful but he ended up having a crack on the lens. But he noted that, if he were to do the same procedure on my car's cluster, in all probability, he would be able to take it off without any damage ...hmmm

Also, I was rethinking the option of buying the Silver Arrow version instrument cluster housing, not because of the projected $$$ that it costs, but in my humble opinion, "too blinggy" ...I'm on the fence on this option.

Another option is to buy a new cluster housing meant for my model year, then fit the new set of chrome rings I have lying around. However, the dreaded white spots occurring sometime down the line, is a possibility ... due to the humidity factor (I'm located in a tropical country)...also notwithstanding always having 3 packs of dehumidifiers inside the car, which is always garaged (roofed) + a car cover
Chicky is offline  
post #15 of 42 (permalink) Old 05-01-2019, 01:36 AM Thread Starter
BenzWorld Elite
 
Chicky's Avatar
 
Date registered: Apr 2007
Vehicle: 1991 R129 500SL
Location: Manila, Philippines
Posts: 1,698
Mentioned: 1 Post(s)
Quoted: 100 Post(s)
(Thread Starter)
Talking

Just wanted to update on the status of this:

I just got back today, the cluster housing and cracked clear lens (which by the way, there is no sure fire way of removing from the cluster housing without cracking the lens, due to being fuse-welded into place )

This coming weekend, I'll try roadhouse's method and will report back on the results + pics

So as off today, here are my options:
A. Buy a new R129 instrument cluster housing, meaning $$$...but I fear that it will eventually get the
same dreaded white spots in the future, being located in a tropical country and having high humidity.
B. Buy the Silver Arrow cluster housing, meaning $$$$...but I still fear that it will also have the dreaded
white spots on the black portion of the cluster housing.
C. "Hoping and praying" roadhouse's methods will work out (and I really hope it does )
D. Don't make an issue of the white spots and disregard ...but being O/C...really hard
Chicky is offline  
post #16 of 42 (permalink) Old 05-01-2019, 01:21 PM
BenzWorld Senior Member
 
Date registered: May 2007
Vehicle: M113 SL500
Location: USA
Posts: 443
Mentioned: 1 Post(s)
Quoted: 156 Post(s)
Since you already have a broken cluster front housing, maybe you can experiment with some thin lexan? I've never tried forming a piece of lexan, but I think a thin sheet would be pretty easy with a heat gun. Then seal it with silicone. Holes can be drilled with light pressure and slow speed to prevent cracking.
brauhaus is offline  
post #17 of 42 (permalink) Old 05-01-2019, 02:16 PM Thread Starter
BenzWorld Elite
 
Chicky's Avatar
 
Date registered: Apr 2007
Vehicle: 1991 R129 500SL
Location: Manila, Philippines
Posts: 1,698
Mentioned: 1 Post(s)
Quoted: 100 Post(s)
(Thread Starter)
Smile

Quote:
Originally Posted by brauhaus View Post
Since you already have a broken cluster front housing, maybe you can experiment with some thin lexan? I've never tried forming a piece of lexan, but I think a thin sheet would be pretty easy with a heat gun. Then seal it with silicone. Holes can be drilled with light pressure and slow speed to prevent cracking.
Hi brauhaus,

The broken clear lens was from my "experimental" cluster housing that I wanted to practice on...before trying to remove my car's original cluster lens.

But you do have a good option there. I haven't tried "g" regarding Lexan and searching if they have a thin (as in 2 or 3mm thick) clear polycarbonate sheets.

Thank you for your suggestion.
Chicky is offline  
post #18 of 42 (permalink) Old 05-02-2019, 12:30 AM
BenzWorld Member
 
ChipThome's Avatar
 
Date registered: Apr 2019
Vehicle: 1995 and 1996 SL320 One Keeper One For Sale
Location: Green Bay, WI 54301
Posts: 154
Mentioned: 1 Post(s)
Quoted: 43 Post(s)
It looks like the hot trend on customizing one's car is wrapping it. Would maybe getting the black face wrapped in a matte black do anything to solve you dreaded white spotting?
ChipThome is online now  
post #19 of 42 (permalink) Old 05-02-2019, 02:15 AM
BenzWorld Member
 
BAHRAINI AMG's Avatar
 
Date registered: Oct 2012
Vehicle: 1999 SL500
Location: Bahrain
Posts: 147
Mentioned: 0 Post(s)
Quoted: 40 Post(s)
Well, I just thought I should share my experience with regards to instrument clusters.

I recently bought a Euro instrument cluster from a friend, this cluster came off a 1998 W140.
I own a 1999 US spec R129.

So naturally, I thought a direct swap would work just fine, understanding very well that my car will display a different odometer reading as the W140 had a lower mileage.

Well, a direct swap didn't work, all the dials worked, however, the LCD display did not.
My electronics guy tried checking all cables and components, nothing was out of the ordinary.

So my guess is, cluster swap is possible but odometer display will not work.

Thought I should share this info in case someone asks.

Now, coming to your issue, if you require parts for your cluster, I have them.

The only parts I used from the W140 cluster were the dial faces. Everything else is in good condition if you're interested.

2016 Lexus GSF
1999 Mercedes Benz SL500
1993 Dodge Viper RT/10
BAHRAINI AMG is offline  
post #20 of 42 (permalink) Old 05-02-2019, 07:10 AM
One of the BW Old Guard
 
Ears's Avatar
 
Date registered: Aug 2004
Vehicle: 1997 SL500- 40th Anniversary
Location: Fort Payne, Al
Posts: 7,056
Mentioned: 9 Post(s)
Quoted: 500 Post(s)
Lifetime Premium Member
Also, be advised the w140 cluster will not have the roll bar MIL, etc. this doesn’t matter if all you want is the bezel. I have heard SDS may be able to marry cluster so LCD might come back. Strictly speculation.
A Specialist is needed to “change” mileage with caveats of potential disaster... o understand the chip set has to be harvested and swapped.

Best Regards...

RM Smith
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

Where is it again that we are going... And why are we in a handbasket?
Ears is offline  
Sponsored Links
Advertisement
 
Reply

  Mercedes-Benz Forum > Mercedes-Benz Roadster Forums > R129 SL-Class

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Mercedes-Benz Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in











Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Topic Author Forum Replies Last Post
instrument cluster stopped working now trouble code P0700 Tyrone Williams W163 M-Class 23 08-23-2016 09:50 PM
ML320 Instrument Cluster replacement Dave0r W163 M-Class 4 11-09-2015 11:04 AM
94 c220 diesel instrument cluster problem!. gudikcik W202 C-Class 3 04-17-2011 01:22 PM
W201 Instrument Cluster Removal Instructions raed_jan W201 190-Class 18 06-20-2009 07:23 PM
'CAN' instrument cluster fault darraghodonnell R129 SL-Class 9 04-30-2009 03:57 PM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 

Title goes here

close
video goes here
description goes here. Read Full Story
For the best viewing experience please update your browser to Google Chrome