ASR/ABS Lights - Mercedes-Benz Forum
Reply
 
LinkBack Thread Tools Display Modes
post #1 of 17 (permalink) Old 01-29-2007, 08:20 AM Thread Starter
BenzWorld Member
 
Date registered: Dec 2006
Posts: 65
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
(Thread Starter)
ASR/ABS Lights

I'm having a problem with the ABS/ASR lights staying on when I first start my 94 320SL. Mechanic said that it was a problem with the speed sensors. Replace both front sensors. Lights still come on. When the car warms up however and I turn the car off and re-start it, they stay off. They never go off by them selves after the car reaches operating temperature. I'm told that the electronics on the 129 are sensative to the cold. Has anyone else had this problem? Could it be because of the cold in NJ or a wiring harness issue or other. The SRS light also stays on for about 2-3 minutes but does go out.
Any thoughs from others is appreciated.
royvan is offline  
Sponsored Links
Advertisement
 
post #2 of 17 (permalink) Old 01-30-2007, 01:56 AM
BenzWorld Member
 
Date registered: Dec 2006
Vehicle: 300SL (103)
Location: London
Posts: 104
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
If the batery has been disconnected or run flat these two lights stay on, even when there's no problem in the system. A merc dealer or speciallist should be able to reset them. I had the same problem when I bought a 1991 R129 a couple of weeks ago. It had been left standing over the Christmas and new year break and the TOAD had flattened the battery. It was taken to a merc specialist who reset the system. Batteries are definately sensitive to cold.

I gather there are sometimes problems with the wiring loom on the 93s and 94s chafing and causing wear that results in shorts, although I've not heard any stories about the loom being sensitive to cold.

Hope this helps.
Dr.DJC is offline  
post #3 of 17 (permalink) Old 01-30-2007, 02:12 AM
Outstanding Contributor
 
Date registered: Jan 2004
Vehicle: '03 SL500, '03 SL55, '97 SL320, (2) '91 300SL, (2) '91 500SL, '00 S500 -- all for sale
Location: Atlanta, USA
Posts: 3,961
Mentioned: 12 Post(s)
Quoted: 559 Post(s)
Quote:
Originally Posted by royvan
Any thoughs from others is appreciated.
Read codes with an LED. If you need help with that, you can send me an email.
bobterry99 is offline  
Sponsored Links
Advertisement
 
post #4 of 17 (permalink) Old 01-30-2007, 05:33 AM Thread Starter
BenzWorld Member
 
Date registered: Dec 2006
Posts: 65
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
(Thread Starter)
Code Reading

Thanks Bob for the offer. I've made a code reader based on the information I've
gleened from the forum. My car only has the 16 pin socket. Both light come on at the same time which leads me to believe it might be a short or something. As I wrote, when the car is cold the lights come on until it warms up. Then, if I turn it off and restart, they go off. They never go off unless I restart. What codes and what socket could I test to see if there is a trouble fault? Also, in using the LED do you hold the button and keep the light on 2-4 seconds or release it to get the fault to light.
I have disconnected the battery to try to clear the fault. Should I try that again?
Thanks for your help.
Roy
royvan is offline  
post #5 of 17 (permalink) Old 01-30-2007, 06:16 PM
Outstanding Contributor
 
Date registered: Jan 2004
Vehicle: '03 SL500, '03 SL55, '97 SL320, (2) '91 300SL, (2) '91 500SL, '00 S500 -- all for sale
Location: Atlanta, USA
Posts: 3,961
Mentioned: 12 Post(s)
Quoted: 559 Post(s)
Quote:
Originally Posted by royvan
Also, in using the LED do you hold the button and keep the light on 2-4 seconds or release it to get the fault to light.
Yes.

Quote:
Originally Posted by royvan
I have disconnected the battery to try to clear the fault. Should I try that again?
I don't believe this can help. But it can't hurt.

Roy, if your car has a 16-socket connector I don't believe you can read codes for the ASR/ABS. But the info I has shows that you should have the round 31-socket connector...

If you send me an email, I can reply with a very basic listing of the codes. But I recommend that you purchase the R129 Tech DVD from MBUSA for about $75 (1-800-FOR-MERC). If that's more than you want to spend, I suggest the Mercedes WIS software that you can buy on eBay for about $15 shipped.
bobterry99 is offline  
post #6 of 17 (permalink) Old 01-30-2007, 06:51 PM
BenzWorld Member
 
Date registered: Apr 2006
Posts: 77
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
i have the same problem... some times i get abs /asr lights on and i need to restart the car to reset it.. it doesn't clear it self ... i think the problem related to the battery voltage and connection..if you got low voltage u get the lights on and need to restart the car to reset it. check the positive plug ont the battery there is a red wire ,,make sure it is connected to the plug and free of carbon..
feras is offline  
post #7 of 17 (permalink) Old 01-31-2007, 03:59 AM
BenzWorld Member
 
Bawbag's Avatar
 
Date registered: Nov 2005
Vehicle: sl-500
Location: cornwall
Posts: 153
Mentioned: 0 Post(s)
Quoted: 2 Post(s)
Send a message via Yahoo to Bawbag
Brake switch

Could be a faulty brake switch, in the drivers area just above the brake pedal,
I replaced mine and have never had a problem since with the abs/asr light staying on, it is a bitch to get at though....

If all else fails, there is always the golf course
Bawbag is offline  
post #8 of 17 (permalink) Old 01-31-2007, 07:27 AM Thread Starter
BenzWorld Member
 
Date registered: Dec 2006
Posts: 65
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
(Thread Starter)
Abs/asr

I've read about the brake switch but wondered why the light still comes on without even depressing the brake. I'll try a voltage check and cleaning the contacts. Also, Bob's suggestion about the DVD is good. My car does not have the 32 pin socket. It's a 1994 320 SL and only have a 16 pin socket. Having the sockets locations and fault codes will help. Hope it warms up on NJ soon so I can get this baby straightened out.
royvan is offline  
post #9 of 17 (permalink) Old 01-31-2007, 08:04 AM Thread Starter
BenzWorld Member
 
Date registered: Dec 2006
Posts: 65
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
(Thread Starter)
Asr/abs

Bob,
I tried to send you a personal e-mail but, your message box is full. I would appreciate getting the codes. I'm not sure that I'm using the reader correctly. When I press the button on it I get a light on all sockets. Do you have to release the button after you get the light for the code to appear?
Seems funny also that the brake light would be the problem since the light comes on even though I don't depress the brake peddle.
royvan is offline  
post #10 of 17 (permalink) Old 01-31-2007, 01:03 PM
Outstanding Contributor
 
Date registered: Jan 2004
Vehicle: '03 SL500, '03 SL55, '97 SL320, (2) '91 300SL, (2) '91 500SL, '00 S500 -- all for sale
Location: Atlanta, USA
Posts: 3,961
Mentioned: 12 Post(s)
Quoted: 559 Post(s)
Roy --

Send me an email -- not a PM -- an email. Then I can reply to you with an attachment.
bobterry99 is offline  
Sponsored Links
Advertisement
 
Reply

  Mercedes-Benz Forum > Mercedes-Benz Roadster Forums > R129 SL-Class

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Mercedes-Benz Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in











Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Topic Author Forum Replies Last Post
OK! New problem! Just fixed the asr light, today, both the asr and the abs lights has come on! Cabbe W140 S-Class 23 04-12-2015 10:13 PM
ASR and ABS Lights stays on?!? Morpheus W140 S-Class 4 06-15-2006 09:36 PM
asr abs lights vrod1495 R170 SLK-Class 1 04-12-2006 10:02 PM
ABS & ASR Lights ON babsoginni W202 C-Class 1 08-11-2005 03:01 PM
Please help ABS/ASR Lights!!!! Kambosoup978 C208/A208 CLK-Class 18 08-05-2005 02:45 PM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 

Title goes here

close
video goes here
description goes here. Read Full Story
For the best viewing experience please update your browser to Google Chrome