Please help with resetting soft top controller - Page 6 - Mercedes-Benz Forum
Reply
 
LinkBack Thread Tools Display Modes
post #51 of 57 (permalink) Old 04-09-2019, 09:04 AM
BenzWorld Member
 
Date registered: Sep 2006
Vehicle: '07 S600, '00 E320 Wagon, other
Location: Tampa Bay, FL
Posts: 179
Mentioned: 1 Post(s)
Quoted: 19 Post(s)
1996 both windows stopped working

Hi, a great thread so here is another related problem. 1996 SL600 (hall sensors not microswitches so no controller resets with paper clips/LEDs like older models). In for a top replacement. Everything works perfectly. The top is down and windows are down. Battery disconnected/reconnected and top being raised (incorrectly) without windows normalization - of course the top goes up only to a vertical position. Manually pushed further and cloth of the top is removed.

Now both windows do not respond to windows up/down switches.

- STAR fault readout shows only that both windows are not normalized. All faults reset. No change
- Fuse 5 in trunk OK (covers windows and central locking, central locking works)

How to otherwise reset the RST/RV controller in addition to fault clearing? STAR actuation menu only shows the roll bar, am I missing the explicit RST/RV reset somewhere?

What would be a next step to diagnose? Note that the battery was being disconnect/reconnect before without problems, so blaming it for the RST/RV controller failure may be premature. Also (albeit incorrectly) the top was operated without windows normalized before without problems.

How to determine if the RST controller is good or faulty before jumping to replacing it? Any other ideas? Please help!! Thanks
George993 is offline  
Sponsored Links
Advertisement
 
post #52 of 57 (permalink) Old 04-09-2019, 09:29 AM
BenzWorld Member
 
Date registered: Sep 2006
Vehicle: '07 S600, '00 E320 Wagon, other
Location: Tampa Bay, FL
Posts: 179
Mentioned: 1 Post(s)
Quoted: 19 Post(s)
Additional information (may or may not be relevant) - roll bar is down, top switch illuminated red, and Anti Theft Control Module (ATA) faults can not be reset. No idea is there is any link between ATA and windows/RST/RV controller
George993 is offline  
post #53 of 57 (permalink) Old 04-09-2019, 10:24 AM
BenzWorld Member
 
Date registered: Sep 2006
Vehicle: '07 S600, '00 E320 Wagon, other
Location: Tampa Bay, FL
Posts: 179
Mentioned: 1 Post(s)
Quoted: 19 Post(s)
And the battery (often a problem in cases like this) is good 13V
George993 is offline  
Sponsored Links
Advertisement
 
post #54 of 57 (permalink) Old 04-10-2019, 06:31 PM
Outstanding Contributor
 
Date registered: Jan 2004
Vehicle: '03 SL500, '03 SL55, '97 SL320, (2) '91 300SL, (2) '91 500SL, '00 S500 -- all for sale
Location: Atlanta, USA
Posts: 3,960
Mentioned: 12 Post(s)
Quoted: 559 Post(s)
There is no "reset" of the RST controller of which I am aware. Of course, removing its source of power would cause it's software to reboot.

Look at the RST controller's "Actual Values" to see if the status of the window control switches are being read. If they are, the trunk fuses which power the windows are good, and you have no codes, then I would suspect the RST controller.

The windows can not be actuated from HHTWIN.
bobterry99 is offline  
post #55 of 57 (permalink) Old 04-12-2019, 06:44 AM
BenzWorld Veteran
 
Date registered: Feb 2010
Vehicle: 96 sl600,97 s420(gone) 96 CL600
Location: Near Allentown Pa. USA
Posts: 600
Mentioned: 7 Post(s)
Quoted: 167 Post(s)
For what its worth, after a recent dead battery on my 96 I had top light and roll bar light illuminated. Scanned with SDS and cleared faults, reset windows, reset steering sensor etc. no change. What worked was disconnecting the battery for a few minutes and reconnecting. It apparently does "reboot" the controller.
FATHERTIME likes this.
glepore is offline  
post #56 of 57 (permalink) Old 04-13-2019, 08:40 AM
BenzWorld Member
 
Date registered: Sep 2006
Vehicle: '07 S600, '00 E320 Wagon, other
Location: Tampa Bay, FL
Posts: 179
Mentioned: 1 Post(s)
Quoted: 19 Post(s)
Thank you guys, I've disconnect the battery a few times, for short period of time and overnight. Same results in both cases. (No change). I think the status is being read, I'll double check. Also the big red top switch causes the latches to click when engaged, so something is working, but the top is not moving.
George993 is offline  
post #57 of 57 (permalink) Old 05-23-2019, 09:03 AM
BenzWorld Member
 
Date registered: Sep 2006
Vehicle: '07 S600, '00 E320 Wagon, other
Location: Tampa Bay, FL
Posts: 179
Mentioned: 1 Post(s)
Quoted: 19 Post(s)
Problem solved. Windows and the top are working fine. The way to fix the non-responsive controller (and non-working windows and non-working top) was to manually put up the convertible top and manually lock all the latches properly.

When the controller received some conflicting information from the latches/switches which were not closed/open in a way which made sense to it, the controller just froze and did nothing.

Once the feedback from latches/switches started making sense to it, it started operating again. This is 1996 btw.
FATHERTIME likes this.
George993 is offline  
Sponsored Links
Advertisement
 
Reply

  Mercedes-Benz Forum > Mercedes-Benz Roadster Forums > R129 SL-Class

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Mercedes-Benz Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in











Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Topic Author Forum Replies Last Post
1997 Soft top controller problem DuckZilla R129 SL-Class 4 07-10-2010 06:35 PM
Soft Top Controller Question alydon R129 SL-Class 3 12-02-2008 10:56 AM
99 R129 soft top possible controller issue? msc R129 SL-Class 1 05-15-2008 07:08 PM
Using windows without the soft top controller unit on a 1991? STEPH R129 R129 SL-Class 18 03-31-2008 03:06 PM
need help erasing soft top controller codes arjan R129 SL-Class 2 05-25-2007 04:23 PM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 

Title goes here

close
video goes here
description goes here. Read Full Story
For the best viewing experience please update your browser to Google Chrome