1979 450 having issues starting it - Mercedes-Benz Forum
 
LinkBack Thread Tools Display Modes
post #1 of 3 (permalink) Old 08-07-2019, 07:17 PM Thread Starter
BenzWorld Newbie
 
Date registered: Apr 2019
Posts: 2
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
(Thread Starter)
1979 450 having issues starting it

I'm not sure if I should start with fuel pumps,fuel distributor,injectors or? I bought the car running but ran rough. It's sat for 6 months and I got it to start but wouldn't idle but would spit n sputter on the pedal. I have another one and I was told fuel distributor was faulty and I had it rebuilt and that car runs fine. I just don't want to start throwing parts without an idea on how to go thru and figure out what may be the problem part. Any ideas on a path to take to check fuel system? Thanks in advance for your help!
Steve Erwin is offline  
Sponsored Links
Advertisement
 
post #2 of 3 (permalink) Old Today, 02:55 PM
BenzWorld Veteran
 
miko1aj's Avatar
 
Date registered: Sep 2012
Vehicle: '79 450SL, '04 CLK200 convertible; former A124, W210, A209.
Location: Galway, Ireland
Posts: 607
Mentioned: 4 Post(s)
Quoted: 110 Post(s)
Garage
Hi Steve, agree with you that the shotgun approach is not the most effective approach - you need to diagnose what's wrong first. I also have a 79 450SL and have had similar issues, cut the long story short in my case it was thermotime. Switch which was flooding the engine due to excessive fuel from the cold start valve.

It could be something else with your car though, and I'd encourage you to review the Encyclopaedia Germanica for R107 which has fantastic troubleshooting guides; it's a sticky on the main page. Have a look and let us know your thoughts.
miko1aj is offline  
post #3 of 3 (permalink) Old Today, 07:23 PM
BenzWorld Elite
 
Djenka018's Avatar
 
Date registered: Jan 2005
Vehicle: '80 450SLC Afro RHD Ikonengold
Location: ɹǝpu∩ uʍop 'ʎǝupʎS
Posts: 2,697
Mentioned: 2 Post(s)
Quoted: 131 Post(s)
I would start with vacuum checks, ignition reliability and fuel pressure tests in any case of undiagnosed start/run issues.
When you can confirm spark is there uninterrupted, blue in colour and that fuel.pressures are correct for the run condition,
Djenka018 is online now  
Sponsored Links
Advertisement
 
Reply

  Mercedes-Benz Forum > Mercedes-Benz Roadster Forums > R/C107 SL/SLC Class

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Mercedes-Benz Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in











Currently Active Users Viewing This Thread: 3 (2 members and 1 guests)
Troglodyte , Djenka018
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 

Title goes here

close
video goes here
description goes here. Read Full Story
For the best viewing experience please update your browser to Google Chrome